SHB: Overlapping SHB and SMS pre-paid amount notification after receiving SMS

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gwagner, Assigned: mikehenrty)

Tracking

unspecified
2.1 S7 (24Oct)
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8504172 [details]
2014-10-13-10-43-44.png

STR on 2.1 build from yesterday
Have pre-paid sim card with remaining amount notification and idle phone with screen off.
Receive SMS, unlock the screen.
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Whiteboard: [systemsfe]
Blocks: 1077579
I'll take a look.
Assignee: nobody → mhenretty
broken functionality and poor user experience
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S7 (24Oct)
(Reporter)

Comment 4

3 years ago
I found another one that might have the same cause. Please file a followup if its different:
Add an additional language to your keyboard.
Long press the select-language key on the keyboard.

The OK button is hidden behind the SHB.
(In reply to Gregor Wagner [:gwagner] from comment #4)
> I found another one that might have the same cause. Please file a followup
> if its different:
> Add an additional language to your keyboard.
> Long press the select-language key on the keyboard.
> 
> The OK button is hidden behind the SHB.

This is a completely separate bug, and is easier to fix. I've filed bug 1082885 for that issue, and will fix it there.
Created attachment 8505938 [details] [review]
[Gaia PR] trigger system-resize on screen unlock
Attachment #8505938 - Flags: review?(alive)
Comment on attachment 8505938 [details] [review]
[Gaia PR] trigger system-resize on screen unlock

r=me
Attachment #8505938 - Flags: review?(alive) → review+
Duplicate of this bug: 1083726
master: https://github.com/mozilla-b2g/gaia/commit/bd0f6cc1f0386b05416733161093aefc91557ce0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8505938 [details] [review]
[Gaia PR] trigger system-resize on screen unlock

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
It is likely this has always been an issue.

[User impact] if declined:
Poor experience for users with pre-paid sims that send class 0 alerts for expenditures.

[Testing completed]:
Manual test, and new integration test.

[Risk to taking this patch] (and alternatives if risky):
This patch is riskier than it seems to be honest, because we now propagate an event system wide that causes all the layout managers to resize themselves when the lockscreen is unlocked. However, this patch is important because ALL app windows were an improper size when unlocking the phone (pieces were hidden by the software home button). This should fix a bunch of bugs we haven't noticed yet.

[String changes made]: none
Attachment #8505938 - Flags: approval-gaia-v2.1?
Duplicate of this bug: 1084671
Attachment #8505938 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Flags: in-testsuite+
Blocks: 1085593
v2.1: https://github.com/mozilla-b2g/gaia/commit/80c7990cd3eb2c2824977ca196ed06e7723ee662
status-b2g-v2.1: affected → fixed
Unable to verify as we do not have access to a SIM on a pre-paid account that allows for data expenditure alerts.
QA Whiteboard: [QAnalyst-Triage?][qanalyst-verify]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][qanalyst-verify] → [QAnalyst-Triage+][qanalyst-verify]
Flags: needinfo?(ktucker)
Michael: From TBPL log & GitHub history your patch used a file only exists in v2.2 (master) so now every time Gaia-Try try to run the test:

    software_home_app_dialog_lockscreen_resize_test.js

In 2.1, it would report:

    Error: Cannot find module './lib/lockscreen.js'

Log example:

    https://tbpl.mozilla.org/php/getParsedLog.php?id=50963854&tree=Gaia-Try

And the root cause is here:

    https://github.com/mozilla-b2g/gaia/commit/80c7990cd3eb2c2824977ca196ed06e7723ee662#diff-c57d1732e1e0d3ab00a93443fb44bc61R4

Please consider to fix the v2.1 patch and use different solution for these two patches. Or, if you want, you can fire another bug to check the library in v2.1, but this of course need an approval, and maybe modify the library for v2.1.

And I don't know what's your convention here: we usually submit two different patches for master and v2.1, and would not merge master patch into v2.1 without any modification. However from the patch you submitted here, it looks like you only submit one patch and merge it into both master and v2.1. I think this is risky because of the possible errors would occur, just like this case. I'm also surprised that Fabrice gave the approval, but since I'm not release management team so maybe this is legal to do that.

Also I'm surprised that your commit shows the error should occur since 10/20, but I seems the first person found the error. I'm not blaming you (because as an unfortunate untitled owner of LockScreen "module", I should find it earlier), but I think this is another instance that b2g-inbound hide Gij tests may be not a good idea, since we now have a clear error in our tree lasts 7 days.
Flags: needinfo?(mhenretty)
Please do not uplift this to 2.1 - it would cause a regression in bug 1085593.
Hi Greg, thanks for raising this issue. Integration tests have indeed been failing for a while on the 2.1 and for a couple of reasons. Alberto opened meta bug 1088675 to track this. b2g-inbound actually uses master, so mozilla-b2g34_v2_1 [1] instead is where these tests have been failing.

In this case, I think it just makes sense to port the libraries. Alberto is also working on this in bug 1088623.

1.) https://treeherder.mozilla.org/ui/#/jobs?repo=mozilla-b2g34_v2_1
Flags: needinfo?(mhenretty)
(In reply to Milan Sreckovic [:milan] from comment #15)
> Please do not uplift this to 2.1 - it would cause a regression in bug
> 1085593.

This bug was uplifted to v2.1 about a week ago. I do not think this bug caused bug 1085593. Looking at the video there [1], it looks like this bug actually revealed an underlying graphics issue. Let's wait for the investigation there, and if it turns out to be a bug in this code (or we can fix this more easily in gaia), we can revisit the solution here.

1.) https://www.youtube.com/watch?v=ZtJqGx6fX8I
(In reply to Michael Henretty [:mhenretty] from comment #17)
> (In reply to Milan Sreckovic [:milan] from comment #15)
> > Please do not uplift this to 2.1 - it would cause a regression in bug
> > 1085593.
> 
> This bug was uplifted to v2.1 about a week ago. ...

What's comment 14 all about then? This caused a visual regression (doesn't really matter if it's exposing another bug or introducing a bug, the problem can be tied to landing this), and there are some unresolved issues mentioned in comment 14?
(In reply to Milan Sreckovic [:milan] from comment #18)
> (In reply to Michael Henretty [:mhenretty] from comment #17)
> > (In reply to Milan Sreckovic [:milan] from comment #15)
> > > Please do not uplift this to 2.1 - it would cause a regression in bug
> > > 1085593.
> > 
> > This bug was uplifted to v2.1 about a week ago. ...
> 
> What's comment 14 all about then? This caused a visual regression (doesn't
> really matter if it's exposing another bug or introducing a bug, the problem
> can be tied to landing this), and there are some unresolved issues mentioned
> in comment 14?

Comment 14 is about Gij tests failing on treeherder v2.1 [1]. However, as comment 16 mentions, our tests have been failing there for quite awhile, and probably pre-dated this landing. In any case, nobody has been looking at that branch until recently and there are a number of different problems there. We have meta bug 1088675 to track those problems, and bug 1088623 to address the specific problem mentioned in comment 14. This bug was fixed in 2.1, so comment 14 has been addressed and is separate from the visual regression in bug 1085593.

1.) https://treeherder.mozilla.org/ui/#/jobs?repo=mozilla-b2g34_v2_1https://treeherder.mozilla.org/ui/#/jobs?repo=mozilla-b2g34_v2_1
Depends on: 1088623
QA Whiteboard: [QAnalyst-Triage+][qanalyst-verify] → [QAnalyst-Triage+][QAnalyst-verify-]
Depends on: 1069608
You need to log in before you can comment on or make changes to this bug.