[FEATURE]UI: Standalone message window

VERIFIED FIXED in M16

Status

defect
P1
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] (beta2 = 1 week))

(Assignee)

Description

20 years ago
bug tracking feature in Summary.
(Assignee)

Updated

20 years ago
Blocks: 10791
Target Milestone: M10
(Assignee)

Updated

20 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 1

20 years ago
Moving to M11 as discussed with Alec

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Target Milestone: M11 → M15

Comment 2

20 years ago
M15

Comment 3

20 years ago
*** Bug 23570 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
*** Bug 24481 has been marked as a duplicate of this bug. ***

Comment 5

20 years ago
*** Bug 26227 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Keywords: 4xp

Updated

20 years ago
Target Milestone: M15 → M17

Comment 6

20 years ago
Is View Source for mail messages part of this bug, or should I file a new one?

Comment 7

20 years ago
seperate bug please
not sure who to assign it to... rhp maybe?

Comment 8

20 years ago
*** Bug 27904 has been marked as a duplicate of this bug. ***

Comment 9

20 years ago
I take it this also covers the 2-pane window, since that bug was marked a dup of
this one?

Comment 10

20 years ago
*** Bug 27904 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Keywords: dogfood
Whiteboard: [PDT-]
Moving DOGFOOD and PDT- over from DUP (because it's dogfood for me, too).

Updated

20 years ago
Depends on: 28239

Updated

20 years ago
Blocks: 6567

Comment 12

19 years ago
It looks like the backend for this is done: I can open an attachment with MIME
type message/rfc822, e.g.,

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=6062

in a browser window.  Isn't that all there is to this bug? The front end (double
click opens in new window) is bug 28239.

Comment 13

19 years ago
no there's more to it. We want to display messenger-specific chrome on such
messages so that you can do stuff like forward the message, etc. Also, if the
message came from a mail store like mailbox: imap:, or news:, we want to be able
to delete/cancel the message, move it somehwere, etc.

Comment 14

19 years ago
*** Bug 30440 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
*** Bug 31162 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Priority: P3 → P1

Updated

19 years ago
QA Contact: lchiang → nbaca

Comment 16

19 years ago
*** Bug 32160 has been marked as a duplicate of this bug. ***

Comment 17

19 years ago
reassign to putterman he wants it.
this is a feature bug, but I don't see it on the beta2 schedule.
Assignee: alecf → putterman
Status: ASSIGNED → NEW
i reiterate that this is pretty serious dogfood for me, for whatever it's worth.
(Assignee)

Comment 19

19 years ago
this is a high priority.  marking M16 because I don't know if I can finish it in
time for M15.  If you have other high priorities, we have a thread in the
mail-news newsgroup asking for opinions on this.
Target Milestone: M17 → M16

Comment 20

19 years ago
Sol, Scott had a great idea.  Let's just open up a normal mail window but move
all the splitters to the borders of the window.  This gives the standalone
appearance and saves a lot of work.  In addition, we get the new feature that
you can use the splitters for navigation :-)

Added 2 day estimate based on this implementation.  Please update the estimate
if the plan changes.
Whiteboard: [PDT-] → [PDT-] (beta2 = 2 days)

Updated

19 years ago
Whiteboard: [PDT-] (beta2 = 2 days) → [PDT-] (beta2 = 1 week)

Comment 21

19 years ago
updating estimate to 1 week.  Scott asked some representative users and
discovered that the main feature of standalone is that it must come up quickly.
He's working on a plan to make that happen.

Updated

19 years ago
Summary: [FEATURE] Standalone message window → [FEATURE]UI: Standalone message window

Comment 22

19 years ago
*** Bug 33978 has been marked as a duplicate of this bug. ***

Comment 23

19 years ago
bulk move to M16 per selmer.
(Assignee)

Comment 24

19 years ago
this is in.  You have to double click to open it up.  There are various things 
not working in that window and we should file individual bugs to track those, 
but the actual feature is there and able to display a message in a separate 
window.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Verified on Linux modulo bugs.
{{{ KISS }}}}

Comment 27

19 years ago
Verified Fixed on NT4 and Mac 8.5.1 too.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.