[prefs] can't add languages

VERIFIED FIXED in mozilla0.9.7

Status

defect
P2
normal
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: chado_moz, Assigned: samir_bugzilla)

Tracking

({intl})

Trunk
mozilla0.9.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

18 years ago
reproduce:
 1. Open Preferences | Navigator | Languages.
 2. Click "Add..." button.
 3. Choose any language, then click "OK".

expected result:
 Choosen language appears in "Languages in order..." area.

actual result:
 Choosen language doesn't appear.

reproducible: always.

build:
 mac 2001-11-05-16-trunk and after can't add languages.
 mac 2001-11-01-08-trunk and before can add languages.
 win 2001-11-05-03-trunk and after can't add languages.
 win 2001-11-01-03-trunk and before can add lanfuages.

additional info: 
 I tried to try on win 2001-11-02-09-trunk, 
 but opening pref for lang caused crash. 

theme:
 On both of classic and modern.

Comment 1

18 years ago
I see this as well using Mozilla/2001110603 on Win2000.

However, if I double click on a language instead of pressing OK, then it works 
as expected.
ccing hewitt since this may be fallout from the <dialog> landing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl, polish
Assignee

Comment 3

18 years ago
The call to doSetOKCancel(AddAvailableLanguage) was removed from
pref-languages.js but is not called from anywhere now.  Patch coming up.
Status: NEW → ASSIGNED
Keywords: polish
Assignee

Comment 4

18 years ago
Assignee

Comment 5

18 years ago
hewitt, please r.
blake, please sr.
Keywords: patch, review
Priority: -- → P2
Target Milestone: --- → mozilla0.9.7

Comment 7

18 years ago
Comment on attachment 57870 [details] [diff] [review]
Patch rev 2: *return* AddAvailableLanguage so false is propagated in alert conditions.  Thanks to Blake for pointing this out.

sr=blake
Attachment #57870 - Flags: superreview+
Comment on attachment 57870 [details] [diff] [review]
Patch rev 2: *return* AddAvailableLanguage so false is propagated in alert conditions.  Thanks to Blake for pointing this out.

r=bryner
Attachment #57870 - Flags: review+
Assignee

Comment 9

18 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
*** Bug 110481 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
Did this make it into 0.9.6? bug 111566 and bug 111570 were just filed
*** Bug 111566 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 111668 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 111721 has been marked as a duplicate of this bug. ***
vrfy fixed using 2001.11.28.0x-comm bits on linux rh7.2, mac 10.1.1 and winNT.
Status: RESOLVED → VERIFIED
*** Bug 112594 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
*** Bug 113040 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
*** Bug 113135 has been marked as a duplicate of this bug. ***
*** Bug 113379 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
*** Bug 114417 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
*** Bug 115062 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

5 years ago
No longer blocks: 1111089
You need to log in before you can comment on or make changes to this bug.