Closed Bug 1150025 Opened 5 years ago Closed 5 years ago

[SIM PIN] Rocketbar is available while in a system dialog

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: apastor, Assigned: apastor)

References

Details

(Keywords: polish, Whiteboard: [systemsfe])

Attachments

(5 files, 1 obsolete file)

STR

1.- Start the phone and skip SIM PIN dialogs
2.- Open SMS
3.- Click on the rocketbar and search for Camera
4.- Click on the app suggestion
Rob, what's the expected behavior here? Thanks!
Flags: needinfo?(rmacdonald)
Attached video IMG_5169.m4v (obsolete) —
Attached video IMG_5178.m4v
Attachment #8586787 - Attachment is obsolete: true
blocking-b2g: --- → 2.2?
Blocks: 1150037
No longer blocks: 1150037
Hi Alberto...

Thanks for drawing my attention to this one. The SIM PIN screen here seems to combine the layout of an app with a dialog and might benefit from some layout changes. Jenny is away this week but I'll NI Harly for feedback in the meantime. Either way the rocketbar should not be triggered in this instance.

Rob
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jelee)
Flags: needinfo?(hhsu)
Also, Francis just pointed out that this appears to be a duplicate of bug 1143142.
I see 2 possible ways to deal with this:
1. Block access to rocketbar when SIM PIN screen appears
2. If user tap the rocketbar, system will treat as the user has pressed "Skip", this is similar behaviour when user press home

Personally, I prefer the second methods because there will always be other ways to trigger something when the SIM PIN screen appears, and its hard to lock them all. But that's just my thoughts on this, I will leave it for Jenny to decide.
Flags: needinfo?(hhsu)
Component: Gaia::System::Input Mgmt → Gaia::System::Window Mgmt
Whiteboard: [systemsfs] → [systemsfe]
duplicate of bug that is not blocking. We will fix but not a blocker
blocking-b2g: 2.2? → ---
Keywords: polish
We have a similar issue :  bug 1150834 which just got fixed.


I can't reproduce the other issue of the scren not being full that's shown in the video.
relooking at this bug on master : 
The steps in comment 0 show the rocketbar field, so I think it's actually ok.
If the SIM PIN overlay shows and you tap the rocketbar search will briefly show and then disappear.

There's some weirdness surrounding these bugs and the behavior changed due to the fix in bug 1150834 in MC.
Agree with UX master Harly here ;)!
Flags: needinfo?(jelee)
Assignee: nobody → apastor
Attachment #8593896 - Flags: review?(alive)
Comment on attachment 8593896 [details] [review]
[gaia] albertopq:1150025-dismiss-pin-rocketbar > mozilla-b2g:master

LGTM, thanks!
Attachment #8593896 - Flags: review?(alive) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified with below build

*test env
Build ID               20150423010203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0b202671c9e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.042933
Firmware Date          Thu Apr 23 04:29:45 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
Target Milestone: --- → 2.2 S11 (1may)
Blocks: 1157535
Comment on attachment 8593896 [details] [review]
[gaia] albertopq:1150025-dismiss-pin-rocketbar > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: The SIM dialog stays opened when opening the Utility tray, and that causes some weird behaviors, as the utility tray allows to access new activities as Settings (see bug 1157535). This small patch closes the SIM PIN when opening the tray.
[Testing completed]: Added unit tests. In master for a while.
[Risk to taking this patch] (and alternatives if risky): Just listening to an event, and closing the dialog when it comes. Tests added. Low risk. 
[String changes made]:-
Attachment #8593896 - Flags: approval-gaia-v2.2?(bbajaj)
(In reply to Alberto Pastor [:albertopq] from comment #16)
> Comment on attachment 8593896 [details] [review]
> [gaia] albertopq:1150025-dismiss-pin-rocketbar > mozilla-b2g:master
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): -
> [User impact] if declined: The SIM dialog stays opened when opening the
> Utility tray, and that causes some weird behaviors, as the utility tray
> allows to access new activities as Settings (see bug 1157535). This small
> patch closes the SIM PIN when opening the tray.
> [Testing completed]: Added unit tests. In master for a while.
> [Risk to taking this patch] (and alternatives if risky): Just listening to
> an event, and closing the dialog when it comes. Tests added. Low risk. 
> [String changes made]:-


Sorry, every time I said UtilityTray I meant Rocketbar.
Hi Norry,
qawanted Flame 2.0/2.1 for whether this is regression issue. Thanks!
Flags: needinfo?(fan.luo)
According to the STR of Comment 0, this bug has been successfully verified on latest Flame v2.0&2.1.
Actual results: We can't see the rocketbar after launching SMS in flame v2.0.
We can launch camera app from the rocketbar after we launched SMS and it is works normally in flame v2.1.
See attachment:verified_v2.0.mp4,verified_v2.1.mp4
Device: Flame 2.0 build
Build ID               20150507160203
Gaia Revision          84898cadf28b1a1fcd03b726cff658de470282f0
Gaia Date              2015-04-03 21:42:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e67ed29e8ad0
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.192933
Firmware Date          Thu May  7 19:29:43 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 build
Build ID               20150507161202
Gaia Revision          3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gaia Date              2015-05-07 15:12:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d85173eb5bf4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.194632
Firmware Date          Thu May  7 19:46:42 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo)
Comment on attachment 8593896 [details] [review]
[gaia] albertopq:1150025-dismiss-pin-rocketbar > mozilla-b2g:master

Approving given this impact user experience. 
Also requesting QA verify on 2.2 after patch landed there.
Attachment #8593896 - Flags: approval-gaia-v2.2?(bajaj.bhavana) → approval-gaia-v2.2+
Keywords: verifyme
Have verified with below steps and test env.

*test steps
1 Skip SIM PIN dialogs
2 Open SMS
3 Click on the rocketbar and search for other app (Camera or Calendar)
4 Click on the local app suggestion
5 After step 4, SIM PIN dialog would be skipped and then launch the app clicked at step 4.

*test env
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041644
Firmware Date          Tue May 12 04:16:55 EDT 2015
Bootloader             L1TC000118D0
Per Comment 19 and Comment 25,clear "verifyme".
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.