Closed Bug 116757 Opened 19 years ago Closed 19 years ago

Save page as... Web page, complete doesn't save anything

Categories

(Core Graveyard :: File Handling, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 115216

People

(Reporter: vincent.deconinck, Assigned: adamlock)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

When trying to save that page, nothing gets saved. An directory is created to
store related files, but there's nothing in it, and no html file is created...

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.geocities.com/pratiksolanki/
2. Click File -> Save Page As ... -> (Name) test.html -> (Type) Web Page,
complete -> OK
3. Look at the place where the file should be

Actual Results:  Nothing was saved, except an empty directory named 'test_files'
was created

Expected Results:  An html file should be created, and linked files (images)
should be stored in the created subdir
confirming with win2k build 20011223..

-> File Handling 
(CC Ben who added this feature in bug 11632)
Assignee: asa → law
Status: UNCONFIRMED → NEW
Component: Browser-General → File Handling
Ever confirmed: true
QA Contact: doronr → sairuh
This is most likely Adam's...
Assignee: law → adamlock
*** Bug 117655 has been marked as a duplicate of this bug. ***
also happens on the mach-o build. marking platform "all"
OS: Windows 98 → All
Hardware: PC → All
would this perchance be the same as, or at least related to bug 115181?

when you encounter this bug, do you see the same kind of "no progress" download
progress dialog? screenshot is at
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=61691

if yes, these bugs seem related!
Severity: normal → critical
Well, during the "save" phase, I can indeed see a transient "Saving file..."
dialog similar to the capture you mentioned, but the progress bar quickly jumps
to 100% then it disappears (and my understanding is that it's not the case for
bug 115181). I think the "dialog" behaviour here is normal, but I managed to get
a capture anyway, ask me if it's of any interest.
I wouldn't conclude that bugs are "related" just because of it (they clearly are
not dups), but the last paragraph of the original report for bug 115181 is
indeed exactly what I see : only an empty <name>_files dir with no files
actually saved.
*** Bug 118243 has been marked as a duplicate of this bug. ***
Blocks: 115634
I made the following strange observations:

attachment 63658 [details]: I can't save this page.

attachment 63659 [details]: I can only sometimes save this page. It depends on the
path length! See table below. If I change the content of the file (e.g. remove a
<link ...> line), I have no problems.

Length of "F:\mozilla_source\bug\" = 22  --> column 1
Length of "F:\mozilla_source\bugs\" = 23 --> column 2

 
 |     directory length      |    subdir    whole path
 |     22+     ¦     23+     |
 +-------------+-------------+
 |   1 :  ok   |   1 :  ok   |    1         .
 |   2 :  ok   |   2 :  ok   |    12        .
 |   3 :  ok   |   3 :  bad  |    123       F:\mozilla_source\bug[s]\123\xy.html
 |   4 :  ok   |   4 :  ok   |    1234      .
 |   5 :  ok   |   5 :  ok   |    .         .
 |   6 :  ok   |   6 :  ok   |    .         .
 |   7 :  ok   |   7 :  ok   |    .
 |   8 :  bad  |   8 :  ok   |
 |   9 :  ok   |   9 :  ok   |
 |  10 :  bad  |  10 :  ok   |
 |  11 :  ok   |  11 :  ok   |
 |  12 :  bad  |  12 :  bad  |
 |  13 :  ok   |  13 :  ok   |
 |  14 :  bad  |  14 :  bad  |
 |  15 :  ok   |  15 :  ok   |
 |  16 :  ok   |  16 :  ok   |
 |  17 :  bad  |  17 :  ok   |
 |  18 :  bad  |  18 :  ok   |
 |  19 :  ok   |  19 :  ok   |
 |  20 :  ok   |  20 :  ok   |
 |  21 :  bad  |  21 :  ok   |
 |  22 :  bad  |  22 :  ok   |
 |  23 :  ok   |  23 :  ok   |
 |  24 :  ok   |  24 :  ok   |
 |  25 :  bad  |  25 :  ok   |
 |  26 :  ok   |  26 :  bad  |

I can confirm this bug for Moz 0.9.7 linux build 2001122108 (i686)

The symptoms I get are similar.

A dialog box comes up, but the program does not do anything after that. 
It does not indicate that it is saving anything. A directory is created to store
the files, but it remains empty.

In my case, this occurs for BOTH "complete" and "HTML only" saving options.

I have tried this on simple HTML pages
eg

http://uk.arxiv.org/list/cond-mat/new

which contains only html text.


*** Bug 118537 has been marked as a duplicate of this bug. ***
Another interesting thing is:

- open Derek's link http://uk.arxiv.org/list/cond-mat/new

- right click and choose 'Edit Page in Composer' from Context Menu

- in Composer change anything, e.g. delete a character

- try to save the changes

=> Error Message "Saving file failed" appears...
*** Bug 118709 has been marked as a duplicate of this bug. ***
*** Bug 118929 has been marked as a duplicate of this bug. ***
*** Bug 119001 has been marked as a duplicate of this bug. ***
Depends on: 119146
No longer depends on: 119146
*** Bug 119229 has been marked as a duplicate of this bug. ***
This looks like a dup of bug 115216.

The html source contains a <link> element with a mailto: href and this is
screwing up the persist object because it thinks there is a channel error when
it can't open the mailto: url . A patch is attached to the other bug but will it
have to be updated once 110135 goes in.

*** This bug has been marked as a duplicate of 115216 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
attachment 63658 [details] contains no <link> element! perhaps this is an other bug (for
example bug 117655)
That's covered by bug 119496, which is apparently also fixed by the patch in bug
115216
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.