[First Time Experience] After turning on data in FTU, but Data still displays disabled in settings app.

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: sunny, Assigned: kgrandon)

Tracking

({regression, smoketest})

unspecified
FxOS-S1 (26Jun)
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [v3.0-nexus-5-l][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8624151 [details]
logcat_1552.txt

[1.Description]:
[Flame v3.0][Nexus5 v3.0][First Time Experience] After turning on data in FTU, Data is not highlighted and can't be used.
Time: 15:52
See attachment logcat_1552.txt and 1552.3gp

[2.Testing Steps]: 
1.Launch settings app.
2.Developer >> tap ''Launch First Time Use"
3.Finish FTE.
4.Pull down Notification.
5.Launch settings app and select "Cellular&Data"


[3.Expected Result]: 
4.Data are highlighted.
5.Data should be enabled .

[4.Actual Result]: 
4.Data is not highlighted .
5.Data is disable

[5.Reproduction build]: 
Flame 2.2 version(Unaffected):
Build ID               20150617002504
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.040422
Firmware Date          Wed Jun 17 04:04:34 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150617160207
Gaia Revision          b404c41c5471c31610e64defb74ec066b411e724
Gaia Date              2015-06-17 17:01:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a3f280b6f8d5
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.192003
Firmware Date          Wed Jun 17 19:20:14 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 version(Unaffected):
Build ID               20150617002504
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150617.042332
Firmware Date          Wed Jun 17 04:24:07 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0 version(Affected):
Build ID               20150617160207
Gaia Revision          b404c41c5471c31610e64defb74ec066b411e724
Gaia Date              2015-06-17 17:01:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a3f280b6f8d5
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150617.192258
Firmware Date          Wed Jun 17 19:23:17 EDT 2015
Bootloader             HHZ12f
[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8624152 [details]
1552.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
regression, please help find the window.
Keywords: regression, regressionwindow-wanted
QA Contact: jmercado
The changes for Bug 1174444 seem to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150615161319
Gaia: eecd9d2bb220e10792762fc274c910cb3febbd72
Gecko: 454b81979ce8
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150615184622
Gaia: 4dfe2da502e4370c9670d5bc13a73d22fb37a785
Gecko: 9f468853e6c9
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: eecd9d2bb220e10792762fc274c910cb3febbd72
Gecko: 9f468853e6c9

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 4dfe2da502e4370c9670d5bc13a73d22fb37a785
Gecko: 454b81979ce8

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/eecd9d2bb220e10792762fc274c910cb3febbd72...4dfe2da502e4370c9670d5bc13a73d22fb37a785
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Kevin, can you take a look at this please? This might have been caused by the landing for bug 1174444.
Blocks: 1174444
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
(Assignee)

Comment 5

3 years ago
I broke this, will take a look.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
(Assignee)

Comment 6

3 years ago
Created attachment 8624600 [details] [review]
[Pull Request] Convert click handler to change

Thank you for filing the bug and the regression range. Here is a patch which fixes the issue, though I'd like to try to write a test against this case.
(Assignee)

Comment 7

3 years ago
Comment on attachment 8624600 [details] [review]
[Pull Request] Convert click handler to change

Sam - I think that due to the dom differences, and some recent changes in gaia-switch, it's necessary to listen to the change event, and not the click event. Please take a look when you get a chance.

I also tried for quite a while to get the data connection panel displaying from an integration test, but I didn't have much luck stubbing out everything that IccHelper needs. I would like to write an integration test for this eventually, but for now I think we should land the fix while I work on the test which might be a while.
Attachment #8624600 - Flags: review?(sfoster)
(Reporter)

Updated

3 years ago
See Also: → bug 1139811
Keywords: smoketest
Duplicate of this bug: 1176251
[Blocking Requested - why for this release]:
Functional regression that fails the smoke tests.
blocking-b2g: --- → 3.0?
Whiteboard: [v3.0-nexus-5-l] → [v3.0-nexus-5-l][systemsfe]
Blocks: 1175619
Comment on attachment 8624600 [details] [review]
[Pull Request] Convert click handler to change

Looks good thanks. Seems like with 'click' the checked value gets out of sync and our callback fires before the value is changed? Anyhow, 'change' is the right thing to do. I'll file a bug to do the same for the geolocation switch.
Attachment #8624600 - Flags: review?(sfoster) → review+

Updated

3 years ago
See Also: → bug 1176312
(Assignee)

Comment 11

3 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/4eb81c190cbddf0860877bf36bea096d9d051a38
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 865121

Updated

3 years ago
Duplicate of this bug: 1175406
Keywords: verifyme
Issue appears to be fixed on RC4 Spark build
Results: Enabling Data in FTU turns on Data for device

--------------------------------------------------
Environmental Variables:
Device: Aries 3.0
BuildID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
--------------------------------------------------
Repro: 3/3
(Reporter)

Comment 15

3 years ago
Created attachment 8625423 [details]
verified_v3.0.3gp

According to the STR of Comment 0, this bug has been verified as pass on latest Nightly Flame v3.0 and Nexus5 v3.0.

Actual results: You can find "Data" is highlighted after pulling down Notification and it is enabled when you launch settings app and select "Cellular&Data".
See attachment: verified_v3.0.3gp
Reproduce rate: 0/10

Device: Flame 3.0 build(Pass):
Build ID               20150622160206
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150622.193834
Firmware Date          Mon Jun 22 19:38:45 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 3.0 build(Pass):
Build ID               20150622160206
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150622.235549
Firmware Date          Mon Jun 22 23:56:06 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+] [MGSEI-Triage+]
status-b2g-master: affected → verified
Keywords: verifyme
Target Milestone: --- → FxOS-S1 (26Jun)
blocking-b2g: 2.5? → 2.5+
You need to log in before you can comment on or make changes to this bug.