Closed Bug 1180935 Opened 4 years ago Closed 4 years ago

First few seconds of YouTube video are visually distorted with hardware acceleration on

Categories

(Core :: Audio/Video, defect)

42 Branch
Unspecified
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla43
Tracking Status
firefox41 --- unaffected
firefox42 + verified
firefox43 + verified

People

(Reporter: acomminos, Assigned: jya)

References

Details

(Keywords: regression, reproducible)

Attachments

(6 files, 5 obsolete files)

Steps to reproduce:
- Ensure media.hardware-video-decoding.enabled is true
- Open https://www.youtube.com/watch?v=q6EoRBvdVPQ
- Frequently, the first ~4 seconds of video will appear black and distorted
- After the initial distortion, playing and seeking within the video is fine

about:support info:

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150706030206
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Symantec VIP Access Add-On
Version: 2.0.5.0
Enabled: false
ID: VIP3X@verisign.com

Graphics
--------

Adapter Description: ATI Mobility Radeon HD 3650
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 256
Asynchronous Pan/Zoom: none
Device ID: 0x9591
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17292)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 211717aa
Supports Hardware H264 Decoding: true
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 3650 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150706030206
browser.startup.homepage_override.buildID: 20150706030206
browser.startup.homepage_override.mstone: 42.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a1
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x9591
gfx.driver-init.driverVersion: 8.970.100.1100
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.lastUpdate: 1436219788
media.gmp-eme-adobe.version: 11
media.gmp-gmpopenh264.lastUpdate: 1436219788
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150706030206
media.gmp-manager.lastCheck: 1436219783
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
security.sandbox.content.tempDirSuffix: {d4fab9e4-8724-4171-96f4-aec0f81d2fa6}

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSMIME
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSSL
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSUTIL
Expected minimum version: 3.19.2
Version in use: 3.19.2

Experimental Features
---------------------
A few questions:
1) Was it happening on earlier Nightly builds or did it just start recently?
2) Can you please make sure you're using the latest graphics driver?
3) Can you please check to see if it reproduces on a new Firefox profile?
Flags: needinfo?(acomminos)
(In reply to Anthony Hughes, QA Mentor (:ashughes) [Away until July 20] from comment #1)
> A few questions:
> 1) Was it happening on earlier Nightly builds or did it just start recently?
> 2) Can you please make sure you're using the latest graphics driver?
> 3) Can you please check to see if it reproduces on a new Firefox profile?

1) It just started recently IIRC.
2) Yes, this is with the most recent drivers provided by Lenovo.
3) Yes, it reproduces on a new profile.
Flags: needinfo?(acomminos)
(In reply to Andrew Comminos [:acomminos] from comment #2)
> 1) It just started recently IIRC.
Can you check which Nightly this bug starts in?

> 2) Yes, this is with the most recent drivers provided by Lenovo.
Is it the latest drivers provided by Windows Update or AMD?

> 3) Yes, it reproduces on a new profile.
Thanks, this at least rules out that as an issue.
I am not able to reproduce the issue with the OP video, but I can reproduce it with the following one consistently:
https://www.youtube.com/watch?v=8uaoBTBofto

On the 0:01 till 0:05 seconds, the video is freezed
(In reply to Mikel from comment #4)
> I am not able to reproduce the issue with the OP video, but I can reproduce
> it with the following one consistently:
> https://www.youtube.com/watch?v=8uaoBTBofto
> 
> On the 0:01 till 0:05 seconds, the video is freezed

Can you please check the latest Nightly and verify you're using the latest drivers? If this still reproduces please provide a copy of about:support.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #5)
> (In reply to Mikel from comment #4)
> > I am not able to reproduce the issue with the OP video, but I can reproduce
> > it with the following one consistently:
> > https://www.youtube.com/watch?v=8uaoBTBofto
> > 
> > On the 0:01 till 0:05 seconds, the video is freezed
> 
> Can you please check the latest Nightly and verify you're using the latest
> drivers? If this still reproduces please provide a copy of about:support.

Yes, I am on the latest Nightly and on latest drivers.
Please see the bug I have just opened:
https://bugzilla.mozilla.org/show_bug.cgi?id=1188651

Seems like that media.mediasource.enabled setting is the name of the game for it.
(In reply to Mikel from comment #6)
> Yes, I am on the latest Nightly and on latest drivers.
> Please see the bug I have just opened:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1188651
> 
> Seems like that media.mediasource.enabled setting is the name of the game
> for it.

I'm going to go ahead and dupe your other report as it's easier to track investigation in a single report. If that issue turns out to be different then we can always reopen it later. For now, please provide a copy of your about:support page as requested earlier.
Flags: needinfo?(acomminos)
Andrew can you please confirm that flipping media.mediasource.enabled changes the behaviour of this bug? If so maybe this is an issue with MSE and not Graphics (or maybe both?).
Duplicate of this bug: 1188651
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #8)
> Andrew can you please confirm that flipping media.mediasource.enabled
> changes the behaviour of this bug? If so maybe this is an issue with MSE and
> not Graphics (or maybe both?).

Attaching about:support

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150728030209
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-a52dd14d-c96d-4192-8929-ab8d62150726
Submitted: 2 days ago

All Crash Reports

Extensions
----------

Name: About:about Button
Version: 1.1.2
Enabled: true
ID: about-about@codefisher.org

Name: All Tabs Helper
Version: 0.2.18
Enabled: true
ID: alltabshelper@alltabshelper.org

Name: Cleanest Addon Manager
Version: 7.0.1-signed
Enabled: true
ID: cam@sdrocking.com

Name: Greasemonkey
Version: 3.3beta2
Enabled: true
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: HTTPS-Everywhere
Version: 5.0.7
Enabled: true
ID: https-everywhere@eff.org

Name: Tab Counter
Version: 1.9.9.1-signed
Enabled: true
ID: tabcounter@morac

Name: The Addon Bar (restored)
Version: 3.2.1-signed
Enabled: true
ID: the-addon-bar@GeekInTraining-GiT

Name: uBlock Origin
Version: 1.0.0.0
Enabled: true
ID: uBlock0@raymondhill.net

Name: About sessionstore
Version: 0.32.1-signed
Enabled: false
ID: aboutsessionstore@dt

Name: Adblock Plus
Version: 2.6.10.3970
Enabled: false
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Classic Theme Restorer
Version: 1.3.6beta7
Enabled: false
ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: Disable WebRTC
Version: 1.0.5.1-signed
Enabled: false
ID: jid1-5Fs7iTLscUaZBgwr@jetpack

Name: Disconnect
Version: 3.15.3.1-signed
Enabled: false
ID: 2.0@disconnect.me

Name: DownThemAll!
Version: 2.0.18.1-signed
Enabled: false
ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8}

Name: Element Hiding Helper for Adblock Plus
Version: 1.3.2.1-signed
Enabled: false
ID: elemhidehelper@adblockplus.org

Name: Gecko Profiler
Version: 1.16.3
Enabled: false
ID: jid0-edalmuivkozlouyij0lpdx548bc@jetpack

Name: Ghostery
Version: 5.4.4-beta1
Enabled: false
ID: firefox@ghostery.com

Name: Hola Better Internet
Version: 1.8.816
Enabled: false
ID: jid1-4P0kohSJxU1qGg@jetpack

Name: HTML5 Video Everywhere!
Version: 0.2.38.1-signed
Enabled: false
ID: html5-video-everywhere@lejenome.me

Name: HTML5 YouTube Everywhere
Version: 0.5.7b
Enabled: false
ID: jid1-b2ybw6mPlFZm6Q@jetpack

Name: Karma Blocker
Version: 0.5.1-signed
Enabled: false
ID: kabl@trac.arantius.com

Name: leethax.net extension
Version: 2014.01.23
Enabled: false
ID: leethax@leethax.net

Name: Magic Actions for YouTube™
Version: 6.8.8.5
Enabled: false
ID: jid0-UVAeBCfd34Kk5usS8A1CBiobvM8@jetpack

Name: NewScrollbars (aka NoiaScrollbars)
Version: 1.2.3
Enabled: false
ID: NoiaScrollbars@ArisT2_Noia4dev

Name: NextVid Stopper for YouTube
Version: 1.1.1-signed
Enabled: false
ID: jid1-8tHTvv1Wsu98MQ@jetpack

Name: No Flash
Version: 0.5.0
Enabled: false
ID: jid1-cplLTTY501TB2Q@jetpack

Name: Noise Control
Version: 16
Enabled: false
ID: jid1-hUBct1DNfZQIeQ@jetpack

Name: Open Tabs Next to Current
Version: 1.0.0.1-signed
Enabled: false
ID: opentabsnexttocurrent@sblask

Name: Places Maintenance
Version: 1.3.1-signed
Enabled: false
ID: places-maintenance@bonardo.net

Name: Prevent Tab Overflow
Version: 7.1.1-signed
Enabled: false
ID: noverflow@sdrocking.com

Name: SPDY indicator
Version: 2.2.1-signed
Enabled: false
ID: spdyindicator@chengsun.github.com

Name: Tab Data
Version: 0.5.7
Enabled: false
ID: jid1-4ogjq7MUzAiCOw@jetpack

Name: Tab Mix Plus
Version: 0.4.1.9pre.150703a1
Enabled: false
ID: {dc572301-7619-498c-a57d-39143191b318}

Name: Tab Utilities
Version: 1.6pre21
Enabled: false
ID: tabutils@ithinc.cn

Name: The Fox, Only Better
Version: 1.2
Enabled: false
ID: thefoxonlybetter@quicksaver

Name: uMatrix
Version: 0.9.1.2
Enabled: false
ID: uMatrix@raymondhill.net

Name: Vacuum Places Improved
Version: 1.2.1-signed
Enabled: false
ID: VacuumPlacesImproved@lultimouomo-gmail.com

Name: Video WithOut Flash
Version: 3.1.1.1-signed
Enabled: false
ID: vwof@drev.com

Name: Yet Another Remove It Permanently
Version: 0.3.4.1-signed
Enabled: false
ID: yarip@mozdev.org

Name: YouTube Center Developer Build
Version: 531
Enabled: false
ID: jid1-cwbvBTE216jjpg@jetpack

Name: YouTube Flash Video Player
Version: 38.0-signed
Enabled: false
ID: {f3bd3dd2-2888-44c5-91a2-2caeb33fb898}

Graphics
--------

Adapter Description: NVIDIA GeForce GTX 660 Ti
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Asynchronous Pan/Zoom: wheel input enabled
Device ID: 0x1183
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17795)
Driver Date: 6-17-2015
Driver Version: 10.18.13.5330
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 35561458
Supports Hardware H264 Decoding: true
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Ti Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 163840
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.parent_directory: G:\~~ Nightly Cache (New) ~~
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.download.useDownloadDir: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150728030209
browser.startup.homepage_override.buildID: 20150728030209
browser.startup.homepage_override.mstone: 42.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
dom.allow_scripts_to_close_windows: true
dom.apps.reset-permissions: true
dom.ipc.processCount: 8
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a1
font.internaluseonly.changed: true
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x1183
gfx.driver-init.driverVersion: 10.18.13.5330
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.lastUpdate: 1437783429
media.gmp-eme-adobe.version: 12
media.gmp-gmpopenh264.lastUpdate: 1430240127
media.gmp-gmpopenh264.path: C:\Users\Mikel\AppData\Roaming\Mozilla\Firefox\Profiles\ogqpk6to.Nightly (New)\gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150728030209
media.gmp-manager.lastCheck: 1438110078
media.hardware-video-decoding.failed: false
media.peerconnection.enabled: false
network.cookie.prefsMigrated: true
network.dns.disableIPv6: true
network.dnsCacheEntries: 20
network.http.keep-alive: true
network.http.pipelining: true
network.http.pipelining.aggressive: true
network.http.pipelining.ssl: true
network.http.proxy.keep-alive: true
network.http.proxy.pipelining: true
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1437594832
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.anti_banner_native_proxy: 2
plugin.state.npcontentblocker: 2
plugin.state.nponlinebanking: 2
plugin.state.npvkplugin: 2
plugin.state.url_advisor: 2
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace:
print.print_command:
print.print_downloadfonts: false
print.print_duplex: 1515870810
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name:
print.print_paper_size_type: 1
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_plex_name:
print.print_resolution: 1515870810
print.print_resolution_name:
print.print_reversed: false
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 0
print.print_unwriteable_margin_left: 0
print.print_unwriteable_margin_right: 0
print.print_unwriteable_margin_top: 0
privacy.cpd.cookies: false
privacy.cpd.offlineApps: true
privacy.cpd.sessions: false
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
privacy.trackingprotection.enabled: true
security.sandbox.content.tempDirSuffix: {e0a35e31-cba3-4cdd-9782-6a6467d718df}
security.ssl.errorReporting.automatic: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1436901809

user.js Preferences
-------------------

Your profile folder contains a user.js file, which includes preferences that were not created by Nightly.

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.9 Beta
Version in use: 4.10.9 Beta

NSS
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSMIME
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSSL
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSUTIL
Expected minimum version: 3.19.2
Version in use: 3.19.2

Experimental Features
---------------------
Version: unspecified → 42 Branch
Flags: needinfo?(acomminos)
I wonder if this is what causes bug 1188131.

If we notice corrupted frames, it may disable HW acceleration as we assume it's the HW that is faulty.

However, if you set media.hardware-video-decoding.enabled=false

do you have any corruptions issue ?

Alice0775, can you reproduce the issue yourself? what machine do you have?
Flags: needinfo?(jyavenard) → needinfo?(alice0775)
See Also: → 1188131
(In reply to Jean-Yves Avenard [:jya] from comment #15)
> if you set media.hardware-video-decoding.enabled=false
> 
> do you have any corruptions issue ?

It helps.


> Alice0775, can you reproduce the issue yourself? 

Yes, Of course.

> what machine do you have?

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150728030209

Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
Asynchronous Pan/Zoom: wheel input enabled
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
Device ID: 0x6779
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17292)
Driver Date: 6-22-2015
Driver Version: 15.200.1046.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 23111787
Supports Hardware H264 Decoding: true
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(alice0775)
by "it helps" you mean the issue is entirely gone ? or it's just better (and there's still corrupted frames)
Can you reproduce it when restarting the video once ended?
Can you reproduce it if you manually set a resolution?
Is one particular resolution showing the problem?

What kind of distortion are you exactly talking about? blocks, greens etc? could you make a capture?

If you right click and select stats for nerd. what does it show?

Thanks
Flags: needinfo?(alice0775)
Attached video bug-screencapture (obsolete) —
Attached image bug-video-stats (obsolete) —
I can confirm I am seeing the same behavior as Alice.
(In reply to Alice0775 White from comment #21)
> Please backed out the offending bug.
> Because, there is a possibility that this bug hides the other new regression.

I don't see why. This bug will be fixed, and we're working on it.
It's Nightly there will always be some road bumps.
(In reply to Alice0775 White from comment #22)
> (In reply to Jean-Yves Avenard [:jya] from comment #20)
> > Can you reproduce it when restarting the video once ended?
> 
> Yes, I can.
> 1. Open video and wait to end
> 2. Close the tab
> 3. Clear cache
> 4. Re-Open the video
> 

by restarting, I mean playing play again once video reach the end.

If you don't clear the cache you can't reproduce it?

> > Can you reproduce it if you manually set a resolution?
> 
> I cannot set new resolution by manually without video play with default
> resolution.
> So I cannot test.
> 
> > Is one particular resolution showing the problem?
> 
> It is default resolution
> 
> > 
> > What kind of distortion are you exactly talking about? blocks, greens etc?
> > could you make a capture?
> > 
> 
> Stop video for a while
> Turn black whole video and reverse color 
> Sips then playbark
> 
> attached bug-screencapture
> 
> 
> > If you right click and select stats for nerd. what does it show?
> > 
> 
> attached bug-video-stats
> 
> > Thanks

oh, you're using e10s that's something I didn't turn on.

thank you for your feedback and help.
Can you reproduce it with e10s turned off?
Ok. I managed to reproduce it consistently as follow.
1. Open https://www.youtube.com/watch?v=8uaoBTBofto
2. Let it play to the end.
3. In the settings, set quality to 360p
4. Press the replay icon.
5. If playback doesn't restart, then press play again after the image has settled.

Video playback will appear frozen, and suddenly restart with corruption.

Probably seeking that is wrong
Assignee: nobody → jyavenard
I'm not sure this is the same issue originally reported as it mentions hardware acceleration ; however Alice's issue can be reproduced even with HW decoding turned off.

Andrew, if you set media.hardware-video-decoding.enabled=false can you reproduce the problem?
Flags: needinfo?(acomminos)
I'm not at the office right now, but IIRC I could not reproduce with hardware video decoding disabled. I can verify tomorrow.
Flags: needinfo?(acomminos)
Ah so that may be another problem then.

In the mean time will create another bug.
See Also: → 1189138
Tracking in 42 because regression, affects YouTube.
Thanks :jya, the steps in comment 29 reproduce this bug for me as well.
Can you still reproduce the issue with the latest Nightly ?
:jya, not for me.
Still reproduceable with steps in #c29
Which version of Nightly are you using?

steps 29 were fixed in bug 1189138.

Version 20150802030218 includes those changes
Yes, I am on Version 20150802030218 and it's still reproduceable reliably.
Back Bug 1171379 out, please
Flags: needinfo?(jyavenard)
It will not be backed out.
Flags: needinfo?(jyavenard)
(In reply to Jean-Yves Avenard [:jya] from comment #29)
> Ok. I managed to reproduce it consistently as follow.
> 1. Open https://www.youtube.com/watch?v=8uaoBTBofto
> 2. Let it play to the end.
> 3. In the settings, set quality to 360p
> 4. Press the replay icon.
> 5. If playback doesn't restart, then press play again after the image has
> settled.

WMF in nightly on Windows.
(In reply to Jean-Yves Avenard [:jya] from comment #40)
> It will not be backed out.

OK, then please fix it before marge this to aurora42.
Otherwise, this should be backed out!
it should already be fixed ; and if not it will be fixed.

We can't back that changeset.
Alice, can you reproduce using the steps described in comment 29 using the latest Nightly?
(In reply to Jean-Yves Avenard [:jya] from comment #44)
> Alice, can you reproduce using the steps described in comment 29 using the
> latest Nightly?

No.

I am using simple STR of comment#13, and reproducible on latest Nightly42.0a1.

https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150802030218
(In reply to Jean-Yves Avenard [:jya] from comment #43)
> it should already be fixed ; and if not it will be fixed.


Not fixed, you should try STR of comment #13. it reproduced.

> 
> We can't back that changeset.

I do not understand why can not.
Flags: needinfo?(jyavenard)
Because there are hundreds of bugs fixed by that change that would now regress ; and would seriously disrupt our plans to enable MSE on all web sites (it's currently limited to YouTube).

In any case ; can you reproduce the problem with the latest nightly using STR in c29?

I'm still unsure if they are one and the same bug ; if you can't reproduce using STR in comment 29; then at least we know that problem is fixed and this particular problem is another.
Flags: needinfo?(jyavenard)
(In reply to Jean-Yves Avenard [:jya] from comment #47)
> Because there are hundreds of bugs fixed by that change that would now
> regress ; and would seriously disrupt our plans to enable MSE on all web
> sites (it's currently limited to YouTube).
> 
> In any case ; can you reproduce the problem with the latest nightly using
> STR in c29?
> 
> I'm still unsure if they are one and the same bug ; if you can't reproduce
> using STR in comment 29; then at least we know that problem is fixed and
> this particular problem is another.

Reopen original Bug 1188651 , it should not duplicate this one
No longer blocks: 1171379
Attachment #8640525 - Attachment is obsolete: true
Attachment #8640527 - Attachment is obsolete: true
got myself setup on a Dell desktop. Can reproduce this bug \o/
Duplicate of this bug: 1188651
(In reply to Jean-Yves Avenard [:jya] from comment #49)
> got myself setup on a Dell desktop. Can reproduce this bug \o/

It's not funny. You also broke DXVA2, D3D11 decoding, as bad as it was already implemented.
Don't drain decoder when encountering WAIT_FOR_DATA. If the next frame following upon resume isn't a keyframe, it will not be decodable.
Update MSE mochitests. The various waiting events won't be fired at the same time
(In reply to ... from comment #51)
> (In reply to Jean-Yves Avenard [:jya] from comment #49)
> > got myself setup on a Dell desktop. Can reproduce this bug \o/
> 
> It's not funny. You also broke DXVA2, D3D11 decoding, as bad as it was
> already implemented.

uh what?
Depends on: 1173657
Attachment #8642366 - Attachment is obsolete: true
Attachment #8642368 - Attachment is obsolete: true
We made the design decision that it was preferable to decode as much of what we had, even if that meant we couldn't decode some frames upon resume.
This can cause significant apparent stalls with some YouTube videos where keyframes are up to 4.2s appart (128 frames).
Attachment #8642809 - Flags: review?(cpearce)
Attachment #8642809 - Flags: review?(cpearce) → review+
Attachment #8642810 - Flags: review?(cpearce) → review+
Depends on: 1191138
Attachment #8644775 - Flags: review?(gsquelart)
In test_HaveMetadataUnbufferedSeek_mp4, do endOfStream after appending 2nd buffer in case decoder doesn't output enough frames to seek to the target point.
Attachment #8644776 - Flags: review?(gsquelart)
Attachment #8644775 - Flags: review?(gsquelart) → review+
Attachment #8644776 - Flags: review?(gsquelart) → review+
Going to commit part 4 as it prevents another intermittent
Keywords: leave-open
The try machines do not have Service Pack 1 installed, the WMF decoder doesn't output frames until a full second of data has been added. Rendering those tests invalid.
The try machines do not have Service Pack 1 installed, the WMF decoder doesn't output frames until a full second of data has been added. Rendering those tests invalid.
Attachment #8646112 - Flags: review?(cpearce)
The test loads 10 frames of video data and expect the loadeddata event to be fired. Windows 7 without SP1 installed (like our try machines) may not output any frames until at least 25s have been input.
Attachment #8646114 - Flags: review?(karlt)
Attachment #8646112 - Flags: review?(cpearce) → review+
Blocks: 1139137
(In reply to Jean-Yves Avenard [:jya] from comment #64)
> Created attachment 8646114 [details] [diff] [review]
> [MSE] P6. Disable some tests on windows 7.
> 
> The test loads 10 frames of video data and expect the loadeddata event to be
> fired. Windows 7 without SP1 installed (like our try machines) may not
> output any frames until at least 25s have been input.

Are the WMF decoders intermittent in their behaviour?

Why did this not mean that the test needed to be disabled before bug 1171379 landed?

https://hg.mozilla.org/integration/mozilla-inbound/rev/c100ddbbaf68#l5.1
Flags: needinfo?(jyavenard)
It is intermittent in behaviour yes. I've seen them outputting frames very quickly.

This is why the test_eme_*_blocked_* where intermittently failing.

We didn't need it before because once we entered a discontinuity or a gap in the data we used to drain the decoder.
But draining the decoder renders all future frames unplayable until a new key frame is added and which is what this bug is about.

When starting (and seeking) YouTube now adds a partial media segment, with 1s worth of data. And then goes on to load the rest of the media segment. This is a new behaviour from them, it didn't occur a few weeks ago.
What would happen is that playback would start, and decode 1s of video before the remaining segment had to time to be downloaded.
We would drain the decoder upon reaching 1s. The next keyframe is found at 4ish s. So we ended with video from 1s to 4s being unplable hence the apparent freeze.

This is what's this bug is correcting, don't drain the decoder and instead wait.

The old MSE used to drain the decoder, but upon resuming with new data would then seek back, so it obfuscated the WMF decoder issue.

It was decided that those tests test the wrong behaviour ; there's nothing that states that if a stream is open ended we should output all pending frames.
Flags: needinfo?(jyavenard)
Comment on attachment 8646114 [details] [diff] [review]
[MSE] P6. Disable some tests on windows 7.

Thanks.  That explanation is very helpful.
Attachment #8646114 - Flags: review?(karlt) → review+
Attachment #8646067 - Attachment is obsolete: true
Looks like this should be set to (fixed and target milestone) 43. 

jya, do you want to request uplift? I know you mentioned you had some other approvals coming. Just making sure this is still on your radar.
Flags: needinfo?(jyavenard)
Target Milestone: --- → mozilla43
Blocks: 1197083
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jyavenard)
Keywords: leave-open
Resolution: --- → FIXED
Backed out for a youtube playback regression. See Bug 1199573.
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bb661db5c6c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Reproduced with Nightly from 2015-07-06 by using STR from comment 29, under Windows 7 x64.
Verified fixed with 42.0b5 (Build ID: 20151008162217) and latest 43.0a2 (from 2015-10-11), under Windows 7 64-bit and Windows 10 32-bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.