Closed Bug 1181023 Opened 5 years ago Closed 4 years ago

[Performance] Improve Settings app startup time to less than 1000ms

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P4)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: bobby.chien+bugzilla, Unassigned)

References

()

Details

(Keywords: perf, Whiteboard: [perf-wanted])

coldlaunch.visuallyLoaded
-------------------------
appName   master  v2.2
--------  ------  ----
Video     974     1020
Messages  1265    986
Settings  2545    2437
Gallery   866     1046
Music     1017    956
FM Radio  764     496
E-Mail    413     1973
Phone     846     754
Contacts  755     717
Clock     1186    1206
Calendar  1421    1342
Camera    1504    1297
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Blocks: 1180696
blocking-b2g: 2.5? → ---
feature-b2g: --- → 2.5?
Whiteboard: [perf-wanted] → [perf-wanted][Profile-wanted]
Report: 2015/08/18

Flame-KK 319MB
-------------------------
appName   master  v2.2
--------  ------  ----
Messages  1545    986
Settings  2669    2437
Video     1182    1020
Gallery   1139    1046
Music     1054    956
FM Radio  741     496
E-Mail    547     1973
Contacts  1149    717
Clock     1395    1206
Calendar  1543    1342
Camera    1465    1297
Dialer    769

Aries-KK 2G
----------------------------------------------------------------------
appName   value  memory  device  branch  context
--------  -----  ------  ------  ------  -----------------------------
Calendar  730    2048    aries   master  calendar.gaiamobile.org
Contacts  565    2048    aries   master  communications.gaiamobile.org
FM Radio  349    2048    aries   master  fm.gaiamobile.org
E-Mail    250    2048    aries   master  email.gaiamobile.org
Music     511    2048    aries   master  music.gaiamobile.org
Clock     518    2048    aries   master  clock.gaiamobile.org
Camera    651    2048    aries   master  camera.gaiamobile.org
Dialer    305    2048    aries   master  communications.gaiamobile.org
Video     710    2048    aries   master  video.gaiamobile.org
Settings  1657   2048    aries   master  settings.gaiamobile.org
Gallery   507    2048    aries   master  gallery.gaiamobile.org
Messages  778    2048    aries   master  sms.gaiamobile.org
[Tracking Requested - why for this release]:
feature-b2g: 2.5? → ---
Priority: -- → P4
Whiteboard: [perf-wanted][Profile-wanted] → [perf-wanted]
The approach to decrease loadtime:

* check index.html to find out possible redundant or removable piece. (done)
* check startup js to remove unnecessary code in startup

Current diagnoses (and tasks that align with existing development goal):

* remove USB switch/warning dialog in root panel (2.5)
  - due to UX change (will reduce size of loading)
* remove BT APIv1 support (maybe after 2.5)
  - remove BT detection code and remove BT helper dependency (will reduce size of loading)
* convert rest of pack-switch css to gaia-switch (will clean some css)

I'd expect ~100ms improvement with above change.

Need dig into js startup procedure to squash more improvement space.
Assignee: nobody → gasolin
Depends on: 1194045
Depends on: 1202945
Depends on: 1211341
According to Current state of performance in Gaia 2015/10/2

Settings v2.2 cold launch: 2474ms
Settings current cold launch: 2950ms (~475ms regression)
Settings v2.2 USS: 17.18MB
Settings current USS: 17.54MB (acceptable)
We'll also check with raptor tool to see if make html import on demend (only load needed html/js) will save some loadtime.
See Also: → 1154058
See Also: → 1216435
According to test result, remove BTv1 API does not save loadtime
Depends on: 1218271
No longer depends on: 1211341
ums panel has been separated by bug 1194045
pack-switch has been removed by bug 1172349.

Come with bug 1216435, the loadtime has decreased 100+ms
Depends on: 1172349
No longer blocks: 1180696
Depends on: 1159657
Assignee: gasolin → nobody
Please reopen if you need.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.