[tracking] Allow Web Extensions add-ons to be submitted to AMO

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: andym, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
We'd like to be able to get web extensions on to AMO. There are some areas we know we have to fix and some areas we need to test and see how they work. These include but are not limited to:
* checking the add-on in the validator
* signing the add-on
* reviewing the add-on
* viewing and installing the add-on
* update checks as the add-on updates

We know the validator has to be changed, not sure on the rest.
(Reporter)

Updated

2 years ago
Depends on: 1210079
And also submitting the add-on to AMO: I guess we'll need a new "Extractor" subclass (https://github.com/mozilla/olympia/blob/a926e1d7f2323c778e638bf82483ae45372608f3/apps/files/utils.py#L86) to deal with the new manifest.json format.
Duplicate of this bug: 1190691
For viewing and installing the add-ons it would be great to get to a simpler way of installing add-ons, maybe like suggested in bug 1153226. And surfacing the powers of specific add-ons, maybe as permissions might be useful to better understand what add-ons can do. And while I am at it, showing the impact on performance an add-on will have would be great as well.
(Reporter)

Updated

2 years ago
Blocks: 1214433
(Reporter)

Updated

2 years ago
Depends on: 1190335
Depends on: 1217358
Depends on: 1217810
Depends on: 1219772
Depends on: 1219773

Comment 4

2 years ago
Any word on an official release date for the web extension api.

Comment 5

a year ago
(In reply to aneury.casado from comment #4)
> Any word on an official release date for the web extension api.

Their wiki says a timeline of Q2 2016 (source: https://wiki.mozilla.org/WebExtensions/RoadMap)
(Reporter)

Comment 6

a year ago
This is turned on and everything else is being tracked in github: https://github.com/mozilla/olympia/issues?q=is%3Aopen+is%3Aissue+label%3AWebExtensions
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard

Comment 7

11 months ago
Any idea why when I submit a WebExtension to AMO, it doesn't use i18n and detects my extension name as "__MSG_name__"?
^ any idea?
Flags: needinfo?(amckay)
(Reporter)

Comment 9

11 months ago
This bug hadn't landed yet:

https://github.com/mozilla/addons-server/issues/1681

It landed on Thursday (7th) and should work. Please file issues in github if it doesn't.
Flags: needinfo?(amckay)
You need to log in before you can comment on or make changes to this bug.