The default bug view has changed. See this FAQ.

URL requested by other apps should open new tab, not window

RESOLVED FIXED in Future

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: HajimeG3, Assigned: jag (Peter Annema))

Tracking

({helpwanted})

Trunk
Future
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.7+)
Gecko/20020125
BuildID:    2002012503

URL requested by other apps(Mail.app, Finder etc.) should open new tab, not window.

Reproducible: Always
Steps to Reproduce:
1.Make URL shortcut file (DnD url onto Desktop)
2.Double-click it


Actual Results:  Mozilla opens new window, and the requested page is shown in it.

Expected Results:  Mozilla shouldn't open new window but new tab.
Or, simply use exist tab.
(Assignee)

Comment 1

15 years ago
-> future, helpwanted
Keywords: helpwanted
Target Milestone: --- → Future
What tab browser preference would you say this should be controlled by, of the
existing ones?
(Reporter)

Comment 3

15 years ago
I think it's 'Open tabs instead of window for -> Windows opend by Web page'
Though it's not implemented yet.
Platform => All
OS => All

Problem confirmed, this applies to MozillaMailNews and ChatZilla as well, I'd say.
That pref should _not_ apply to this situation, actually,
since the window is _not_ being opened by a webpage.  This
would need a separate preference and implementation.

Setting severity to enhancement (which this would have to be),
confirming bug.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
True,

"Open Tabs instead of Windows for..." (in Preferences | Navigator | Tabbed Browsing)
=> "Links clicked in external applications" (or perhaps "programs").
It would be terribly clever to be able have one window per requesting app.  It
would keep me organized, anyway.  Might be hard on non-Mac OS's.

Comment 8

15 years ago
Wouldn't it be nice to have something like this in Preferences | Navigator |
Tabbed Browsing ?

Action                  Open in new...
---------------------------------------------------
Open URL in other app   (.)Window  ( )Tab
Link in webpage         (.)Window  ( )Tab
JS window.open()        (.)Window  ( )Tab*

* or launch Mozilla if it isn't started yet

Just my 2 cents...
Action                  Open in...
                        New window | New tab | Current tab
----------------------------------------------------------
Open URL in other app   (.)         ( )        ( )
_blank Link in webpage  (.)         ( )        ( )
Normal Link in webpage  ( )         ( )        (.)
JS window.open()        (.)         ( )        ( )

How's this?

Comment 10

15 years ago
This looks great!
Maybe you could even have some
...
JS  ( )    ( )     ( )     (x) Open in background tab
But maybe this gets too complicated ;-)
How about

JS  ( )    ( )     ( )     (x) Open in background tab     (x) Fetch some ice
cream while rendering

;-)

Comment 12

15 years ago
Really changing Platform->All, OS->All
I think that this bug should be blocked by bug 104204 (or maybe better the other
way round?)
OS: MacOS X → All
Hardware: Macintosh → All

Comment 13

15 years ago
*** Bug 131213 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
This bug is now blocked (in part) by bug 155402.  External applications no
longer open a new anything (unless Mozilla is not actually loaded at the time)
but reuses whatever window/tab is currently focused.
Depends on: 155402
(Reporter)

Comment 15

15 years ago
Bug 155402 seems to affect only windows build.
Mac OS X build still open new window...

Comment 16

15 years ago
There is a hidden pref on Mac that controls this behaviour:
"browser.always_reuse_window"
This controls whether URLs opened via Apple Events replace the existing content
(if the pref is on), or make a new window (the default). It's not possible in
Mozilla to have them go into new tabs (c.f. Chimera).

Comment 17

15 years ago
*** Bug 157407 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
I vote for comment 9 and such. I purrsonally prefer new windows, no silly tabs.
And I said NEW, cause I don't previous window's conent to be replaced with
something without my explicit permission.

Anyways, having that stuff configured, like in comment 9, is the best solution.

Comment 19

15 years ago
*** Bug 160971 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 161466

Updated

15 years ago
Summary: URL requested by other apps should open new tab, not window → [RFE] URL requested by other apps should open new tab, not window

Comment 20

15 years ago
*** Bug 162098 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
I agree
Two other details for this:
1. If the preference is set, then urls that are dragged into the mozilla 
window should create a new tab
2. If I try to execute mozilla [url] on the command line (and there is only 
one window open), create a new tab

Comment 22

15 years ago
I agree
Two other details for this:
1. If the preference is set, then urls that are dragged into the mozilla 
window should create a new tab
2. If I try to execute mozilla [url] on the command line (and there is only 
one window open), create a new tab

Updated

15 years ago
Depends on: 75138
No longer depends on: 155402

Comment 23

15 years ago
*** Bug 167015 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → pmac
Summary: [RFE] URL requested by other apps should open new tab, not window → URL requested by other apps should open new tab, not window

Comment 24

15 years ago
*** Bug 104204 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
I would prefer this:

Action                  Open in...
                        New window | New tab | Current tab
----------------------------------------------------------
Open URL in other app   ( )         (x)        ( )
_blank Link in webpage  ( )         (x)        ( )
Normal Link in webpage  ( )         ( )        (x)
JS window.open()        (x)         ( )        ( )

The above suggestions would keep my browsing experience neat and clean, thus
avoiding cluttered windows.  I would like to see the first two items as
Preference options in the browser.

matthew

Comment 26

15 years ago
i feel that all this should be able to be controlled by command line parameters.
for example.
i have an application that launches a url using some data that is gathered in
the application.
pretty much all that it does is launch the url.
once one url is launched, the next url will always want to replace that
one(always use the window that was used last), otherwise if it makes a new
window, you will always have to close the previous window, or you will have a
million windows on the screen. also, it should never replace an existing browser
window, because that will wipe out something else that you were looking at.

however, for my standard setting i would want it to always open in a new window,
or new tab, because other system url executions will not generally be one that
would be done continuously, and would always be something that would be starting
a new topic.

another option, would be if the command line parameter that tells mozilla what
to do is ommitted(which would probably be the system default for a url
association) it would bring up a box, and ask you where you want the url to be
opened.(a new tab, new window, existing tab, existing window, etc.), kind of
like the box that comes up on windows xp, and asks you what to do when you
instert a new cd.

this box popping up would also be appreciated from a link that you click on in 
an e-mail.

Comment 27

15 years ago
I agree with Matthew Artukovich (Comment 25): nicely thought-out solution.

I'm trying to stay with the switch from NetCaptor to Mozilla (to be free of
IE!), but it's killing me not having this feature!

Example: if you get the NY Times in your Inbox, you want to be able to click on
several stories and read them. On Netcaptor, after every one is clicked they are
opening in tabs and they're all ready to read when I'm done clicking!

So please at least give us the option! :)

Comment 28

15 years ago
For the reason mentioned in comment #27, yes, please give the option of opening a URL 
requested by another app in current opened browser window/tab (no new tab or 
window). Thanks.

Comment 29

14 years ago
This bug has been around for a long time--and it's still in...
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

Could someone look at this before it goes another year?

Comment 30

14 years ago
trillian on Win2k with Mozilla Firebird set as default system browser cannot
open a window or tab to check email, this would be handy

also, the program News Interceptor (http://www.newsinterceptor.com/) can use
Mozilla to open windows to webpages, but for it to be able to open a new tab in
the one window for each webpage would be appreciated.

Comment 31

13 years ago
*** Bug 238526 has been marked as a duplicate of this bug. ***

Comment 32

12 years ago
The backend for this was implemented by bug 172962 (the Suite UI came with bug
161466). Therefore marking as dupe.

*** This bug has been marked as a duplicate of 172962 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 33

12 years ago
Reopening.  Yes, we have UI and a backend pref now, but it doesn't completely
work.  I have several applications that, despite the setting, open in a new
window - completely disregarding the new tab preference.

The two I've found that do this are Outlook and Pegasus.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 34

12 years ago
Right, but this bug has been solved by the fix to bug 172962. Open a new bug for
those issues, and make it depend on bug 172962.

*** This bug has been marked as a duplicate of 172962 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Blocks: 163993

Comment 35

12 years ago
> Right, but this bug has been solved by the fix to bug 172962.

No, it hasn't.  It's been helped a great deal, but it's by no means been solved.

Read the summary of this bug.  It says "URL requested by other apps (Mail.ap,
Finder, etc.) should open new tab, not window."  It doesn't just read that we
need to have a preference for this.  Although that was certainly a part of the fix.

I've already listed 2 apps in which the behaviour that this bug was meant to
solve is still non-functional.  I somehow doubt that Outlook (probably the most
common email application there is) can be considered an edge case.

Fixing 172962 has made a lot of headway here, but it hasn't solved it
completely.  This bug has only been partially fixed.  It makes much more sense
to mark the dependency correctly (that this bug depended on 172962) but to keep
working on this bugs problem in this bug.
Status: RESOLVED → REOPENED
Depends on: 172962
Resolution: DUPLICATE → ---

Comment 36

12 years ago
As you wish, but keep in mind that leaving this much more general bug open will
not really help to get the issue resolved more quickly. As Grey Hodge said:
instead you should file specific bugs for the issues you still see. (As you
refer to Outlook and Pegasus the issues might well be windows specific.)

Updated

12 years ago
No longer blocks: 163993

Comment 37

12 years ago
I guess this is too obvious, but I haven't seen it mentioned in here. Has anyone
looked at this extension to see what can be brought from it? 

http://www.spuler.us/extensions/singlewindow.htm

Comment 38

12 years ago
> Has anyone looked at this extension to see what can be brought from it?

Excellent.  I just installed it and Pegasus is now opening in a new tab as it
should rather than a new window.  (I won't have a chance to test Outlook until I
get to work again next week.)

So - what is it that the extension is doing right that Mozilla itself is
currently doing wrong?

Comment 39

12 years ago
I'm happy to report that that "singlewindow" extension also fixes the Outlook
problem.  I'll see if I can get the extension creator to come up with a patch
for the suite itself.  Or at least comment here on what he's done.

Comment 40

12 years ago
(In reply to comment #39)
> I'm happy to report that that "singlewindow" extension also fixes the Outlook
> problem.  I'll see if I can get the extension creator to come up with a patch
> for the suite itself.  Or at least comment here on what he's done.

A classic case of not reinventing the wheel. Glad to have helped. Now, if we can
get Duplicate Tab, Focus Last Selected Tab, TabX, and UndoCloseTab also in here,
it will be a lot less clutter with extensions. ;-)

Comment 41

12 years ago
Unfortunately, the singlewindow extension no longer seems to work with the
latest builds.  (And I never did hear back from the author about contributing to
this bug.)

Comment 42

12 years ago
Even with bug 299444 fixed, the singlewindow extension still doesn't work. 
Whatever allowed it to function was broken at the same time as applications
opening in tabs instead of windows (for most cases) was broken.

Updated

12 years ago
Depends on: 300465

Comment 43

12 years ago
Filed bug 300465 for the specific case of Outlooks hyperlinks opening in new
windows rather than tabs, and set it as blocking this bug.
No longer depends on: 300465

Updated

12 years ago
Depends on: 300465

Updated

12 years ago
Depends on: 299983

Comment 44

12 years ago
(In reply to comment #39)
> I'm happy to report that that "singlewindow" extension also fixes the Outlook
> problem.  I'll see if I can get the extension creator to come up with a patch
> for the suite itself.  Or at least comment here on what he's done.

Any luck contacting the author?

Comment 45

12 years ago
> Any luck contacting the author?

None.  My email to him doesn't bounce, but he doesn't got back to me.

BTW: Look at bug 300465 comment 2 on a way of getting the singlewindow extension
working again in the most recent nightlies.

Comment 46

12 years ago
Fixed by the fix for bug 300485!  No more need for the Single Windows extension.
 Since nobody else has commented on something other than Outlook / Pegasus not
opening a new tab but, instead, a new window, and that's now resolved (bug
300485 also fixed bug 300465), I'm going to resolve this one as FIXED again.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Comment 47

12 years ago
So how is it supposed to work? Do I have do set an option which decides if I 
want a new tab, a new window or a reuse of an existing window? Or how else do I 
decide?

pi
preferences -> navigator -> tabbed browsing, lower right
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.