bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

cannot read mails in Thunderbird - seems to be caused by Calendar update problem (already caused problems earlier - bug 1211291)

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
2 years ago
10 months ago

People

(Reporter: frank, Unassigned)

Tracking

(Blocks: 1 bug)

38 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 2 obsolete attachments)

(Reporter)

Description

2 years ago
Created attachment 8721666 [details]
ScreenHunter_138 Feb. 20 17.22.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

I do not know what happened, I am not aware of doing something wrong


Actual results:

I am a long time user of Thinderbird and Firefox, to full satisfaction
since about two weeks, Thunderbird has been acting strangely
first it slowed down immensely, then it came to a full stop
allthough it still seems to work fine (in the background):
all folders are there (even the local folders),
and I see new mails arriving by seeing the numbers of unread mails in the in income mail folder increase
but I can not open and read any of my mails any longer
whatever folder I click on, the reading panel stays the same
also none of the buttons in the extra menu work any more
I have backed up my profile and mails with Mozbackup
I have deleted and reinstalled Thunderbird's latest version 30.6.0 over 10 times,
I have deleted it completely with Revo Uninstaller Pro
then reinstalled the latest version
restored my profile and mails
I have repaired my Windows 10 with Reimage Repair at least 3 times
I have no malware or viruses on my PC
all to no avail,
still the same result:
everything seems to be present, but nothing works:
no lists and  no mails appear in the main panel
plus most of the buttons in the menus do not react
please find three screenshots after clicking on three different folders:
the mail panel doesn't change
please help
ooops, I apparently can attach only one



Expected results:

Thunderbird should have worked properly again,
like it has worked for many years
(Reporter)

Comment 1

2 years ago
Created attachment 8721667 [details]
ScreenHunter_138 Feb. 20 17.22.jpg
(Reporter)

Comment 2

2 years ago
Created attachment 8721668 [details]
ScreenHunter_139 Feb. 20 17.23.jpg
(Reporter)

Comment 3

2 years ago
Created attachment 8721669 [details]
ScreenHunter_137 Feb. 20 17.21.jpg
Attachment #8721666 - Attachment is obsolete: true

Comment 4

2 years ago
Looks like this user was hit by the calendar update problem in bug 1211160, although that should be fixed in TB 38.6.

Simply remove the calendar add-on be deleting this folder {e2fda1a4-762b-4020-b5ad-a41df1933103} from the extensions folder in your profile folder.

MakeMyDay: Does this sound familiar?
Flags: needinfo?(makemyday)
Summary: cannot read mails in Thunderbird → cannot read mails in Thunderbird - seems to be caused by Calendar update problem (bug 1211160)

Updated

2 years ago
Duplicate of this bug: 1249560

Comment 6

2 years ago
Before you delete anything, please provide your TB version number. If you're on TB 38 but not yet on TB 38.6.0 (which seems to be likely because that version is not out for two weeks now), please update to that version. Also let us know whether you had Lightning installed.

If you are already on that version and had installed calendar before, please enable extesions.logging preference in the config editor and attach all the log messages you get at TB startup (taking screenshots of the error console is maybe the easiest way to do this). Also, please attach the chrome.manifest file from folder {path of your tb-profile}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
Flags: needinfo?(makemyday) → needinfo?(frank)
(Reporter)

Comment 7

2 years ago
Thanks,
I have provided the TB version number, and mentioned it in my mail:
but I made a typo: it is not 30.6.0, but 38.6.0
and the latest one that can be downloaded if you do a normal search on google for Thunderbird
I have erased prvious versions,
downloaded and reinstalled this "latest" version many times, to no avail

Indeed I had Lighning Calendar installed
apparently this is where the bug was (or still is)
I wil try and follow your instructions to eliminate this bug caused by Lighning

meanwhile I have helped myself with Mailbird
by far it cannot compete with Thunderbird

but it has two very interesting new features:
the possibility to delay and stop a send for up to 30 seconds,
so an impulsive send can be corrected

and a direct and immediate connection to Google agendas

greets and thanks
Frank
Flags: needinfo?(frank)

Comment 8

2 years ago
Thank you. Can you still provide the requested chrome.manifest file and the logs? Without that we cannot furthe debug the issue.
Version: unspecified → 38 Branch
(Reporter)

Comment 9

2 years ago
hello, 
I am now trying to follow your instructions
I have done a search for e2fda1a4-762b-4020-b5ad-a41df1933103 folders
all over my PC
there were many of them, see screenshot attached
I have deleted all of them, including the .msf file
so far so good, I hope
but still the same problems with Thunderbird:
still no change in the main panel, whatever folder I click on

should I delete my last installation of Thunderbird or not?

now for the rest of your instructions, please bear with me:
how do I
"enable extesions.logging preference in the config editor"

I suppose this has to be extensions.logging and not extesions.logging ?
is this a typo ?

which config editor ? where do I find this editor ?

"and attach all the log messages you get at TB startup (taking screenshots of the error console is maybe the easiest way to do this)."

I guess I can do this, if I am allowed the time to take screenshots

"Also, please attach the chrome.manifest file from folder {path of your tb-profile}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}"

I will see to this if I get there

greetings and thanks
Frank
(Reporter)

Comment 10

2 years ago
Created attachment 8721988 [details]
ScreenHunter_140 Feb. 22 15.40.jpg
(Reporter)

Comment 11

2 years ago
I have also Teamviewer on my PC
just now, I downloaded an installed the latest version
I will give you access
greets
Frank

Comment 12

2 years ago
Config editor:
Tools > Options, Advanced tab, General.
The option is called extensions.logging.enabled, double click to change the value from false to true.

If you really deleted all the folders named e2fda1a4-762b-4020-b5ad-a41df1933103, you can't supply the file we asked for. But if you deleted the folder, the problem would have gone away, I believe.

I don't understand why you have so many folders by that name on your system. Most likely the one modified most recently (20 Feb) is the candidate we're interested in.

Maybe it would be easiest of my colleague visited you via Teamviewer so he can inspect what he needs to see and then reset the installation so you can use TB again.
Flags: needinfo?(makemyday)

Comment 13

2 years ago
Let's keep this bug in Thunderbird for now, though it is almost certainly a toolkit extensions bug. Not sure of the relationship to bug 1211160 yet, but let's assume for now that the fix there had some unexpected side effect. Confirming based on several reports.
Blocks: 1211160
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true

Comment 14

2 years ago
Yes, probably this is another toolkit issue. Bit we need some more debug info first to see whether or not it's related to bug 1211160. A teamviewer session would be great and the easiest way to dig into this issue. Unfortunately, I'm not available for such in the next days due to pto/travel and no notebook around. Philipp or Kent, can you check with Frank to collect some debugging information?
Flags: needinfo?(makemyday) → needinfo?(philipp)

Comment 15

2 years ago
If Philipp is not available, I can do it tonight from 21:00 (GMT+1). Frank, could you mail the necessary details to Philipp (see e-mail below) and myself, click on the "JK" icon to see the profile with the e-mail.
(Reporter)

Comment 16

2 years ago
the button Tools > Options, Advanced tab, General
is not working
in fact, none of the buttons in the extra (tools) menu are working
except for "filters", "account settings" and "mailbox alerts"

"I don't understand why you have so many folders by that name on your system. Most likely the one modified most recently (20 Feb) is the candidate we're interested in."
all these files are still in my recycle bin,
some of them are too large to add to a mail

so please let's organise a Teamviewer session

I have sent you both a mail, so you have my mail address

Comment 17

2 years ago
Created attachment 8722488 [details]
Two extensions causing startup problems

I spent about an hour on the machine of the user via Teamviewer.

The user lives in the Flemish part of Belgium and has the Dutch version of TB 38.6.0 installed.

When starting TB, the Help menu wasn't present and most items on the Tools menu weren't usable, so I couldn't do any logging with extensions.logging.enabled.

The user had five add-ons installed, that is, five files/folders in the extensions folder. Lightning had already been removed.

By trial and error I found two add-ons which caused the peculiar symptom: "Google Calendar" and "SoundPlus". I removed them from the user's extension folder. Both are enclosed for further dissemination.

After removing these, TB ran normally and I manually installed Lightning and Google Calendar from AMO.

I took some screenshots, so maybe I can answer further questions.
Flags: needinfo?(philipp)
(Reporter)

Comment 18

2 years ago
thank you for very efficient and friendly help
Frank

Comment 19

2 years ago
When I unpack the Google Calendar {a62ef8ec-5fdc-40c2-873c-223b8a6925cc} from the RAR file and place it into the extensions folder for a profile used with 38.6, TB 38.6 is pretty much broken as described.

Comment 20

2 years ago
Jorj: can you please send me a copy of this Google Calendar file that is causing the issue? I've got pretty good at investigating this stuff after my work on bug 1211160

Comment 21

2 years ago
The Google Calendar extension in the attachment is missing many files, including the .dtd files in the localization, as well as the skin directory, compared to a good copy. Both claim to be Google Calendar 2.7
(Reporter)

Comment 22

2 years ago
at this moment everything is workinglike a train !
Thanks, guys !
I am a happy man
PS if you want me to send any copies of the new calendar files, just ask !
Frank

Comment 23

2 years ago
(In reply to Kent James (:rkent) from comment #21)
> The Google Calendar extension in the attachment is missing many files,
Should we close the bug then? We won't find out how these files went missing.

Comment 24

2 years ago
No we should not close the bug. We need to keep investigating. This bug should be the main bug for this issue.

To anyone seeing this, there is something different about the systems that are seeing this, and we need to figure out what that is. I've tried updates myself, and I do not see the problem. In particular, is there anything other than Thunderbird that might be trying to write to your profile folder? In the previous manifestation of this issue, that something was Windows roaming profile sync.

It would be also good to post basic information about your install, which would be the information in Help/Troubleshooting Information. You could post that as an attachment here, or email to rkent@caspia.com Also mention what AV solution, if any, that you are using.

Also useful would be an archived version of the extensions directory from your profile (archived so that it preserves file dates), taken while the symptoms of this bug are present. We need to confirm that the behavior seen by frank is also seen by anyone else seeing this.

Anyone supporting this, please encourage people who see this bug to zip the extension directory prior to implementing workarounds to fix the issue.

Comment 25

2 years ago
One more point, if you have a backup of your pre-update state available, and are able to reproduce this problem by restoring that backup and doing an update, then you are a key to resolving this. We would very much appreciate you contacting us and offering to help investigate.

Comment 26

2 years ago
The other add-on which caused this user grief was SoundPlus 1.2.2 (https://addons.mozilla.org/en-US/thunderbird/addon/soundplus/).

I have downloaded the add-on from AMO and compared it with the add-on retrieved from the user's PC. Here the differences which don't surprise:

Only in D:\Desktop\soundpl/chrome/content: abCardOverlay.xul
Only in D:\Desktop\soundpl/chrome/content: abNewEditCardDialog.xul
Only in D:\Desktop\soundpl/chrome/content: images
Only in D:\Desktop\soundpl/chrome/content/lib/sqlite: soundplus.sqlite
Only in D:\Desktop\soundpl/chrome/content: preferences.xul
Only in D:\Desktop\soundpl/chrome/content: skin
Only in D:\Desktop\soundpl/chrome/content: sound
Only in D:\Desktop\soundpl/chrome/content: soundplus.xul
Only in D:\Desktop\soundpl/chrome/locale/en-US: soundplus.dtd
Only in D:\Desktop\soundpl/chrome/locale/fr-FR: soundplus.dtd
Only in D:\Desktop\soundpl/chrome/locale/pt-BR: soundplus.dtd
Only in D:\Desktop\soundpl/chrome: skin

So, some .dtd files and skin directories are missing.

The other add-ons on the user's PC were .xpi files, so they were intact. The user has MozBackup installed, I don't know whether it was used during the various recovery attempts, see comment #0.

Another option would be to ask the user for the MozBackup of his profile taken a while ago, restore it and see whether that produces the update problem. However, most likely the MozBackup is unsuitable, since it contains personal information.

Updated

2 years ago
Duplicate of this bug: 1250438

Updated

2 years ago
Severity: normal → major
(Reporter)

Comment 28

2 years ago
Ok, I have a complete backup on another drive, but I'm not sure what this will show
we can arrange another teamviewer session
Frank
(Reporter)

Comment 29

2 years ago
Hello Jörg
I am very thankful to you
now I have Thunderbird fully working again,
as it has many more and better features than Mailbird
like local folders, extra columns in the listings
and quick sorting per column i.e. subject, sender, date, etc..

but there is one feature in Mailbird that would be a nice addition to Thunderbird:
that of being able to delay/undo a send (adjustable to up to 30 seconds in Mailbird)
there have been many times when I clicked on the send button,
remembering too late that I needed to correct the text, add a note, or a second file

please consider this
greetings

Frank

Comment 30

2 years ago
Thanks again for giving us access to your machine.

Re.: "Send Later". Please file an enhancement request for this.
This could also be done as an add-on. There is a similar one already:
https://addons.mozilla.org/en-US/thunderbird/addon/send-later-3/
This can replace "Send" with "Send Later" and delay the sending by a given amount of time, sadly the smallest amount seems to be 15 minutes.
(Reporter)

Comment 31

2 years ago
where do I file an enhancement request?
the Mailbird feature delays every send for the amount of time chocen (up to 30 seconds)as a standard
so during this time one can either correct mistakes or undo the send

Comment 32

2 years ago
(In reply to frank from comment #31)
> where do I file an enhancement request?
Here in Bugzilla. You create a new bug for product Thunderbird and component "General" and select "Enhancement" from the Importance box.

Comment 33

2 years ago
It's bug 246865

Comment 34

2 years ago
I looked at bug 246865 but is a little different, it calls for a completely different send mechanism. The behaviour that is described for Outlook there doesn't give you a fixed delay. All it does is put he message into the Outbox and send it "later", which can be now or in 10 seconds or in 10 minutes, as it deems fit. The sending happens in the background.

Comment 35

2 years ago
Yes but after you'd have something like that set up it would be pretty easy to set up an ui with the fuse burning...

Updated

2 years ago
Duplicate of this bug: 1250592

Comment 37

2 years ago
I am out of town presently.  I should be able to get what you want on Monday or Tuesday.  tom

Comment 38

2 years ago
That would be very good. You could upload the zipped extensions to a file transfer hoster (like www.WeTransfer.com) and post the link here. Thanks in advance!
(Reporter)

Comment 39

2 years ago
As suggested, I have created a new bug for the feature enhancement delay send / unsend
it is n° 1251440

Comment 40

2 years ago
I still have this problem and I have no clue what to do. I tried deleting the extensions but no help.

This might be a huge coincidence but I am Dutch aswell looks like thunderbird likes to tease use. (my version is in english though) maybe Frank can help me in dutch might be alot easier to understand.

Kind regards,

Comment 41

2 years ago
The fix is very simple.
Visit your profile, it is located here (on Windows):
C:\Users\<username>\AppData\Roaming\Thunderbird\Profiles\<name of profile>
In my case:
C:\Users\jorgk\AppData\Roaming\Thunderbird\Profiles\testing.testing

In the profile folder is a folder called "extensions". Rename that to "extensions-xx" and your problem is solved. Of course all your extensions will disappear this way.

If you want to save the world, then compress the "extensions-xx" folder using Zip/7Zip/Rar and make it available to the Thunderbird development. We are still looking for a reproducible case. You could upload the zipped extensions to a file transfer hoster (like www.WeTransfer.com) and post the link here. Or share it via Dropbox. Thanks in advance!

Comment 42

2 years ago
Thanks now it is working again. Can you send me a e-mail address instead?
(Reporter)

Comment 43

2 years ago
try the suggestions by Jorg K, Nohumour@gmx.com
it is how Jorg fixed the problem on my PC in a Teamviewer session

in Dutch (by the way, I am Flemish, not Dutch ;-) )

Bezoek je profiel(in Windows):
C:\Users\<username>\AppData\Roaming\Thunderbird\Profiles\<name of profile>
In zijn geval:
C:\Users\jorgk\AppData\Roaming\Thunderbird\Profiles\testing.testing

In de profiel map folder zit een map genaamd "extensions". Hernoem die naar "extensions-xx" en het probleem is opgelost. Uiteraard worden alle extensies op deze manier uitgeschakeld.

comprimeer de "extensions-xx" map met Zip/7Zip/Rar en stuur die via dropbox of www.WeTransfer.com door naar het Thunderbird development team vb. naar Jorg (linkermuisknop op zijn naam geeft je het mail adres)

Comment 44

2 years ago
I'm not sure what you mean. You can get my e-mail by clicking on the JK icon to see my profile. Please do not send me any big files. As I said, www.wetransfer.com or Dropbox, or if the zipped archive is smaller than 2 MB attach it here. Go to the top of the page and click on "Add an attachment" under "Attachments".

Comment 45

2 years ago
Created attachment 8724659 [details]
extensions-xx.rar

Thanks frank already understood it got confused/lost before he did something on your computer. Flemish/Dutch same thing. at least the language(typing).

Additional information: started using Thunderbird end December 2015 I never added additional plug in/extensions add-ons, didn't know their were any (very happy with TB). I am using windows 7. Time zone GMT- +1 Malta. Language set in English. if you need more information just ask.

Comment 46

2 years ago
Thanks! I can see that you only had one extension installed: {e2fda1a4-762b-4020-b5ad-a41df1933103}, that's Lightning. We'll investigate. I we have questions, we'll come back to you. Thanks again.

Comment 47

2 years ago
FYI, I made my post to the original link:  https://bugzilla.mozilla.org/show_bug.cgi?id=1250592

Updated

2 years ago
Duplicate of this bug: 1251929

Updated

2 years ago
Duplicate of this bug: 1253906

Updated

2 years ago
Summary: cannot read mails in Thunderbird - seems to be caused by Calendar update problem (bug 1211160) → cannot read mails in Thunderbird - seems to be caused by Calendar update problem (already caused problems earlier - bug 1211291)

Comment 51

2 years ago
Created attachment 8729096 [details]
extensions.zip my extension folder when symptoms are present

After the update to 38.6.0 Thunderbird behave strange. Cannot open folders in the start page, no help available, settings cannot be changed ....

Comment 52

2 years ago
HermanTheGerman, thanks for sharing. But unfortunately, this is the copy of the wrong extension directory - we need not the one in the application directory but that in your Thunderbird profile directory. Can you please provide that one?

Comment 53

2 years ago
Created attachment 8729857 [details]
profile_extensions.zip

Sorry for the mistake. I should have read all entries before uploading the zip file. Here comes the (hopefully) correct one.
Attachment #8729096 - Attachment is obsolete: true

Comment 54

2 years ago
(In reply to Jorg K (GMT+1) from comment #41)
> The fix is very simple.
> Visit your profile, it is located here (on Windows):
> C:\Users\<username>\AppData\Roaming\Thunderbird\Profiles\<name of profile>
> In my case:
> C:\Users\jorgk\AppData\Roaming\Thunderbird\Profiles\testing.testing
> 
> In the profile folder is a folder called "extensions". Rename that to
> "extensions-xx" and your problem is solved. Of course all your extensions
> will disappear this way.
> 
Ok I went to my profile but there is four more folders. Each one has the same folders in them.  Do I rename each extension folders?  BTW I never added any add on in Thunderbird that I'm aware of.

Comment 55

2 years ago
Do you have four profiles? Just rename the extension folder of the profile you're really using. Or if your unsure, rename them all. The only add-on that gets installed automatically unless you chose not to, is the Mozilla Calendar "Lightning". That is currently causing a lot of update problems.

Comment 56

2 years ago
(In reply to Jorg K (GMT+1) from comment #55)
> Do you have four profiles? Just rename the extension folder of the profile
> you're really using. Or if your unsure, rename them all. The only add-on
> that gets installed automatically unless you chose not to, is the Mozilla
> Calendar "Lightning". That is currently causing a lot of update problems.

Thank you.  Renamed all extension folders in all 4 profiles.  I wasn't sure of which one so did all.  Now it's back to normal.  Thank you again.

Comment 57

2 years ago
Will we be notified in this link when the problem is corrected with a new Update? I am not taking updates until this is corrected.  Thx

Comment 58

2 years ago
tomartel: If the issues being reported here are identified and fixed, yes there should be some notes here about that.

The current status is that we've seen a few profiles, and they show evidence of missing files in "unpack" type extensions after update. This is likely some subtle issue in the core Mozilla addons code. Unfortunately nobody yet has a good idea of the root cause of this, nor is there a known reproducible case, and with that it is hard to fix.

The very similar issue in bug 1211160 has been fixed. That is related to roaming profiles, so if those are in use they are likely the cause, and the fix is in place.

Comment 59

2 years ago
Has this issue been fixed?  I'm still using Ver 38.5.1 and not accepting updates.  I see the latest ver is 45.0.  I'm curious how you moved from 38.5 ot 45 so quickly.   Should I begin to accept updates?  Thx

Comment 60

2 years ago
TB 45.x has been out for a while, right now we're at TB 45.1.1.
Thunderbird only does ESR releases, so the number jumps by 7: 31, 38, 45 and 52 early in 2017.
Sure, you should upgrade since TB 45.x is much better than TB 38.

Updated

2 years ago
Blocks: 1215828

Comment 61

11 months ago
Tom and Frank report they no longer see this issue.

Does anyone still encounter this on updates?
Whiteboard: [closeme 2017-09-15 WFM]

Comment 62

10 months ago
Resolved per whiteboard and Comment 61
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-09-15 WFM]
You need to log in before you can comment on or make changes to this bug.