[UserStory] Printing of basic pdf file

RESOLVED WONTFIX

Status

()

defect
P3
normal
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: yury, Unassigned)

Tracking

(Depends on 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfium-viewer-mvpscope] )

Reporter

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1268829 +++

+++ This bug was initially created as a clone of Bug #1264551 +++

The bug is to correctly print the basic pdf file.
http://www.orimi.com/pdf-test.pdf

This is a feature the users complain the most about PDF.js viewer. (A web page cannot fully control printing and produce vectorized output of the canvas on some platforms)

It unique from Flash support (bug 1264552). This concern shall be addressed as part of bug 1264551 IMHO.

Updated

3 years ago
Blocks: 1273059

Updated

3 years ago
No longer blocks: 1273059

Updated

3 years ago
Blocks: 1273066

Updated

3 years ago
No longer blocks: 1273066

Updated

3 years ago
Blocks: 1283028

Updated

3 years ago
No longer blocks: 1283028
Blocks: 1297579
No longer blocks: 1297579
Blocks: 1307709
No longer blocks: 1307709

Updated

3 years ago
Duplicate of this bug: 1328215

Updated

3 years ago
Assignee: nobody → fatseng
Group: mozilla-employee-confidential

Comment 2

3 years ago
Jet, I just dup bug 1328215 to this one, but I can't setup triage owner for you. Please feel free to attach yourself here. :)
Flags: needinfo?(bugs)

Updated

3 years ago
Depends on: 1295109

Updated

3 years ago
Depends on: 1286498

Updated

3 years ago
Depends on: 1309441
No longer depends on: 1286498
No longer depends on: 1309441
Duplicate of this bug: 1321236

Updated

3 years ago
Depends on: 1309441
Whiteboard: [pdfium-viewer-mvpscope]
No longer depends on: 1345710
No longer depends on: 1345783
No longer depends on: 1345786
No longer depends on: 1345789
No longer depends on: 1329881

Updated

2 years ago
Depends on: 1335664
Flags: needinfo?(aschen)
No longer depends on: 1295109
Flags: needinfo?(aschen)
Priority: -- → P3
Flags: needinfo?(bugs)
Assignee: fatseng → nobody

I'm closing this bug as WONTFIX per:

"The Mortar experiment has concluded. Mozilla does not consider the PDF use case justifies the burden of implementing and maintaining PDFium and a Pepper API implementation in Gecko."

Source: https://wiki.mozilla.org/Mortar_Project

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.