Chatzilla tabs should resemble tabbrowser tabs

RESOLVED INVALID

Status

Other Applications
ChatZilla
RESOLVED INVALID
16 years ago
5 years ago

People

(Reporter: Garth Wallace, Assigned: Robert Ginda)

Tracking

(Depends on: 2 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
As a matter of UI consistency, Chatzilla's tabs should look like the browser's tabs.

Comment 1

16 years ago
And how don't they look like them?  They're the same tabs.  Or do you mean that
they aren't on top?
(Reporter)

Comment 2

16 years ago
They're not on top, they lack a close button, and they're missing the small bar
between the content area and the tabs that makes them look connected.

Comment 3

16 years ago
Created attachment 75767 [details]
corrupted tab separation

This also applies to bug 114742.  If either the fourth or fifth tabs are
selected, or by extension the eighth or ninth, then the tab painting does not
distinguish it from the background.

Comment 4

16 years ago
Amen.  Tabs are non-standard already; let's not make it harder than need
be by having 2 different interfaces.

I'd also add: cmd-W should close the current tab only, and show the tabs
based not on a menuitem buried in a sub-menu, but by the same criteria the
browser uses, i.e., show the tab bar if-and-only-if there is more than one
tab.

(See also bug 122902, which is specifically about the close-box; would that
be a dupe?)
(Reporter)

Comment 5

16 years ago
Bug 122902 would block this one.

Of course, most of the time there will be more than one tab. Each server you
connect to gets a tab, as does each channel, and each private conversation. If
you only have one tab open, you're not connected to any servers.

Comment 6

16 years ago
For my usage, at least, most of the time there's no more than one *useful*
tab.  The "*client*" and "irc.wherever.org" tabs seem to serve no useful
purpose, besides bootstrapping into a channel window.

Navigator, Mail&News, etc., don't have an extra tab for communicating
directly with the server, and they don't start up with a blank tab where
you have to type in a /special /language to use it ("Type /help ..."!).
I hope these things are temporary and will eventually disappear, and
Chatzilla will start behaving like the other Mozilla applications.
(Reporter)

Comment 7

16 years ago
I agree that I find *client* to be pretty useless. But the server tab is used
for the responses to certain commands that report on the status of the server,
such as /list.

Comment 8

16 years ago
Elsewhere in Mozilla, they typically use a (XUL) list box to display a list
of items, usually as the result of selecting a menuitem.

Granted, giving everything in "Currently implemented commands are [...]"
a decent user interface will take some time, but eventually the server tab
shouldn't be needed, either.

Comment 9

16 years ago
Ken, have you used any other irc client before?  This is pretty standard look
and feel.  Now that doesn't mean we can't do better, but we'd need a pretty good
demonstration that it would be better before changing things.  If you would like
to describe ui changes in a new bug or an appropriate existing bug, we would be
happy to see it.
(Assignee)

Comment 10

16 years ago
If you have at least one other tab open, you can /delete the client tab.  If you
have at least one other view set to open at startup, you can deselect the open
at startup option on the *client* view.

Aside from showing the welcome message and list of networks at startup, the
*client* view can be used to evaluate arbitrary javascript, without requiring
the /eval command.  Useful if you have the need for a js scratchpad, or want to
poke at chatzilla while it's running.

As far as the server views go, you're kinda stuck with them for now.  That's
just the way it's done.  Once you're connected you could /delete the view, and
it'll come back if another message is posted to the view (like if you have "Copy
inportant messages" turned on, or you could /hide it and it won't.  If you do
/delete or /hide, and feel the need to get it back, just /attach to it again. 
ChatZilla will see that you're already attached, and just display the view instead.

Comment 11

16 years ago
Samuel: sure, several.  This is only "standard look and feel" for text-based
clients, like ircII.  See http://www.losttreasure.com/mircimages/mirc9.gif
for an example of how a graphical client can present a list of channels to
the user nicely, without requiring him to type special commands.  As an example
in Mozilla itself, go to Mail&News, click on a news server, and click "Subscribe
to Newsgroups" -- you get a scrollable list of newsgroups on that server.

Point taken that we're "kinda stuck with them for now", but I don't think there's
anything that says bugs in Bugzilla have to be closed in /n/ days.

Comment 12

16 years ago
Subscribing to the request.

Tabs in Chatzilla should be similar to the tabs in browser with close button and 
right-click menu on them, context menu that also offers close command

Comment 13

16 years ago
I would like to have Chatzilla open its main window inside a browser tab (always
optional), to have only one Mozilla window.
Is it too hard to implement such a feature?
(Reporter)

Comment 14

16 years ago
That would be an unrelated feature request. It has nothing to do with getting
the tabs within Chatzilla to resemble tabs in the browser.

Updated

15 years ago
Blocks: 122902
(Reporter)

Comment 15

15 years ago
Bug #122902 blocks this, not the other way around. Correcting.
No longer blocks: 122902
Depends on: 122902

Comment 16

14 years ago
additional request: middle click on a tab should close it

Comment 17

14 years ago
(In reply to comment #4)
> I'd also add: cmd-W should close the current tab only

Current ChatZilla versions do this.

(In reply to comment #16)
> additional request: middle click on a tab should close it

And this, though they hide the tab instead of closing it.
Product: Core → Other Applications

Comment 18

13 years ago
Notes about the multiple window plan:

 * Multi-window stuff will move tabs to the top.
 * Close button is NOT going on the tab row (makes no sense).
 * "show the tab bar if-and-only-if there is more than one tab" is bad UI, so is
not happening. Tabs will always be shown if you are using a tabbed layout (the
drag-drop code may optimise-away a tabbed view with a single view on it, but the
tabbed view itself will never hide its own tab bar).
Depends on: 76175

Comment 19

12 years ago
Alright, there's a whole bundle of concerns here worded vaguely as 'resemble tabbrowser tabs'. The point here is, that all these concerns are by now either fixed or covered by more to-the-point bugs, without a whole bundle of advocacy about how an IRC client or Mozilla app should behave. I'm closing this bug as INVALID. For all the issues raised here:

- Tabs at the top (and/or 'small bar to make them appear connected'), work done in bug 76175.
- Close button for tabs, work done in bug 122902.
- Context menu on tabs, was added ages ago in bug 116013.
- Tab separation feature, was removed by bug 114742.
- Command-W closes current tab, probably also fixed by bug 116013 (not sure on bug #, but definitely fixed).
- See comment 10 for more about hiding server/client tabs. There's a bug about the server tabs, which is bug 249188.
- There has been a "Join Channel" dialog for some time now, see bug 107245.
- There's a bug about changing to a treeview instead of tabs, which is bug 322542.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

5 years ago
Duplicate of this bug: 850405
You need to log in before you can comment on or make changes to this bug.