Open Bug 76175 Opened 19 years ago Updated 4 years ago

Chatzilla doesn't support multiple windows

Categories

(Other Applications :: ChatZilla, enhancement)

enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: mpt, Assigned: rginda)

References

(Depends on 1 open bug, Blocks 4 open bugs)

Details

Build: 2001041308, Mac OS 9.1

To reproduce:
*   Open Chatzilla.
*   Choose `New Chat Window' from the `File' menu.

What happens:
*   The item isn't there.
Chatzilla doesn't support multiple windows, hence the missing menu item.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
I know, that's why I filed the bug.
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Can't open a new Chatzilla window → [RFE] Chatzilla doesn't support multiple windows
Being able to have several windows seems essential: I find myself 
switching to a tab that has gone red again and again only to find out
that what is new is not interesting. To or more windows side by side
would just require a short glance for that.
The "floating views" that I'm working on for venkman could probably be ported to
chatzilla when the command manager comes over.  See
<news://news.mozilla.org:119/3CCE2003.5020704@netscape.com>.
Remove myself from QA of 33 open Chatzilla bugs and change to default QA
contact, since I have no way to verify these easily.  Still no working Mozilla
on my primary platform and it doesn't look like it will happen anytime soon. :(
QA Contact: mozilla → samuel
Summary: [RFE] Chatzilla doesn't support multiple windows → Chatzilla doesn't support multiple windows
*** Bug 212558 has been marked as a duplicate of this bug. ***
*** Bug 250413 has been marked as a duplicate of this bug. ***
I believe this is a WONTFIX
related: bug 70245. See also bug 111891, bug 231156
I'd say it's not WONTFIX as /such/, as one thing we've got planned is multiple
windows for ChatZilla, but it's more being able to undock channels and stuff,
not sure if each window would get the full complement of UI.
the comment was really intended for bug 250413, which isn't really a dup:
Multiple windows isn't the same as MDI tiling.
Product: Core → Other Applications
Assignee: rginda → silver
Status: REOPENED → NEW
Status: NEW → ASSIGNED
Blocks: 110550
Blocks: 114742
Blocks: 129913
Blocks: 194913
Blocks: 249188
Blocks: chatzilla1.0
Depends on: 342988
Blocks: 349086
adding myself as CC
Depends on: 391842
No longer blocks: 194913
QA Contact: samuel → chatzilla
Assignee: silver → rginda
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.