Closed Bug 1309486 Opened 6 years ago Closed 6 years ago

Incorrectly uses "From" email while is should use the "reply-to" or "list-post" headers/emails

Categories

(Thunderbird :: Untriaged, defect)

51 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: martin.monperrus, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160926162149

Steps to reproduce:

I reply to Github notification emails by using "Ctrl R" (simple reply).


Actual results:

The email is lost. My comment never arrives to the corresponding Github issue page.


Expected results:

The reason is that the Github email contains three headers:

From: John Doe <notifications@github.com>
Reply-To: INRIA/spoon <reply+000c4352400071c00011414710392a169ce0adc6133@reply.github.com>
List-Post: <mailto:reply+000c4352400071c00011414710392a169ce0adc6133@reply.github.com>

When I press Ctrl-R, Thunderbird uses the "From" address which is incorrect (notifications@github.com is a no-reply sink).

In this case, I expect that Thunderbird uses  either the "Reply-to" or the "List-post" address.

(Note that repliy-to-list works).
Yes, this was changed in bug 77304.

You need to "Reply List" now.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 77304
Let me make this the master bug for all the complaints we had about the new feature. Please leave it at WONTFIX.
Resolution: DUPLICATE → WONTFIX
Duplicate of this bug: 1372908
Duplicate of this bug: 1354093
Duplicate of this bug: 1367729
Magnus, we had a lot of complaints about what we implemented in bug 77304, see duplicates here. Do you think we should do something about it?
Flags: needinfo?(mkmelin+mozilla)
Duplicate of this bug: 1373181
This really can't be left as a WONTFIX. It's clearly broken behaviour, in direct contravention of RFC 822.

It also still seems to be generating unexpected behaviour, even when this is taken into account. I tested it with a mailing list I belong to, which adds the list address as the Reply-To. I included a Reply-to in my message which the list sfotware appended with its own address, resulting in this set of incoming headers:

From: mark@good-stuff.co.uk
Reply-To: mark@goodge.co.uk, [list address]
List-Post: <mailto:[list address]>

and when I clicked 'Reply' on Thunderbird, it sets up the following set of outbound header fields:

From: mark@good-stuff.co.uk
Reply-to: mark@goodge.co.uk
Reply-to: [list address]
To: [list address]

That's wrong on all sorts of levels. It isn't doing what it's documented as doing now (which is ignore the Reply-to altogether), but it isn't doing what I'd normally expect it to do (which is reply to the Reply-to). On the other hand, clicking on the 'Reply List' button replies to the list address. So the Reply-to is not being replied to, even when explicitly set to be different to both the From address and the list address.  

FWIW, I'd argue that the correct behaviour is that the 'Reply' buttion should follow RFC 822 (use Reply-to if set, and From if not), while 'Reply List' should override that and always use the list address. 

I'm not sure that bug 77304 really was a bug at all, as the previous behaviour was precisely that mandated by RFC 822, even if it can be somewhat counter-intuitive in a list setting. If we really want to allow explicit reply to sender, even when Reply-to and List-Post are both set, then add a 'Reply Sender' option in there somewhere (but users should be aware that that may not work, as the From address may be a no-reply address - which is another reason why it's horribly, horribly wrong to simply disregard Reply-to). Don't try to fix someone's bad experience with a mailing list by breaking it for everyone else!
The way I read bug 77304, it doesn't request a change to the (old) "Reply" behaviour as such; it just asks for *some* (possibly different) way to reply to the "From" address. An extra "Reply Sender" button might give the reporter precisely what he wants (if he cares at all any more - the issue is from 2001.)
Comment from Mrten via private message:

===
Today, I tested the behavior of major mailers to test the behavior of "Reply" when all three headers From/Reply-To/List-Post are present in an email.

Here are the results:

Gmail: "Reply" goes to reply-to address
Zimbra: "Reply" goes to reply-to address
Horde/IMP: "Reply" goes to reply-to address
Outlook Web: "Reply" goes to reply-to address
Yahoo: "Reply" goes to reply-to address
Roundcube: "Reply" goes to reply-to address

Evolution:
"Reply" asks the following question and saves the answer, hence the behavior is configurable:
You are replying to a message which arrived via a mailing list, but you are replying privately to the sender; not to the list. Are you sure you want to proceed?
Reply Privately -> goes to reply-to address
Reply to List -> goes to list-post address
Reply to All
===

My comment: There doesn't appear to be an option to reply to the original sender only.
Just summarising what we're discussing. Here is the code change:
https://hg.mozilla.org/comm-central/rev/b91eb48f1dae#l2.43

Old state:
If Reply-to is not empty, always use it as recipient of the reply.

New state:
If Reply-to is not empty, use it as recipient of the reply
  unless there is also a coinciding list-post header.
  In this case use the original From header.

The argument was to allow users to reply to the original poster as requested in bug 77304 and its 10 duplicates. People wishing to reply to the list can still do so.

Note bug 1322136.
How does the new code cope with the situation where someone explicitly sets a Reply-To address on their outbound mail, and then posts to a list that doesn't use Reply-to munging? 

From my reading of the code, there's no way to reply to the sender's preferred reply address (other than manually editing it in the To field, obviously) - choosing 'reply' will disregard the Reply-to and send to the From, whereas 'reply list' goes to the list.
Summary: Incorrectly uses "From" email while is should use the "reply-to" or "list-post" headers/emails (Github email communication broken) → Incorrectly uses "From" email while is should use the "reply-to" or "list-post" headers/emails
(In reply to MarkSG from comment #13)
> How does the new code cope with the situation where someone explicitly sets
> a Reply-To address on their outbound mail, and then posts to a list that
> doesn't use Reply-to munging? 

Then the Reply-To of the sender is respected. It's only disregarded for reply-to munging.
(In reply to MarkSG from comment #9)
Please don't test on your own messages. If you reply to self, it's treated as a followup (same headers as originally kept) - this has nothing to do with this bug.
Flags: needinfo?(mkmelin+mozilla)
I'd like the case of multiple addresses in Reply-To to be accounted for, but other than that I don't see a good reason to revert the change. All reply possibilities are now accessible, which they weren't previously. It's only that you have to use another button if reply-to munging was involved.
Thunderbird is the unique major email client to use this behavior, all others use the reply-to field (see https://bugzilla.mozilla.org/show_bug.cgi?id=77304#c93). One reason to revert could be the principle of least surprise in UX (https://en.wikipedia.org/wiki/Principle_of_least_astonishment).
(In reply to Magnus Melin from comment #15)
> (In reply to MarkSG from comment #9)
> Please don't test on your own messages. If you reply to self, it's treated
> as a followup (same headers as originally kept) - this has nothing to do
> with this bug.

That's even more daft. If I send a message to a list, then my message should, when it returns to me, be treated exactly the same as any other list message.

I agree with the comment above from martin.monperrus. This change puts Thunderbird out of step with every other major mail client. Even if we accept the argument that RFC 822 has been superseded and therfore we are free to ignore its principles for handling Reply-to, the reality is that RFC 822 behaviour is embedded as the norm across the entire industry. Going off on a tangent just to fix some ancient "bug" (reported 16 years ago, and at the time itself marked as a INVALID!) seems wholly unjustifiable.

Please revert this. Or, even better, do what the original reporter of bug 77304 wanted, which was to *add* a 'reply sender' option, or allow the behaviour to be customisable by the user. 

In the meantime, this is a killer bug for me; I've downgraded to TB 45 and will stay there until TB either returns to the same default handling of Reply-to as every other mail client or allows me to configure it to do so. Life is too short to have to remember to click one button on every other mail client I use and a different one on TB.
(In reply to Magnus Melin from comment #16)
> I'd like the case of multiple addresses in Reply-To to be accounted for, but
> other than that I don't see a good reason to revert the change. All reply
> possibilities are now accessible, which they weren't previously. It's only
> that you have to use another button if reply-to munging was involved.

I think you are missing part of the point. It's not just about having "all reply possibilities", but also being able to reply in the manner that's recommended for a particular mailing list. For some types of high-volume lists, people are generally encouraged to contact the original sender directly unless they *know* the follow-up is of high public interest. Other lists are intended as more of a forum, and replies should really go to the list all the time - unless, perhaps, you start some kind of  private conversation that's completely unrelated to the original subject. These recommendations are generally encoded in the Reply-To. If the list admin thinks most replies should be private, he simply makes sure no Reply-To information is added by the list software, while if he's running a "forum" type list, he sets up so that Reply-To is set to the list address.

With the update discussed here, there is as far as I can tell no way to respond to a mailing list post the way the list admin intended. This really makes Thunderbird a lot less usable if you are on many mailing lists.
The list admin can't know which reply type you need for each message, only you can.

There is general consensus munging is harmful, so please don't debate that here.
https://woozle.org/~neale/papers/reply-to-still-harmful.html
It's not a consensus.

http://marc.merlins.org/netrants/reply-to-useful.html

And even if there is general agreement that munging is usually the less optimal solution, there are specific cases where it is useful. And, either way, that's for the list admins and users to debate among themselves. Mail clients shouldn't be overriding that choice.
I hate to say it, but I think the current state of the software, ignoring Reply-to when it has been "munged" to match the List-post header, is best. Looks like this has turned into a religious war.

Personally I think
https://woozle.org/~neale/papers/reply-to-still-harmful.html and
http://www.unicom.com/pw/reply-to-harmful.html are more convincing than
http://marc.merlins.org/netrants/reply-to-useful.html.
It's only become an extension of the Reply-to religious war because TB is now out of step with every other major mail client, though.

Whether Reply-to munging is a good or bad thing can, and will, be endlessly debated. But it's a debate for list admins and their users. It's simply wrong for a mail client to take a side in that war.
(In reply to Jorg K (GMT+2) from comment #22)
> I hate to say it, but I think the current state of the software, ignoring
> Reply-to when it has been "munged" to match the List-post header, is best.
> Looks like this has turned into a religious war.
> 
> Personally I think
> https://woozle.org/~neale/papers/reply-to-still-harmful.html and
> http://www.unicom.com/pw/reply-to-harmful.html are more convincing than
> http://marc.merlins.org/netrants/reply-to-useful.html.

I have to say I don't follow with some of what's being said there; for instance

> When they hit "reply" they want it to go to the person who wrote the message. 
Actually, when I hit "reply", I want to respond in the way that seems most appropriate for the message and context. In a mailing list context, that's generally to send a message to the mailing list, and not to the original sender. And it would seem that other people on lists I follow feel the same way. I also don't really understand the bits about sending private replies to the list by mistake. What private replies? For the lists I have in mind, the only reason I can think of to follow up on a discussion privately would be that you are going to respond in way that's too abusive or impolite for the public to see, but in that case, perhaps you'd better not hit any button at all. And if your response is not relevant to the discussion at hand, the function to use is "Write", or possibly "Compose new message to".

But be that as it may. I think MarkSG is right here; whether or not it's correct to set up the messages this way is really besides the point. Thunderbird should just handle messages the way it's instructed via the messaging headers. It's not its business to try be clever and "correct" the information it gets.
(In reply to Magnus Melin from comment #20)
> The list admin can't know which reply type you need for each message, only
> you can.
Actually, the convention is that it's not really up to me to decide where normal replies should go; instead the sender requests that they are delivered to a specific address. This is what the Reply-To header is all about. And for mailing list messages, I think you may say that the actual sender is the list system represented by a list admin, as opposed to the person who wrote the message, or differently put, list admins get to have a say in how people should communicate over the list; this is something you implicitly accept when you subscribe to it.

I may have good and valid reasons not to honour the requests of the sender or list admin, and yes only I can know what those reasons might be, but that's not the same thing. The problem is that now I can't even know what was requested, and that's *bad*, IMO.

Also, surely a better and more complete resolution of bug 77304 would be to add a "Reply to From address" option that completely ignored the "Reply-To" regardless of whether a list address was involved? After all, the request didn't originally mention mailing lists at all.
> Also, surely a better and more complete resolution of bug 77304 would be to add
a "Reply to From address" option that completely ignored the "Reply-To"
regardless of whether a list address was involved?

This would be along the line of what Evolution does. In Evolution, "Reply" triggers a modal dialog: "You are replying to a message which arrived via a mailing list, but you are replying privately to the sender; not to the list. Are you sure you want to proceed?"
Duplicate of this bug: 1377850
Sorry guys, if religious or not. TB was a good MUA for mail and for mailinglists, for me for about 15 years. Now, with the new behaviour it is not any more.

If I see a mail I want to reply to, I hit Ctrl-R. In all normal situations it was sent to where I wanted it to be. If I answered a private mail the reply was sent to the sender. If I hit Ctrl-R at a mail in a mailinglist, which set Reply-To, the mail was sent to the mailinglist. That was logical. In a mailinglist I always want to answer to the list, extremely seldom I want to send a mail to the sender ...

Since the last update I answered a lot of mails in mailinglists and wondered, why they didn't arrive in the mailinglist after a few minutes and then ... "Ahhrgh! TB changed behaviour! ... goto Sent, copypaste mailcontent, do Reply-To-List... paste ..." 

Sorry again, but this is so silly ... why the heck is Reply-To set by mailinglists? That new TB has a nice thing to ignore???
(In reply to 4titov from comment #28)

I fully agree. Such a fundamental change after years! So many emails were lost for the rest of my mailinglists, because neither me nor the From person have even realized that my replies didn't go to the entire list. Please revert the old behaviour back. You can make the current implementation optional in the settings.
> Let me make this the master bug for all the complaints we had about the new
> feature. Please leave it at WONTFIX.

Why WONTFIX? It ist a nasty, annoying bug! Introduced as a fix for https://bugzilla.mozilla.org/show_bug.cgi?id=77304 , this is not a fix for that but instead creates new unwanted behaviour.

Now I have to differ, if I answer to a mail in a mailinglist or to a mail from a single sender. I cannot easily answer to a mailinglist any more! Please open that bug again and revert ASAP.

(In reply to Jorg K (GMT+2) from comment #3)
(In reply to 4titov from comment #30)
> I cannot easily answer to a mailinglist any more!
Clicking "Reply List" is not an option for you?
(In reply to Jorg K (GMT+2) from comment #31)
> Clicking "Reply List" is not an option for you?

Not an option for me. Sometimes, I reply to lists 20 times a day. Each time, do I have to remember not to use CTRL+R as I did for years? This is clearly a regression (for no serious reason).
(In reply to Jorg K (GMT+2) from comment #31)
> (In reply to 4titov from comment #30)
> > I cannot easily answer to a mailinglist any more!
> Clicking "Reply List" is not an option for you?

No, it is not an option. Because I always answer to a mail, about 50 to 100 times a day. I do not differ between a mail coming from a mailinglist and a mail coming from a single sender. I reply ... no ... I replied, for 15 years, till now ... :(

The mailinglist (ML) sets Reply-To to ensure, that my answer goes the right way. In case of a ML to the address of the ML (and not the sender)! That is the natural receiver for mails to a ML so that the program behind the ML can spread the mail to the other members of the list.

If I have to click "Reply List", first I have to check, if the mail I'm answering to, originates from a ML. I do not do this all the time. Why? I never needed it! And how should I check (except the fact, that I personally filter mails from MLs to different folders), whether the mail came from a ML? Hitting Ctrl-U and inspecting the source?

For me this new behaviour is be the same as if – hypothetical – I had to check first, if the mail came from a single sender (by hitting Ctrl-U), and then had to click a "Reply To Sender" instead of "Reply", because "Reply" does something other. I think, that would annoy you!

I have thousands and thousands of mails in TB, I am member in over 20 mailinglists and used TB for a very long time. But because of this new behaviour I would have to choose another MUA, that does its job right and respects Reply-To.
(In reply to 4titov from comment #33)

> I have thousands and thousands of mails in TB, I am member in over 20
> mailinglists and used TB for a very long time. But because of this new
> behaviour I would have to choose another MUA, that does its job right and
> respects Reply-To.

Downgrading to version 45.8 is the simplest solution, unless you actually need one of the features or bugfixes introduced in the 5x.x branch. It will install in place over the top of the latest version with no adverse effects. You just have to be sure to disable automatic updates once you've done it. Pick your OS from here:

https://archive.mozilla.org/pub/thunderbird/releases/45.8.0/

In fact, I'd recommend that generally at the moment, as there are other issues with the 5x.x branch that seem to be affecting a fair number of people. It's probably better to stay off auto-update until all of them, including this one, have been resolved.
(In reply to MarkSG from comment #34)
>
> https://archive.mozilla.org/pub/thunderbird/releases/45.8.0/

Oh cool, thank you! That worked fine. Had also to install a downgraded version of enigmail.

> In fact, I'd recommend that generally at the moment, as there are other
> issues with the 5x.x branch that seem to be affecting a fair number of
> people. It's probably better to stay off auto-update until all of them,
> including this one, have been resolved.

Yes, I hope so. Merci bien.
I'm glad I took the time to research TB's new unexpected Reply behavior. I've read the comments, and it seems clear that although the change was intentional, it was clearly the wrong solution to the request.

As has been documented, every other MUA handles the Reply-To header like TB *used* to, or at least they ask what you'd like to do. For TB to completely ignore that header is ridiculous.

Asking users to downgrade in order to get expected, conventional, and normal functionality as a long-term solution is ridiculous as well. Maybe I should just go back to Netscape Navigator...

I cannot believe that such a drastic change change to the Reply (Ctrl+R) behavior was warranted by the original request. I'm not against *adding* the functionality requested, nor giving a user the option of choosing which behavior they would like, but removing normal functionality for the rest of us is ridiculous.

Seriously, this is just plain silly. Those of us who have been using this software since 1995 don't expect drastic behavior changes like this. We use TB because it does the *right thing*. Sadly, in this situation it no longer does.

(In reply to MarkSG from comment #34)
 
> In fact, I'd recommend that generally at the moment, as there are other
> issues with the 5x.x branch that seem to be affecting a fair number of
> people. It's probably better to stay off auto-update until all of them,
> including this one, have been resolved.

Should that give us hope that this problem will be resolved?
Duplicate of this bug: 1379428
This has clearly become a religious war with many parallels to the "reply-to harmful/useful" war. Any arguments I could make have already been made in this thread. I am only commenting because I am a GNU Mailman core developer, and as such, my perspective might be interesting.

First let me say that the developers of GNU Mailman believe that Reply-To: munging is bad. It only exists at all as a feature in GNU Mailman because of intense demand. Comments in the code by another developer say:

    # Yuck, I really hate this feature but I've caved under the sheer pressure
    # of the (very vocal) folks want it.

The point is that whether we agree or not, the people who configure their lists this way, do so for a reason. It is not necessary to do so. Reply-List, where available, will reply to the list, and in the absence of that, Reply-All is arguably even better, but the people who configure their lists to munge Reply-To: do so because they want "Reply" to go to the list. For an MUA to say there's another way to reply to the list so if you "Reply" you must want to reply to the sender is not a decision an MUA should be making.
"Wontfix"? Intentionally ignoring the Reply-To header is bad form, and contrary to expected and desired results, even if it's not technically in violation of the relevant email RFCs.

List owners set up Reply-To <list-address> for a specific reason - I happen to now be one of them. Jumping through hoops to reply to a mailing list TO THE MAILING LIST when the list mails instruct the client to do so is reason enough to find an alternate mail client.
Please fix this. Newer versions of TB are useless for me if it's going to ignore the reply-to header.
Originally, in bug : https://bugzilla.mozilla.org/show_bug.cgi?id=77304
quote: In a mail containing both a Reply-To: and From: header entries, replies cannot
be made to address in From: field....
Steps to Reproduce:
1.Send an e-mail to oneself with a Reply-To: field
2.Reply to it (using Reply All)

unquote

it would seem that because some people wanted to 'Reply-All' to include the original senders email address when the 'sender' clearly did not want to be replied to because they set a 'Reply-to' header, the result being that everything was changed if the 'Reply-to' happened to be a mailing list.

One would have expected the 'Reply-all' to be the only part to be changed by including the 'From' when a 'Reply-to' has been set.

Instead, there is now a confusing or iritating situation which is probably causing more grief than intended, where you would expect a 'Reply' to reply to the 'From' email address unless a 'Reply-to' header has been intentionally included.
This works as expected unless the 'Reply-to' header happens to be a mailinglist, at which point the behaviour alters.

The result being emails could accidentally be sent to the wrong recipients.

If a received email has a 'Reply-to' header with an ordinary email address AND a mailing list.
Reply replies to the 'FROM' address.
Reply-List will reply TO the mailing list.
Reply-All will only reply TO both items in the 'Reply-to' header.


But having two actions for a 'Reply-to' header does not appear to be well received.
Could the original bug have been sorted by adding the FROM to the 'REply-all' and left the 'Reply' function alone?
Duplicate of this bug: 1387822
I've managed to misdirect dozens of messages because Thunderbird now ignores Reply-To on mailing lists.  Instead of going to the mailing list, my messages end up going only to the original sender of the message I'm replying to.  That is almost never what I want to happen.

I could not find any keyboard shortcut for the "Reply List" button, which means I have to resort to the mouse -- assuming that I even remember that the message I'm replying to requires a different action.  Normally I don't remember that.  For DECADES, with several email programs, I have pressed Ctrl-R on the keyboard to reply to any message.  Until very recently, this always gave me exactly what I was looking for.

I can understand giving people the *option* of changing this kind of behavior, but that does not appear to be what was done here.  A fundamental email client behavior was altered with no apparent option to undo the change.
The only (In reply to Shawn Heisey from comment #43)

> A fundamental
> email client behavior was altered with no apparent option to undo the change.

The only reason that I can imagine this was done for is, that the person who decided this never used a mailinglist.
I just want to say, religious war or not, most other email clients treat the reply-to in the original way (thinking of gmail, which I apparently will need to start using...) and the change is just so surprising. I too have managed to misdirect dozens of messages. One does not expect that something as simple will start working so  inconsistently all of a sudden.

This change should have been introduced as a configuration option defaulting to the previous behavior. Now the damage is done.
Bug 1392371 is a proposal to resolve this problem: 
add option to configure reply behavior when "reply-to" header is set by mailing lists

DOn't hesitate to follow or vote for it.
(In reply to martin.monperrus from comment #46)
> Bug 1392371 is a proposal to resolve this problem: 
> add option to configure reply behavior when "reply-to" header is set by
> mailing lists
> 
> DOn't hesitate to follow or vote for it.

Done.
Okay, I got so frustrated by this that I wrote an Add-on. Until Mozilla figures this out, people like me can just enable the Add-on and get back the previous functionality. https://addons.mozilla.org/en-US/thunderbird/addon/stop-ignoring-reply-to/
(In reply to Cassandra Gelvin from comment #48)
> Okay, I got so frustrated by this that I wrote an Add-on. Until Mozilla
> figures this out, people like me can just enable the Add-on and get back the
> previous functionality.
> https://addons.mozilla.org/en-US/thunderbird/addon/stop-ignoring-reply-to/

Thank you!
It is a sad day when basic normal intuitive functionality expected in an email client such as correct reponse to a 'Reply-to' header needs an addon in order to fix what people may regard as a dreadful mess causing emails to be sent to wrong people.

This all started because someone wanted to reply to the 'From' email address and not the 'Reply-to' which the sender wanted them to use. 
The 'Reply-all' did not include the 'From' when a  'Reply-to' was set.
They wanted the 'From' to be included when they used 'Reply-all'. 

I do not recall anyone asking that the default in Thunderbird upon clicking 'Reply' was to completely ignore 'Reply-to' header if a list was inserted as a means of including the 'From' in the 'REply-all' when a list was in a 'REply-to'.

I'm astonished at the unwillingness of accepting when a mistake has occured - some bugs get few complaints, but the response from various people and support forum complaints on this issue is not one or two unhappy bunnies.

Are those who created this problem (albeit with good intent) the same people who are not willing to accept their error of judgement and this is the reason for not wanting to fix it?
Dear Anje, thank you for sharing your concern. However, your post is not helpful (and somewhat polemic, "it is a sad day", "are not willing to accept their error of judgement") since it overly simplifies the issue.

The issue is this: Some mailing list administrators use "reply-to munging". They set the Reply-To header and the List-Post header to contain the same address. There is a religious war going on about whether this is a good or bad thing. Please refer to
Against munging: http://www.unicom.com/pw/reply-to-harmful.html
In favour of munging: http://marc.merlins.org/netrants/reply-to-useful.html.

In bug 77304 Thunderbird changed behaviour
https://hg.mozilla.org/comm-central/rev/b91eb48f1dae#l2.49
and now sends the reply to the address in the From header instead of the Reply-To only if munging was detected. Replying to the list is still available via "Reply List".

It seems that the opponents of that change are very vocal, whereas other people have nothing to complain about. They consider the change an improvement of the functionality since "Reply" and "Reply List" gives them different behaviour and hence (perceived) richer functionality.

The decision has been made by Magnus, the Thunderbird module owner, that the change won't be reverted. However, as volunteer driven open source project we will consider accepting a patch to implement an option to restore the behaviour. That can happen in bug 1392371. The effort to implement his is about one hour. All you need to do is define the preference, say mail.undo_munging, and add about five lines of code to read the preference adjust the behaviour accordingly. In fact, could have finished the patch in the time I've been writing this post.

I think in this discussion everything has been said, so I'm closed the bug for further comments.
Restrict Comments: true
Of course I meant to say: I'm closing the bug for further comments. I've written a patch in bug 1392371 which is now pending review.
I implemented a preference mail.override_list_reply_to in bug 1392371. When set to false (default: true) this will restore the TB 45 behaviour. This will ship in TB 52.4 at the end of September, so you can count the sad days until then ;-)
Duplicate of this bug: 1428071
You need to log in before you can comment on or make changes to this bug.