Closed Bug 1324582 Opened 3 years ago Closed 3 years ago

Pref off full-duplex for Windows and Mac in beta

Categories

(Core :: WebRTC, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox51 + fixed

People

(Reporter: jesup, Assigned: jesup)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

[Tracking Requested - why for this release]:
Must be preffed off for release

+++ This bug was initially created as a clone of Bug #1311050 +++

There are still issues with device switching in full-duplex on Windows.  Preffing off in beta until they're resolved.  Bugs are assigned and should be resolved soon.
Rank: 8
MozReview-Commit-ID: 8qwr60BKMjS
Attachment #8820061 - Flags: review?(padenot)
Comment on attachment 8820061 [details] [diff] [review]
pref off full_duplex audio input on Windows in beta  a=?

Approval Request Comment
[Feature/Bug causing the regression]: bug 1308917 and bug 1308918

[User impact if declined]: hang/crash on unplugs of mics on windows during calls or failure until a new call is made

[Is this code covered by automated tests?]: requires manual QA (plug/unplug)

[Has the fix been verified in Nightly?]: N/A - non-full-duplex is still used for Android and in 50.

[Needs manual test from QE? If yes, steps to reproduce]:  yes - follow steps in bugs above, and also do basic audio input checks in a webrtc call using any server (such as appear.in).

[List of other uplifts needed for the feature/fix]: none

[Is the change risky?]: no

[Why is the change risky/not risky?]: pref off of new feature for windows only; same as was done for 50 for the same reason.

[String changes made/needed]: none
Attachment #8820061 - Flags: approval-mozilla-beta?
Attachment #8820061 - Flags: review?(padenot) → review+
Comment on attachment 8820061 [details] [diff] [review]
pref off full_duplex audio input on Windows in beta  a=?

OK to uplift to beta 51, let's pref this off till it's ready.
Attachment #8820061 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
MozReview-Commit-ID: Ef4e9MumAOc
Attachment #8821010 - Flags: review?(padenot)
Summary: Pref off full-duplex for Windows in beta → Pref off full-duplex for Windows and Mac in beta
Comment on attachment 8821010 [details] [diff] [review]
pref off full_duplex audio input on Mac in beta  a=?

Approval Request Comment

Same as for Windows.  Mac has similar issues with drift.
Attachment #8821010 - Flags: approval-mozilla-beta?
Comment on attachment 8821010 [details] [diff] [review]
pref off full_duplex audio input on Mac in beta  a=?

Pref off this feature. Beta51+. Should be in 51 beta 10.
Attachment #8821010 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Landed with rs=jesup
https://hg.mozilla.org/releases/mozilla-beta/rev/65271a0777167a85058f50fdea4f2d794d7d5027
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Attachment #8821010 - Flags: review?(padenot) → review+
Blocks: 1340519
Duplicate of this bug: 1341226
You need to log in before you can comment on or make changes to this bug.