Closed Bug 1328637 Opened 4 years ago Closed 5 months ago

Personal (bookmarks) toolbar lacks a keyboard shortcut to show/hide the bar (ideally same as Chrome)

Categories

(Firefox :: Bookmarks & History, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
83 Branch
user-doc-firefox docs-needed
Tracking Status
firefox53 --- wontfix
firefox83 + disabled
firefox84 --- verified

People

(Reporter: pascalc, Assigned: mtigley)

References

(Blocks 1 open bug)

Details

(Keywords: parity-chrome, parity-safari)

Attachments

(2 files)

Something that bothers me is the lack of keyboard shortcut to show/hide the personal toolbar in Firefox.

On Chrome this is CTRL+SHIFT+B and I think it would be nice to have the same shortcut as they have.

I am currently using an unmaintained 2013 extension (https://addons.mozilla.org/fr/firefox/addon/show-hide-bookmarks-toolbar/) to get that feature but I feel that the keyboard shortcut should be built in Firefox.

Thanks
What should happen with the library shortcut, which is what accel-shift-b currently points to?
Component: Toolbars and Customization → Bookmarks & History
Flags: needinfo?(pascalc)
On my Linux box, en-US or fr loclaes, the library shortcut is ctrl+B so there is no conflict. I don't know if the locale of the OS and keyboard default impact this. Obviously I am not asking for an existing shortcut to be replaced, if we can't have the same shortcut as Chrome that's a minor point, that's why I said it would be nice to have the same shortcut, not that it must be the same as what Chrome uses.
Flags: needinfo?(pascalc)
On both OS X and Windows, accel-b opens the bookmarks *sidebar*, and accel-shift-b opens the library. On my Linux (Ubuntu) VM, using m-c compiled or Ubuntu's packaged version of Firefox, ctrl-b opens the sidebar, not the library. I'm not sure why you're seeing something else. It seems on Linux (at least for me) the library shortcut is ctrl-shift-o.

It looks like the library shortcut is different on GTK compared to everywhere else, presumably (maybe at the time, and not anymore) because of a conflict with the window manager or something.

https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser-sets.inc#306-308

In any case, both accel-b and accel-shift-b are taken on Windows and OS X.


Can you elaborate on when this shortcut is useful and/or why it'd be better than the sidebar shortcut, given we can't have a "nice"/obvious shortcut for the bookmarks bar that doesn't conflict with existing shortcuts (on all OSes)?

I suppose we could in principle use ctrl-shift-b on GTK (if it's really not taken (anymore)) and accel-shift-o on Windows and OSX, but that feels a bit naff.

(For background: I have the bar permanently visible, and I'm not sure in what circumstances you'd want it hidden if you use it regularly. It's also not keyboard-accessible, so you'd need to keyboard shortcut and then mouse over when you show it. Almost feels like a toolbar button might be more useful, maybe? But I guess I'm just not following how you use it :-) )
Flags: needinfo?(pascalc)
I don't have the bar visible permanently because it takes up visual/reading space and generally speaking It makes the UI feel cluttered. I store there a few bookmarks I use on a daily basis (for example the status update pages for the team meetings I participate in which are all at the end of the European day, so no use for these bookmarks to be visible constantly) but not often enough to have that bar open all the time. The sites I use all the time are not bookmarks but pinned tabs.

Opening the library sidebar is less agreable visually because it causes all of the content on the page to be narrowed which I find disturbing especially for sites that will reorganize the page content because of the narrowed space for content, the library sidebar also contains other content than the personal toolbar as well as a search bar and forces scanning the bookmarks from top to down and not from left to right which I do faster.
Flags: needinfo?(pascalc)
Note that maybe we could change the shortcut on Linux for the Library window to be CTRL+SHIFT+B if there is no reason today to have a different shortcut on Linux. That could result in:
Library Window: Ctrl+Shift+b
Library Sidebar: Ctrl+b
Personal Toolbar: Ctrl+Shift+o

This way the Library Window shortcut is unified across platforms and we now can use ctrl+shift+o for the new shortcut.
Priority: -- → P3
For what it's worth, I'd like to emphatically second the motion for Ctrl/Cmd+Shift+O as the Library shortcut, and Ctrl/Cmd+Shift+B for Show/Hide Bookmarks Bar. This should work great on all three platforms.

As far as use cases for having the shortcut: as another commenter noted, hiding the bookmark bar helps me eliminate distraction and increase vertical space for content. Even *if* the bookmarks bar isn't keyboard-accessible, it'd still be nice to have a hotkey for quick access. I'm personally having to rely on bookmarklets for several services that don't have functional Firefox extensions anymore.

Once upon a time there was a pretty good extension (https://addons.mozilla.org/en-US/firefox/addon/hide-bookmarksbar/) that allowed you to show/hide the bookmarks bar with a keyboard shortcut, but it's since fallen by the wayside. Not sure to what extent the WebExtensions API allows you to manipulate the browser UI (apart from tabs), but I'm guessing it's very limited, and probably the extension will never be updated.

Furthermore, and I think most importantly, using "Ctrl+Shift+B" is no longer a proper mnemonic for the Library, because more things have been moved/consolidated into that window over the years besides just bookmarks. It's like another "File... Open" dialog of sorts, and so I'm really in favor of assigning <modifiers>+"O" as in "Open" to that.

On the other hand, "Ctrl+Shift+B" *is* a great mnemonic for "Bookmarks Bar". I think it's a win-win. :)
Oh, that was never the motion. I guess I read what I wanted it to read. And actually, <accel>+Shift+B *is* a good mnemonic for "Show All Bookmarks," so I take that back. Anyway, respectfully submitted.

I'd also like to point out that unless you are a long-time user of the "Show All Bookmarks" shortcut, or know the "Alt" key trick to display the menus, or have a Mac (where there's a global menu bar), the keyboard shortcut for "Show All Bookmarks" isn't even exposed in the new UI unless you go <menu> -> Library -> Bookmarks, and then all the way at the bottom. That's pretty buried, and Ctrl/Cmd+B is way easier nowadays.

I feel like the user impact to changing it to <accel>+Shift+O on potentially two out of three platforms is pretty minimal, if the end result is better cross-platform consistency (and feature parity with Chrome and Opera with respect to the show/hide bookmarks bar shortcut).
The most important use-case for this I see is for creating screenshots of websites for sharing (semi)publicly. I don't want to share all my top-level bookmarks/folders on these screenshots and enabling disabling the bar via mouse/menu is cumbersome for this.
Ctrl+Shift+B would also be my preferred variant since I'm used to that from other browsers.

If that "global" shortcut change is too much to ask, an option in about:flags would also be fine for me.
Now my proposal: 

Ctrl + Shift + O seems ok to me, yet  Ctrl + Alt + B would continue the existent keyboard shortcuts trend for bookmarks. The first three following shortcuts are the currently used, and the 4th is the proposed as the last piece of the puzzle we missed:

Ctrl + Shift + B  -> displays the bookmark Library, 
Ctrl + B          -> for the bookmarks left-side navigation pane.
Alt + B           -> displays the bookmarks from the menu. 
Ctrl + Alt + B    -> new shortcut for the bookmarks horizontal toolbar.

Also, Ctrl + Alt keys form a horizontal bar, which resembles the horizontal toolbar (it might serve as a mnemonic).

(In reply to Mart from comment #18)

… Ctrl + Shift + O seems ok …

Mozilla bug 1527337 - The established keyboard shortcut Ctrl+Shift+O for 'Show All Bookmarks' is not documented in Mozilla help for keyboard shortcuts

– not documented, but (through actual use of Firefox) people have become accustomed to the shortcut.

For this bug 1328637: at the time of writing I don't know what to suggest. Sorry.

(In reply to Mart from comment #18)

… Ctrl + Shift + B -> displays the bookmark Library, …

Documented by Mozilla but truly, this shortcut is non-effective with actual use of Firefox 65.0 on FreeBSD-CURRENT and Firefox 65.0 in Lubuntu.

On which OS – if any – does Ctrl-Shift-B have any effect in any recent release of Firefox?

(In reply to Graham Perrin from comment #20)

On which OS – if any – does Ctrl-Shift-B have any effect in any recent release of Firefox?

Windows. Mac also has cmd-shift-b. See also comment #3.

ctrl-alt combinations are not feasible on Windows. See bug 1438308 comment 2 to 4.

Thanks. Apologies for any confusion.

Now at https://bugzilla.mozilla.org/show_bug.cgi?id=1527337#c1

… I should treat this bug as a Tier-2 Knowledge Base content issue; …

Sorry, Tier-3. I forgot, FreeBSD is Tier-3.

Duplicate of this bug: 1538040
Summary: Personal toolbar lacks a keyboard shortcut to show/hide the bar (ideally same as Chrome) → Personal (bookmarks) toolbar lacks a keyboard shortcut to show/hide the bar (ideally same as Chrome)
Duplicate of this bug: 1546015

Not sure if this is the right place to also make this feature request. This shortcut is mostly needed to make screenshots without exposing personal bookmarks.

Hiding/showing the bookmark toolbar is easily done by right-clicking the empty space between the address bar and the extension icons, and checking/unchecking the "Bookmarks toolbar" option.

(In reply to hx48jai2 from comment #30)

Hiding/showing the bookmark toolbar is easily done by right-clicking the empty space between the address bar and the extension icons, and checking/unchecking the "Bookmarks toolbar" option.

This doesn't really address the requested user experience issue.

If a patch was proposed for these changes, would they be accepted? What would be the process to get support to get them accepted?

It seems to me the summary of this thread is "I want Firefox to act just a little bit more like Chrome", to which I vehemently agree, and I am curious what the general philosophy to that sentiment is in this community?

(In reply to davetcoleman from comment #33)

If a patch was proposed for these changes, would they be accepted? What would be the process to get support to get them accepted?

It seems to me the summary of this thread is "I want Firefox to act just a little bit more like Chrome", to which I vehemently agree, and I am curious what the general philosophy to that sentiment is in this community?

See here: https://developer.mozilla.org/docs/Mozilla/Developer_guide/Introduction

This has already been prioritized as a P3 (backlog) item, so a good patch would be accepted (after code review, of course). The reporter of the bug is a Mozilla employee, so I think you are good to start - you can ask Pascal for help if you like (or he will direct you to someone who can help).

(In reply to davetcoleman from comment #33)

If a patch was proposed for these changes, would they be accepted?

Which changes, exactly? As far as I can tell nobody has come up with a realistic shortcut to use here (see earlier comments), without removing either the shortcut for the sidebar or for the library window. If you're proposing to do either of those, it'd be worth talking to a UX person to make sure that's acceptable, before putting in the work of writing a patch...

I'm a first-timer to Firefox development, though certainly not to contributing to open source C++ projects. I got the build from source running last night and grep'ed the code for an hour, but couldn't find where OS-specific keybindings are defined. I'm probably not the right person to champion a patch, in hindsight.

I was searching where the Ctrl-Shift-B vs Ctrl-Shift-O bindings were defined and was going to propose we unify them as Ctrl-Shift-O, as some have proposed in this discussion thread. This would make room for Ctrl-Shift-B to allow the booksmark toolbar to be shown/hidden.

Having a UX person weight in sounds like a good idea, though no doubt this behavior was already approved by the Chrome team's UX people long ago.

(In reply to davetcoleman from comment #36)

I'm a first-timer to Firefox development, though certainly not to contributing to open source C++ projects. I got the build from source running last night and grep'ed the code for an hour, but couldn't find where OS-specific keybindings are defined. I'm probably not the right person to champion a patch, in hindsight.

They're at https://searchfox.org/mozilla-central/rev/557a0e222dd104c5d805ba344c45d6abc27d3db0/browser/base/content/browser-sets.inc#258-262 , with the localized shortcuts defined at https://searchfox.org/mozilla-central/rev/557a0e222dd104c5d805ba344c45d6abc27d3db0/browser/locales/en-US/browser/browserSets.ftl#134-147 . If you're changing them, note that you'll want to change the string identifiers too (not just the values).

I didn't realize that Chrome uses ctrl-shift-o for the library / bookmarks manager. It looks like it's accel-opt-b on mac, but ctrl-shift-o elsewhere. If we're aligning with that we should do the same here.

I was searching where the Ctrl-Shift-B vs Ctrl-Shift-O bindings were defined and was going to propose we unify them as Ctrl-Shift-O, as some have proposed in this discussion thread. This would make room for Ctrl-Shift-B to allow the booksmark toolbar to be shown/hidden.

Having a UX person weight in sounds like a good idea, though no doubt this behavior was already approved by the Chrome team's UX people long ago.

Aaron, can you rubberstamp us moving the library shortcut and adding one for the bookmarks toolbar to align with Chrome?

If we're doing this, it'd be worth (either here or in a follow-up) moving focus directly to (the first item in) the bookmarks toolbar if it's shown with the shortcut, so you can easily activate a bookmark with the keyboard.

Flags: needinfo?(abenson)

The problem of being able to see the bookmarks toolbar only under certain circumstances has been reported multiple times, for example we have Bug 727668 that suggests a subset of users would like to see it only on "empty" pages or even have an alternative access point, but it's likely there's also users who prefer to always see it.
A keyboard shortcut may help a bit, but it's not very discoverable, and should activate keyboard navigation through bookmarks, otherwise you show the toolbar with the keyboard and then can't move through them?
A toggle button that one could customize into the toolbar may also do for mouse users (though we already have a contextual menuitem)

I think we must evaluate the general problem of "Seeing the toolbar only when it's useful" and pick a direction, if we can identify a usage pattern it would be better to do it in some automated fashion, if we go the shortcut path we should ensure keyboard navigation works.

Chrome's solution is also bit puzzling, it's not discoverable, the shortcut doesn't work on the new tab page and that's surprising.
I'm also not sold on using ctrl+shift+B to go to the toolbar, because while coherent with Chrome, it would break most Firefox users that use it to go the Library.
As suggested, this is a UX problem to unwrap from scratch.

Note that based on https://developer.gnome.org/hig/stable/keyboard-input.html.en
"In addition, the shortcuts for Unicode character entry should also be avoided. This includes Shift+Ctrl+A through to Shift+Ctrl+F, or Shift+Ctrl+0 through to Shift+Ctrl+9."
That is the reason CTRL+SHIFT+B was not used on Linux.

Duplicate of this bug: 1630226

Saw this post: https://www.reddit.com/r/firefox/comments/g5bz9k/my_mind_is_tellin_me_firefoxbut_my_bodymy_bodys/ where this bug is featured.

I just did a quick audit of the shortcuts for the bookmarks sidebar in other browsers.

In Safari, it is ⌘-⌃-1 (command-control-1)
In old Edge it is Ctrl-i
In Internet Explorer, it is ctrl-shift-i

The ctrl-shift-b shortcut works in old Edge and Internet Explorer, while command-shift-b works in Safari.

Safari, Chromium and New Edge (on macOS) use ⌘-⌥-b to open its bookmarks editor.
Chromium on Windows and Linux, New Edge (Windows) use control-shift-o to open their bookmarks editor

I don't think that all of these shortcuts are the greatest, but they do provide a path forward -- Firefox could use:

  • for the bookmarks sidebar: ctrl-shift-i or ⌘-⌃-1 on Windows/Linux or macOS respectively (Ctrl-i is already used by Firefox's Page Info panel, which makes a lot of sense, imo).
  • for the bookmarks editor control-shift-o on Windows and Linux. ⌘-⌥-b on macOS.
  • for the bookmarks toolbar: ⌘-⇧-b/control-shift-b on macOS and Windows/Linux respectively.

There would be some jiggling around, but as a Linux user, I would only see one change (since Linux already uses the control-shift-o shortcut), and you also get to get rid of a collision with bold in text fields in rich forms.

I'm sorry but I don't understand the see-also bug you added, it's totally unrelated.

You also didn't address the fact ctrl+shift+b cannot be used on Linux.

See Also: 1621570

(In reply to Marco Bonardo [:mak] from comment #42)

I'm sorry but I don't understand the see-also bug you added, it's totally unrelated.

You also didn't address the fact ctrl+shift+b cannot be used on Linux.

That is actually the reason it is see also - platform rules can be broken in favor of consistency with other applications on the OS itself or Firefox itself on other OSes.

ctrl+shift+b is used in Linux Chromium, so this may be a situation where breaking the platform rules (like bug 1621570) is worthwhile.

Ctrl+Shift+B would be fantastic.

Assignee: nobody → tigleym
Status: NEW → ASSIGNED
Assignee: tigleym → mtigley
Blocks: 1665353

Tracking for 83 as it is likely to land in this cycle.

Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94b3b8f32af5
Add a keyboard shortcut for showing/hiding the bookmarks toolbar. r=jaws,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

'm sorry, I'm a bit lost with this countless updates
I see that is has been marked closed on 2020-09-30 and ths status is resolved

In which version will it be available? and what will be the keyboard shortcut in linux?

Thanks a lot

Sorry, I just saw that the target version is 83, thanks

(In reply to Sebastian Scarano from comment #50)

Sorry, I just saw that the target version is 83, thanks

This will likely stay on Nightly and early beta until Firefox 84.

Flags: needinfo?(abenson)

(In reply to Sebastian Scarano from comment #49)

what will be the keyboard shortcut in linux?

The shortcut will be Ctrl+Shift+B on Linux and Windows. And Cmd+Shift+B on macOS.

That will be perfect, thanks a lot

Regressions: 1672730
Depends on: 1672792
Depends on: 1674083

This reverts commit 2e95085964fa051c00039010e09839d3ae5cf359.

Comment on attachment 9186107 [details]
Revert "Bug 1328637 - Add a keyboard shortcut for showing/hiding the bookmarks toolbar. r=jaws,Gijs"

Beta/Release Uplift Approval Request

  • User impact if declined: Users will see that the shortcut shown for opening the bookmarks library in the "Bookmarks" > "Show All Bookmarks" menu will always show "Ctrl+Shift+O" even if the new bookmarks pref is off.

This is confusing since we don't want users to see differing shortcuts for opening the bookmarks library between different releases.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Ensure that "browser.toolbars.bookmarks.2h2020" is false
  1. Press Ctrl+Shift+B to open the bookmarks library window.
  2. Open menu "Bookmarks" > "Show All Bookmarks". Observe displayed shortcut.

ER:
The shortcut should be "Ctrl+Shift+B"

AR:
The shortcut displayed is "Ctrl+Shift+O"

Note: When the pref is enabled, the shortcut for opening the bookmarks library IS "Ctrl+Shift+O".

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Backing out a small change that allowed toggling the bookmarks toolbar via Ctrl+Shift+B
  • String changes made/needed: reverting new string "bookmark-show-all-shortcut" in this backout
Attachment #9186107 - Flags: approval-mozilla-beta?
Attachment #9175565 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Hi,
In my attempt to verify this in latest Nightly build 84.0a1 (2020-11-05) and Beta 83.0b9, using Windows 10, I observed the following behavior:
When browser.toolbars.bookmarks.2h2020 pref is set to true, ctrl+shit+B enables the bookmarks toolbar and the shortcut displayed near the Show All Bookmarks is Ctrl+Shit+O.
When browser.toolbars.bookmarks.2h2020 is set to false, indeed Ctrl+Shift+B open the bookmark library, but in the bookmarks menu still Ctrl+Shift+O is displayed near the Show All Bookmarks. Shouldn't be Ctrl+Shift+B displayed when the pref is set to false and the bookmarks library can be opened with Ctrl+Shift+B?
Thanks.

Flags: needinfo?(mtigley)

(In reply to Alin Ilea from comment #56)

When browser.toolbars.bookmarks.2h2020 is set to false, indeed Ctrl+Shift+B open the bookmark library, but in the bookmarks menu still Ctrl+Shift+O is displayed near the Show All Bookmarks. Shouldn't be Ctrl+Shift+B displayed when the pref is set to false and the bookmarks library can be opened with Ctrl+Shift+B?

This is covered in bug 1672730, which is why there's a request to back this out of 83 beta, and in bug 1675549 for nightly.

Depends on: 1675549
Flags: needinfo?(mtigley) → needinfo?(alin.ilea)
Attachment #9175565 - Flags: approval-mozilla-beta?

Comment on attachment 9186107 [details]
Revert "Bug 1328637 - Add a keyboard shortcut for showing/hiding the bookmarks toolbar. r=jaws,Gijs"

Approved for the beta branch before the merge, thanks.

Attachment #9186107 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Given the fact that in 83.0 (build id: 20201110140026) the behavior is the same as in comment 56 but the shortcut displayed issue is covered by the bugs from comment 57, could this be marked as verified?
Thank you.

Flags: needinfo?(alin.ilea) → needinfo?(gijskruitbosch+bugs)

Comment on attachment 9186107 [details]
Revert "Bug 1328637 - Add a keyboard shortcut for showing/hiding the bookmarks toolbar. r=jaws,Gijs"

We missed uplifting the backout as it was requested in the same bug as the landing so 83 was already marked as fixed, let's approve it for mozilla-release in case we have a RC2 as a ride-along if we have a driver (or a dot release).

Attachment #9186107 - Flags: approval-mozilla-beta+ → approval-mozilla-release+
Flags: needinfo?(gijskruitbosch+bugs)

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

Reverted for Fx83 RC2. This still remains landed for 84+.
https://hg.mozilla.org/releases/mozilla-release/rev/b4d233ef14ae

Comment on attachment 9186107 [details]
Revert "Bug 1328637 - Add a keyboard shortcut for showing/hiding the bookmarks toolbar. r=jaws,Gijs"

Clearing the approval to get this off the needs-uplift radar.

Attachment #9186107 - Flags: approval-mozilla-release+

Verified - Fixed in 83.0 (build id: 20201112153044). The Ctrl+Shift+B open the bookmark library and in the bookmarks menu Ctrl+Shift+B is displayed near the Show All Bookmarks. In latest Nightly 84.0a1 (build id: 20201112212842) Ctrl+Shift+B shortcut show/hide the bookmarks toolbar and the "Show all Bookmarks" shortcut displayed is Ctrl+shift+O. This behavior is the same with browser.toolbars.bookmarks.2h2020 pref set to false or true.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

How does this show/hide the bookmarks toolbar, as very simply stated, where in fact it opens the Library dialog? I'm a confused user.

(In reply to Ryan Stokes from comment #66)

How does this show/hide the bookmarks toolbar, as very simply stated, where in fact it opens the Library dialog? I'm a confused user.

My mistake. Saw "Fixed in 83.0", but that was re: the bookmark library. Will be welcome. Thanks!

Vam, this bug is already fixed - you can see the status as VERIFIED FIXED in the tracking section above. This fix is being rolled out currently, and should be released to everyone in Firefox 85 next Tuesday.

Bugzilla is a forum for developers to do work and we do hide comments that are not constructive or that do not add new/useful information... as otherwise the bugs can become difficult to read and follow the discussion that is actually relevant to fixing the bug. We also have a policy of no obligation, and your comment touches on both of these. Please read the etiquette before posting again.

(In reply to Mark Banner (:standard8) from comment #69)

Vam, this bug is already fixed - you can see the status as VERIFIED FIXED in the tracking section above. This fix is being rolled out currently, and should be released to everyone in Firefox 85 next Tuesday

It's better than that, this has been fixed since the beginning of the 84 release, no roll-out -- the shortcut change was changed to not honour the roll-out preference in bug 1675549, because of the unpredictability it caused on beta.

You need to log in before you can comment on or make changes to this bug.