Closed Bug 133153 Opened 18 years ago Closed 16 years ago

local mail directory set to UNC path stops message display

Categories

(MailNews Core :: Backend, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sierra, Assigned: mscott)

References

()

Details

(Keywords: fixed-aviary1.0, fixed1.7.5)

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:0.9.9) Gecko/20020311
BuildID:    20020311

When setting the local mail directory to a UNC path, like
"\\COMPUTER\C\[...]\Local Folders" instead of a drive/folder like
"C:\[...]\Local Folders", the folders can be opened and the message list
appears, but the message content is never displayed.



Reproducible: Always
Steps to Reproduce:
1. set the local folders directory setting to the same physical directory, but
in UNC format.
2. show a local folder (e.g. Inbox)
3. select a message

Actual Results:  Message window keeps unchanged / empty.

Expected Results:  Show the selected message

It seems that there is a small flaw causing this problem, because everything
else works well with UNC names (folders can be opened, message list is shown,
addressbook can be used etc.).

A workaround may be to use a mapped network drive (e.g. "net use F:
\\COMPUTER\C") instead of a UNC path.

Background: The same Mozilla installation should be started from different
machines, always using the same file-server based profile directory. UNC would
be helpful in this case.
QA Contact: gayatri → esther
Depends on: 101953
  i have seen this bug as well and have been meaning to report it.  the impact
on the user is that she is forced to include a new drive mapping in order to use
a mozilla mail repository over a network.  somewhat inconvenient mainly.
  it's odd that the message list on the UNC path is shown properly in the
display but one cannot view or manipulate the entries in the list.  hopefully a
simple fix?
Blocks: 101953
No longer depends on: 101953
I guess the problem is related to bug #66194. If I'm wrong, please remove the
dependency.
Depends on: 66194
I don't think we use file URLs to access mail. Removing dependency.
No longer depends on: 66194
Is this still reproducable with a modern build?
Yes, this bug is still present in Mozilla 1.5 (confirmed on win32 version).
Atached patch solve problem with UNC paths in Local Folders and Imap Folders in
Mozilla Thunderbird.

Apparently solve some other bugs:
http://bugzilla.mozilla.org/show_bug.cgi?id=246411
http://bugzilla.mozilla.org/show_bug.cgi?id=207565
http://bugzilla.mozilla.org/show_bug.cgi?id=243609
http://bugzilla.mozilla.org/show_bug.cgi?id=236902

Probably solve some bugs from this meta bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=101953

Slavek.
Confirming on basis of patch.

Good!

We should request review and superreview. For more information, see 

http://www.mozilla.org/hacking/code-review-faq.html

http://www.mozilla.org/hacking/reviewers.html
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8a4?
Attachment #157487 - Flags: superreview?(bienvenu)
Attachment #157487 - Flags: review?(sspitzer)
Blocks: 246411
*** Bug 207565 has been marked as a duplicate of this bug. ***
*** Bug 243609 has been marked as a duplicate of this bug. ***
that would be great if this fixes it...
Comment on attachment 157487 [details] [diff] [review]
Patch for URL handling

I think we kinda own nsFileSpec now. I'll try running with this patch.
Attachment #157487 - Flags: superreview?(bienvenu)
Attachment #157487 - Flags: superreview+
Attachment #157487 - Flags: review?(sspitzer)
Attachment #157487 - Flags: review?(mscott)
Attachment #157487 - Flags: review?(mscott) → review+
David, what's the word here? Is this landed or gonna land on the trunk any time
soon?
yes, I'll check it in - I haven't had any problems running with it.
fixed on trunk and aviary branch - thx a lot, Slavek!
Status: NEW → RESOLVED
Closed: 16 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
*** Bug 246411 has been marked as a duplicate of this bug. ***
Flags: blocking1.8a4?
*** Bug 143567 has been marked as a duplicate of this bug. ***
*** Bug 233784 has been marked as a duplicate of this bug. ***
Attachment #157487 - Flags: approval1.7.x?
*** Bug 263158 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Comment on attachment 157487 [details] [diff] [review]
Patch for URL handling

a=asa for 1.7.x checkin.
Attachment #157487 - Flags: approval1.7.x? → approval1.7.x+
Keywords: fixed1.7.x
Product: Core → MailNews Core
Duplicate of this bug: 189875
You need to log in before you can comment on or make changes to this bug.