If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Tracking] Create new bug entry page without the legacy concerns of enter_bug.cgi

RESOLVED DUPLICATE of bug 1365317

Status

()

bugzilla.mozilla.org
General
P3
normal
RESOLVED DUPLICATE of bug 1365317
7 months ago
3 months ago

People

(Reporter: dylan, Unassigned)

Tracking

({bmo-big, bmo-bug-quality})

Production
bmo-big, bmo-bug-quality

Details

(Whiteboard: [gsoc])

(Reporter)

Description

7 months ago
This bug is about writing a new bug entry page that is actually easy to use for new comers.

Current problems include:
1. There are three views (simple, advanced, and the “guided” bug entry version
2. New contributors and existing contributors have trouble communicating because what one type sees, the other does not.
3. The guided bug entry form increases work for bug triagers, because it funnels bugs into the wrong areas.
4. Making any substantial changes to enter_bug.cgi is difficult because of legacy concerns (custom forms, complicated spaghetti code)

My proposal on this is purely on the technical aspects, I want to have guidance from a UX person on how it behaves and looks.

Implementation criteria:

- brand new .cgi, new_bug.cgi (name is not important)
- same header/footer as the rest of the site, this cannot look that out of place.
  If this means we have to do a little fixes here and there on the global header and footer, those are just blocking bugs.
- response time for page load must be the same or better than index.cgi
- This must be developed and work under the same strict CSP as bug modal.
Keywords: bmo-big, bmo-bug-quality
Priority: -- → P3
Whiteboard: [gsoc]
See Also: → bug 1365983
Does it need to be a brand new new_bug.cgi, or is it also possible to fork the existing one into tree files (e.g. enter_bug_simple.cgi, enter_bug_advanced.cgi and enter_bug_guided.cgi) and clean up the code?
Or - if just one view should exist in future - to just clean up enter_bug.cgi?

Dipankar, would this be a challenge for you, or is this 'project' to big for you?

I guess I added all the dependencies, that belong to this bug, to bug 1365983, right?
So I will fix my mistake, if this is so...

Comment 2

3 months ago
Thanks a lot Tobias for adding me to the cc list. I will take this one up. 

But I need a little more clarification from Dylan. 

But before that, because this is marked as gsoc, I would like to ask Dylan whether somebody is already working on this or not?? 
And whether it is okay if I take up this bug and start working on it?
Flags: needinfo?(dylan)

Comment 3

3 months ago
Dylan, if nobody is working on this, I would love to take this one up. 

But I will need a little of guidance.
(Reporter)

Comment 4

3 months ago
This is actually the tracker bug for Sebastin's project, which is being worked on in other bugs.
Flags: needinfo?(dylan)
See Also: bug 1365983
(Reporter)

Updated

3 months ago
(Reporter)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365317
You need to log in before you can comment on or make changes to this bug.