File Bookmark in context menus, not Bookmark This Page.

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Jason Bassford, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020403
BuildID:    2002040303

It seems to me that rather than having "Bookmark This Page" in the context
menus, we should have "File Bookmark".  The latter does exactly the same thing,
with the exception of an additional mouse click, but it also adds far more
functionality.

I discovered this when I was unable to access "File Bookmark", in order to
create a tab group, except via the menu.  In the old context menu I could access
"File Bookmark".

Alternatively, a context menu item of "Bookmarks" could expand into any of the
bookmark sub-menus, including the two mentioned above.

Reproducible: Always
Steps to Reproduce:
1. Right-click.
2. See "Bookmark This Page".

Actual Results:  Only "Bookmark This Page" is available in the new context menus.

Expected Results:  There should be some method of getting to "File Bookmark" via
the new context menus - either by replacing "Bookmark This Page", or by using a
"Bookmarks" item that expands into further bookmark commands.

Comment 1

16 years ago
Confirmed, 2002040303, Mac OS 9.2. Without the confirmation provided by the 
File Bookmark dialog, someone mousing up in slightly the wrong place when 
aiming for Save Page As could easily end up adding a bookmark by mistake -- 
with no obvious evidence that that's what has happened. This is more important 
in the shortcut menu than for normal menus, because people try to move through 
shortcut menus quickly and gesturally (regardless of what happens after they 
mouse up).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
qa --> sairuh@netscape.com
QA Contact: paw → sairuh
Blocks: 135841

Comment 3

16 years ago
*** Bug 135843 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
This makes life so difficult for me that I had to rig up a quick workaround.  I
just played in the context menu, so this probably isn't the right fix.  I
changed contentAreaContextOverlay.xul in comm.jar line 115:

oncommand="gContextMenu.addBookmark();"/>                       

changed to

oncommand="BookmarksUtils.addBookmarkForBrowser(document.getElementById('content').webNavigation,
true);"/>

This reverts to the previous version's handling, and works well enough to help
get me back on track.  Hope it helps somebody else...

Comment 5

16 years ago
This is espacially annoying together with bug 133351. You have no way to
indicate the destination folder for bookmark and once you made this mistake (and
filed it with context menu) you have no way to move it (other than opening
manage bookmarks window). Thus creating a bookmark became a very time-consuming
operation.

confirming : RH 7.2, nightly build 2002041108

Comment 6

16 years ago
-> marlon
Assignee: blaker → marlon

Comment 7

16 years ago
*** Bug 138538 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 139208 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 140005 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 142267 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 143272 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 144451 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 144991 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 160461

Updated

14 years ago
Blocks: 233283
Product: Core → Mozilla Application Suite

Updated

13 years ago
Assignee: marlon.bishop → nobody
Severity: normal → enhancement
Component: XP Apps: GUI Features → Bookmarks

Comment 14

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 16

5 years ago
Bookmark this page... menu item now opens the bookmark star panel which allows you to choose which folder to put the bookmark in.

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1
Build identifier: 20120814163219
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.