Closed Bug 1356226 (dt-addon) Opened 3 years ago Closed 2 months ago

[meta] Ship developer tools as an add-on - Move developer tools to github

Categories

(DevTools :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

(Keywords: meta)

https://docs.google.com/document/d/1_cl1ZtcS7zFy4JTmh4ShqaVl0HHnXrN2oHBcJMgN6lU/edit?ts=5886398e#heading=h.kft9zibe60g5

In order to release faster updates of DevTools to web developers, we have to quit mozilla-central which is tightly related to Firefox train release cycle.
So most of /devtools/ folder is going to be moved to its own github repository.
Then, we need a new release mechanism if we are not following Firefox release cycle. We are planning to use an Add-on to ship the tools to web developers.
There will still be a "shim" in mozilla-central/Firefox. That, to automatically install this add-on whenever the user intend to use the tools.

This bug is a meta bug for all that.

Note that many things can be landed early, before we actually execute this move.
We should first ensure that Firefox still works (no error, green tests) if we happen to remove devtools codebase.
Depends on: 1356231
Depends on: 1356237
Depends on: 1356244
Assignee: nobody → poirot.alex
Alias: dt-addon
Keywords: meta
Priority: -- → P3
Summary: Ship developer tools as an add-on - Move developer tools to github → [meta] Ship developer tools as an add-on - Move developer tools to github
Depends on: 1357789
Depends on: 1358070
Depends on: 1358080
Depends on: 1356415
Depends on: 1359083
Depends on: 1359085
Depends on: 1359090
Depends on: 1361054
Depends on: 1361081
Depends on: 1361146
Depends on: 1362040
Depends on: 1363327
Depends on: 1363417
Depends on: 1363419
Depends on: 1363533
Depends on: 1363539
Depends on: 1364063
Depends on: 1364075
Depends on: 1364077
Depends on: 1364877
Depends on: 1365238
Depends on: 1343871
Depends on: 1365889
Depends on: 1365891
Depends on: 1366698
Depends on: 1366723
Depends on: 1366823
Depends on: 1367424
Depends on: 1367425
Depends on: 1367428
Depends on: 1367985
Depends on: 1369714
Depends on: 1369801
Depends on: 1371298
Depends on: 1372520
Depends on: 1374735
Depends on: 1375809
Depends on: 1378151
Depends on: 1378157
Depends on: 1378341
Depends on: 1378400
See Also: → 1380687
See Also: → 1380688
Depends on: 1382194
Depends on: 1384117
Depends on: 1386616
Depends on: 1386620
Duplicate of this bug: 1105503
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.