The default bug view has changed. See this FAQ.

CSS errors in chrome

RESOLVED FIXED in mozilla1.2alpha

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Trunk
mozilla1.2alpha
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [whitebox] [Check Boffo on MozillaTest][patch])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
This is a bug for the CSS errors in the chrome that have crept in since bug
71637 was fixed.  The patch I'm about to attach includes all the errors on the
1.0 branch except for those in messageBody.css, which is covered by bug .

I haven't tested this at all, and I don't think it should be checked in as-is. 
But I certainly think it's an interesting demonstration of how little some of
the CSS in the tree has been tested.
(Reporter)

Comment 1

15 years ago
Created attachment 80900 [details] [diff] [review]
patch fixing CSS errors in chrome

This is a patch against the 1.0 branch.

The bug on messageBody.css is bug 130728.

I found this using the command-line tool I just wrote (see bug 139943).
(Reporter)

Updated

15 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla1.1beta
Arguably, the incorrect lines should be removed, not fixed...

Comment 3

15 years ago
@@ -201,8 +201,8 @@
     font-family: arial, helvetica, sans-serif; 
     font-size: 12px;
   line-height: 1;
-    margin-top: 0;
-    margin-bottom: 4;
+    margin-top: 0px;
+    margin-bottom: 4px;
   }

"line-height: 1;" is a no-op, right? Remove it?
(Reporter)

Comment 4

15 years ago
No, since 'line-height' is inherited.  And there's a .7 in the previous rule,
which I expect it's overriding.
(Reporter)

Comment 5

15 years ago
There's also a bad 'background-color' declaration in pref-viewing_messages.xul
that I should fix.

Comment 6

15 years ago
(Good point about the inheritance, which I hadn't considered. Although, looking 
at the usage, it seems like the 'inthissection' and 'inthissections' are used
independently. But it's obviously not your job to fix every bit of redundant
css in the tree :-).

Comment 7

15 years ago
cc'ing myself
(Reporter)

Comment 8

15 years ago
For reference, bug 65469 is the bug on CSS error reporting an bug 155855 is the
bug on turning on CSS error reporting in DEBUG builds only.  (I intend to do the
localization sometime before trying to turn it on for release builds.)
(Reporter)

Comment 9

15 years ago
Created attachment 90270 [details] [diff] [review]
similar patch against current trunk
Attachment #80900 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Target Milestone: mozilla1.1beta → mozilla1.2alpha
Depends on: 158069

Updated

15 years ago
No longer depends on: 158069

Comment 10

15 years ago
*** Bug 158069 has been marked as a duplicate of this bug. ***
David: what do you want to do with this patch? Could we get simple stuff in at
least? Adding the correct @namespace rules for example would already fix some
errors and I think it's mostly clear that that was just an oversight.
(Reporter)

Comment 12

15 years ago
Which ones?  Adding some of those rules might break other things.

Updated

15 years ago
Whiteboard: [dev notes]

Updated

15 years ago
Whiteboard: [dev notes] → [whitebox]

Comment 13

14 years ago
People need to look at the CSSERR parts of the patch. Let's try and get this
resolved.

Updated

13 years ago
Whiteboard: [whitebox] → [whitebox] [Check Boffo on MozillaTest]
(Reporter)

Updated

13 years ago
Depends on: 130728

Updated

13 years ago

Comment 14

13 years ago
Created attachment 138226 [details]
remaining errors

I filed bugs on the appropriate components and attached patches. Hopefully the
owners will be able to determine if the patches are appropriate. I did not
include anything for layout/html/tests and was not able to fix all errors. The
remaining errors are mainly due to # pre-processor statements or vendor
specific properties I am not familiar with.
(Reporter)

Updated

11 years ago
Whiteboard: [whitebox] [Check Boffo on MozillaTest] → [whitebox] [Check Boffo on MozillaTest][patch]
(Reporter)

Updated

10 years ago
Assignee: dbaron → nobody
Status: ASSIGNED → NEW
QA Contact: ian → style-system
(Reporter)

Comment 15

5 years ago
I think this has been fixed for a while; these don't creep in much anymore now that they show up on the console.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.