Closed Bug 1421696 Opened 4 years ago Closed 3 years ago

regression: flickering ui (ANGLE?)

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected

People

(Reporter: steve, Assigned: kvark)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [wr-reserve])

Attachments

(5 files)

Attached image webrendererror.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171129111030

Steps to reproduce:

Updated to the latest nightly.

Use my browser as normal. Visiting https://www.wikipedia.org/ for example, reproduces.


Actual results:

Several aspects of the browser chrome are rendering oddly. The forward button, the V button on the URL bar, and the background of all of the tabs have strange artifacts that sometimes flicker when I move my mouse.

Screenshot attached; it doesn't show the V button, but the tab backgrounds and forward button are shown messed up. 

I do have a https://addons.mozilla.org/en-US/firefox/addon/rustacean/ installed but I doubt it's that specifically causing an issue.


Expected results:

UI rendered as usual.
Could you please re-enable WebRender for a moment (restart required) and copy/upload the output of about:support then? Thank you.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Whiteboard: [wr-mvp] [triage]
Version: 57 Branch → Trunk
Sorry for a slightly pedantic comment; you say "re-enable" but I have it on. Do you want about:support with WebRender on, or off?
Thanks for leaving it enabled. Maybe you produce some crash reports. ;)
Steps with WebRender enabled: Do something that let you see the described issues, open about:support then, click on the "Copy text to clipboard" button, paste it into a text file and upload it here.
Attached file support.txt
No worries, that's the idea! I can use Developer Edition if it bugs me too much ;)

Attaching the text.
> Compositing: Basic
Weird.

> Description: Intel(R) HD Graphics 520

> Decision Log
> WEBRENDER:
> opt-in by default: WebRender is an opt-in feature
> available by user: Enabled by pref
No crashes & no failures.
> Updated to the latest nightly.

Is this a regression for you? Was WebRender fine yesterday, but broken today? (Or did you enable WebRender just today?)
I've had webrender on for a long time; this appeared after I updated. Was totally fine before updating.
Flags: needinfo?(jan)
Attached video 2017-11-30 04-11-24.mp4
Nightly 59 x64 20171129220149 de_DE @ Windows 10 1709 (Radeon RX480)
fresh profile: gfx.webrender.enabled, gfx.webrender.blob-images, image.mem.shared

mozregression-gui, good 2017-11-27, bad 2017-11-29, clone-first,
1. I opened https://web.telegram.org/,
2. played a video in telegram,
3. switched the chat, started playing 4 gifs,
4. burger menu > options > privacy & security, scrolled to the bottom,
5. switched back to the telegram tab, pressed f5, 
6. gifs and some ui elements flicker - mostly red -
(so many broken builds)
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2f2ec35ccf5f2ce84fddac8bc291bd461c8ecbe7&tochange=38f11a0d41117367c8864aad3c26e1294618bfd8

You get
> Compositing: Basic
but I don't.

@ethlin: Could it be possible that bug 1421196 plays a role here?
Flags: needinfo?(jan) → needinfo?(ethlin)
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Ever confirmed: true
Keywords: regression
Summary: flickering ui → regression: flickering ui
See Also: → 1421849
Duplicate of this bug: 1421849
I can reliably reproduce my STR, but not when gfx.webrender.force-angle is set to false.
@Steve Klabnik: Can you confirm this observation? Would disabling gfx.webrender.force-angle fix it for you, too?
Those grey/red things flicker when I move the mouse to another element or when I have a blinking caret (bug 1421472 comment 4). If a caret is blinking in the search field on the top of the about:support tab, things flicker on Telegram (UI + content) as well.

Didn't help:
gfx.webrender.enabled;true
gfx.webrender.blob-images;false
gfx.webrender.program-binary;false
gfx.direct2d.disabled;true
gfx.canvas.azure.backends;skia,cairo
gfx.content.azure.backends;skia,cairo
image.mem.shared;false
layout.display-list.retain;false
layers.omtp.enabled;false
layers.mlgpu.enabled;false
layers.mlgpu.enable-on-windows7;false
layers.gpu-process.allow-software;false
media.gpu-process-decoder;false
webgl.disabled;true
webgl.enable-webgl2;false

Helped:
gfx.webrender.enabled;true
gfx.webrender.force-angle;false
@jan andre, so this morning I've updated again, and now it's working! Maybe https://bugzilla.mozilla.org/show_bug.cgi?id=1421196 fixed it?

I was going to try disabling force-angle, but since it's working...

Thanks all!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Shouldn't have spoken so fast; now after some time, it's back.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(I tried changeset 2422d2803b34 from autoland (bug 1421196) directly, but couldn't reproduce it so far.)
Status: REOPENED → NEW
Flags: needinfo?(ethlin)
Summary: regression: flickering ui → regression: flickering ui (ANGLE?)
I've got the same issue and setting "gfx.webrender.force-angle" fixed it after a restart.
FYI: There is information leak on these logs with name and address of printers. I had to remove they, would be cool to not have them automatically (replaced by some placeholder)
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-reserve]
Now I have the same issue. Updated to Nightly 04.12.2017 and it started to flick in UI and some page elements.

It seems that it starts with tabs, that are active for some time.
BTW Before I had build 28.11.2017 without this issue. 
So, it seems it was introduced 28->29.11.2017?


06.12.2017 has it as well.
So, after updating today, I didn't have any problems, and I thought maybe it had been fixed!

But then I hit this page http://www.latimes.com/local/california/la-me-southern-california-wildfires-live-firefighters-attempt-to-contain-bel-air-1512605377-htmlstory.html

and not only is that page *majorly* showing these red artifacts, like entire layers on the page, but now the forward button is flickering again, even after the page goes away.
I... spoke too soon. Now, ten minutes later, the UI flicker has stopped. Re-opening that page doesn't cause any red, or UI flicker.

Something very odd is going on...
Attached file Minimal reproduction
This is apparently linked to shadow rendering.

It seems that there are very specific (still unknown) conditions to trigger this bug the first time, that have to do with several shadows overlapping in a certain manner. However, after it has been triggered once, any shadow in the same window (even in different tabs) will flicker or be badly rendered.

If you open a new window, the issue won't manifest until those same conditions are encountered again.

I am able to reproduce 100% this bug on my machine using the attached html file.

To reproduce (epilepsy warning as the whole screen might flash white/red/black):
- Open a new empty firefox window (no need to close the browser if it's already open)
- Open the attached html file in that window
- Alternatively scroll to the top/bottom
You will notice the whole content flickering black/white, the scrollbar flickering red, the forward button (browser UI) flickering grey

This is on the latest nightly (2017-12-07), on Windows x64, with webrender enabled (same as the previous commenters).
I can confirm that the above attachment does cause the issue.

After this issue occurs, going to about:support and clicking "Trigger Device Reset" under the Diagnostics header of the Graphics section fixes the flickering (for me at least).
I get the red flashing when I scroll at msn.com.  Setting gfx.webrender.force-angle to false is a workaround as mentioned.
Thanks for making this a P1. One other affect I saw when setting gfx.webrender.force-angle to false was that it totally screwed up http://zone.msn.com/bingame/msso/default/.
Do you plan on resolving this issue any time soon?  I would like to turn on WR permanently but this bug is preventing me from doing so barbecue it affects many sites I visit.
Depends on your definition of "soon". I wouldn't expect anything until mid or late January at the earliest. Most people are away until the first week of January anyway.
That's fine.
I made a fresh build today and can no longer reproduce the issue.

Previously, I was able to get it 100% of time using the following steps:

  1. Open FF with no tabs
  2. Open the attached HTML in one tab, scroll to the bottom (Note: this step alone was never enough for me).
  3. Open another heavy page in a second tab (I used "tut.by"), scroll to the bottom
  4. Switch back to the first tab and try scrolling up/down

Opening /r/Overwatch as advised in https://bugzilla.mozilla.org/show_bug.cgi?id=1424700#c2 doesn't trigger it either.

Gary, can you reproduce it somewhere with a fresh Nightly?
Flags: needinfo?(garyshap)
Using a brand new profile I still get the flickering red frames on msn.com when scrolling. It's always been 100% producible unless I turn of Angle which causes problems elsewhere as I mentioned in one of my previous replies. I'm on the latest Nightly.
Flags: needinfo?(garyshap)
I've been updating rarely thanks to the holidays, but I updated today and I haven't seen it yet, /r/overwatch and msn.com don't show it at all.
Thanks Gary, thanks Steve!

I'm not seeing it on MSN either (with fresh build), but I do see it with a Nightly. The next Nighly build will likely be fixing it then.
(In reply to Dzmitry Malyshau [:kvark] from comment #34)
> Thanks Gary, thanks Steve!
> 
> I'm not seeing it on MSN either (with fresh build), but I do see it with a
> Nightly. The next Nighly build will likely be fixing it then.

I don't understand.  I am getting the red flickering on msn.com but no one else here is? Are you saying that there will be a patch coming shortly that will fix the msn.com problem?
Here is a video of the red flickering on msn.com  https://1drv.ms/i/s!AtusZi2hwX-rgtMGT3YOS6rgu_ERYA

I'm running the latest Nightly.
There are definitely issues on nightly with webrender on Windows - it's possible that your card/driver combination has the exhibiting as red flickering, while the others get different symptoms (e.g., bug 1424457)
FWIW my gfx card is an NVIDIA GeForce GTX 1080 Ti with the latest official drivers.
(In reply to Gary [:streetwolf] from comment #35)
> (In reply to Dzmitry Malyshau [:kvark] from comment #34)
> > Thanks Gary, thanks Steve!
> > 
> > I'm not seeing it on MSN either (with fresh build), but I do see it with a
> > Nightly. The next Nighly build will likely be fixing it then.
> 
> I don't understand.  I am getting the red flickering on msn.com but no one
> else here is? Are you saying that there will be a patch coming shortly that
> will fix the msn.com problem?

Let me clarify. I also see it on Nightly, but it appears to be fixed with the latest code (that has possibly not made it into the Nightly yet).
If you have f.lux or any similar color adjusting software installed, disable it and try again.
I just updated to the latest inbound release and msn.com no longer red flickers.
(In reply to Gary [:streetwolf] from comment #41)
> I just updated to the latest inbound release and msn.com no longer red
> flickers.

The flickering did come back once on msn.com.  It's fine for now.  Wonder what kicked it off?
I still get the flickering on some sites.  When I do get it and go to msn.com that starts to flicker also.
Still flickering right after FF starts. Only "Trigger Device Reset" after every restart helps.
If it helps, I've noticed this issue most often when there are instances of text-shadow or filter:blur(x) in effect. Restarting the GPU process solves the issue until something else triggers it.
Assignee: nobody → kvark
bad news: apparently, something happened that had turned webrender *off* for me, and so when I said it had stopped, well, that's because the settings changed. The latest WebRender newsletter said to turn on that one flag, so I checked, and turns out something had turned it all off.

Now that it's back on again, I'm seeing the blinks again. https://www.fortanix.com/blog/2018/01/secure-by-design-rust-and-runtime-encryption/ was the page that made it happen this time; same deal as before, it's the animation in the title that seems to flicker.
 Dzmitry, any progress on the patch you are working on?
Here is the status:
  - initial bug about red flickering was successfully reproduced on multiple machines
  - I produced a workaround in WR in https://github.com/servo/webrender/pull/2280, which got into Nightly recently
  - I traced the bug down to Angle, and my fix was merged: https://chromium-review.googlesource.com/c/angle/angle/+/862256
  - WR workaround was replaced by a more generic (and less hacky) solution yesterday: https://github.com/servo/webrender/pull/2317
  - there is a high chance Steve (and Milan here, to an extent) see a different issue that needs investigation. So far I wasn't able to reproduce it, will keep trying on different env/hws
(In reply to Dzmitry Malyshau [:kvark] from comment #49)
> Here is the status:
>   - initial bug about red flickering was successfully reproduced on multiple
> machines
>   - I produced a workaround in WR in
> https://github.com/servo/webrender/pull/2280, which got into Nightly recently
>   - I traced the bug down to Angle, and my fix was merged:
> https://chromium-review.googlesource.com/c/angle/angle/+/862256
>   - WR workaround was replaced by a more generic (and less hacky) solution
> yesterday: https://github.com/servo/webrender/pull/2317
>   - there is a high chance Steve (and Milan here, to an extent) see a
> different issue that needs investigation. So far I wasn't able to reproduce
> it, will keep trying on different env/hws

Thanks for the update.  Your fix did indeed seem to fix the red flashing but now I am getting non-red flashing on at least one site which happens to be my bank's site.  Are you aware of this problem and will a new patch be forthcoming?
(In reply to Gary [:streetwolf] from comment #50)
> non-red flashing on at least one site which happens to be my bank's site.

Could you file a new bug about that website, please? If it's public I could search for a regression range or so. If not, a small screencast could be helpful to compare with other bugs. At least it would be tracked and not forgotten.
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #51)
> (In reply to Gary [:streetwolf] from comment #50)
> > non-red flashing on at least one site which happens to be my bank's site.
> 
> Could you file a new bug about that website, please? If it's public I could
> search for a regression range or so. If not, a small screencast could be
> helpful to compare with other bugs. At least it would be tracked and not
> forgotten.

Unfortunately you would need to log in to the site to see the flickering.  Unless I can reproduce the problem without logging in I'll make a video of the flickering.
I just went to the site and it started flickering like crazy.  I didn't have to log in at all.  Also, it carried over to the sites I subsequently went to.  

https://www.santanderbank.com/us/personal/banking/digital-banking/online-banking

Note:  When I moved my pointer over the Save Changes button to save this post I got the flickering/flashing.  I came here directly after I started Fx.
a black box replaces certain images, check boxes, and other native elements like text boxes, combo boxes, buttons and so on. the same elements that used to be red are now black. Animated images are filckering too.
I didnt have a severe case of this problem before but now i do. 
Now there's black boxes all over the UI like the back-forward buttons, the loading throbber.  

ID: Mesa DRI Intel(R) Sandybridge Mobile 
Driver: 3.0 Mesa 17.2.8
(In reply to bull500 from comment #56)
Hm. That could be bug 1439059 comment 2 (or bug 1438958).
There have been multiple sources of flickering observed. This issue got mixed reports from different causes. I fixed one in Angle related to our render target initialization (https://bugzilla.mozilla.org/show_bug.cgi?id=1421696#c49), so let's close this issue appropriately then.
For black squares on Nvidia, let's continue using that one - https://bugzilla.mozilla.org/show_bug.cgi?id=1431560

https://bugzilla.mozilla.org/show_bug.cgi?id=1421696#c56 appears to be different. Please check out the issues :darkspirit kindfully noted and either append your repro case/screenshot/system info there, or create a new one.
Status: NEW → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.