Quick Launch doesn't work with multiple profiles

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
6 years ago

People

(Reporter: waiyee404, Assigned: law)

Tracking

({regression, relnote})

Trunk
mozilla1.2alpha
x86
Windows 98
regression, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 2002051006
I chose to enable Quick Launch when installing Mozilla,
and double-checked it in "Edit -> Preferences -> Advanced",
but when the last open window is closed,
the Quick Launch icon disappears and it takes a long period to reopen Mozilla.

The could be irritating to some users like me that are using Mozilla in a very
old computer :(

Comment 1

17 years ago
Confirmed. I have similar behaviour with RC2 (platform Win98).

Comment 2

17 years ago
cannot reproduce here - Win98 and build 2002051304

Comment 3

17 years ago
Windows ME (4.90.300)
Mozilla 1.0RC2 (2002051006)

I'm experiencing the exact same problem as Winnie described.

On another note, I've used versions 0.9.7 and 0.9.9 on the same machine and
Quick Launch worked fine with both of them.  Tried uninstalling/reinstalling RC2
but problem persists.

Comment 4

17 years ago
Same problem with RC2 on Win2K Professional (Serv.Pack 1)

Comment 5

17 years ago
Seen on WinNT since installing 1.0RC2 (was OK on 1.0RC1)

Comment 6

17 years ago
Changing status to confirmed, since so many confirmations.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
Actual results: Enabling Quick Launch, then closing Mozilla puts a Quick Launch
icon in the bar, but does not enable Quick Launch. After rebooting, Quick Launch
is enabled.

Expected results: Enabling Quick Launch works next time Mozilla is started,
without rebooting.

Is this a regression? 
Keywords: mozilla1.0, nsbeta1
Summary: Quick Launch enabled but doesn't work → Quick Launch enabled but doesn't work until reboot

Comment 8

17 years ago
My experience is that it makes no difference restarting Mozilla or even
rebooting the O/S. Quick start is *completely* broken on my PC.

This is broken since installing 1.0RC2 (2002051006). Quick start worked with RC1.

My O/S is: Win2K Pro, SP1.

Comment 9

17 years ago
I can confirm that. I got Quick Launch to work once, but subsequent to that,
after restarting Mozilla, and even rebooting, it just doesn't work. 

Quick Launch is broken. Critical severity. 
Severity: major → critical
Keywords: regression

Comment 10

17 years ago
for the folks that quick launch does not work for,
do you have multiple profiles?

chris h.

Comment 11

17 years ago
Including my one 4.x profile, I currently have 5 profiles. Not sure about other
folks.

Comment 12

17 years ago
I have problems with RC2's quickstart too, see bug 145306 - I have no profiles.

Comment 13

17 years ago
WFM with 1.0 RC2 on WinME.

Comment 14

17 years ago
With respect to comment #10 - yes, I have two profiles.

Comment 15

17 years ago
I have also two profiles (Comment #1).

Comment 16

17 years ago
After deleting my three test profiles, and keeping my 4.x profile and my one
Mozilla profile, I'm able to get QuickLaunch working. If you have one Mozilla
profile, it works. Otherwise, it's broken.

The exception is Tom Chiv, who must have at least one profile. You can figure
out how many profiles you have by closing Mozilla, then using Start | Run to
execute this:

c:\progra~1\mozilla.org\mozilla\mozilla.exe -profile_manager

Or alter that command line if you have Mozilla installed elsewhere.

Comment 17

17 years ago
*** Bug 145306 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
wfm rc2 (2002051006) on win2K

Every time I install a new version of Mozilla, I
   1)   Unzip the latest zip file to a new directory
   2)   Rename the directory with the old profile and code
   3)   Delete the old profile in Profile Manager
   4)   Create a new profile with a new name

I often end up with QuickLaunch trying to load itself twice (once from the
previous install, once from the latest install).  Perhaps that's the problem?
Try using the seamonkey full installer and 
also reboot or restart your windows session.
Also check this BUGs:
http://bugzilla.mozilla.org/show_bug.cgi?id=103786
http://bugzilla.mozilla.org/show_bug.cgi?id=121100
and mark "duplicate" as needed

Comment 20

17 years ago
Chris, I have three profiles.

Comment 21

17 years ago
Re: comment 19. I don't see a duplicate of this bug. 

Changing URL to reflect how the problem is specific to Mozilla installations
with more than one profile.

Proposed relnote: Quick Launch is supported in this release only if the Mozilla
installation has one Mozilla profile. If there is more than one Mozilla profile,
Quick Launch will not work.
Keywords: relnote
Summary: Quick Launch enabled but doesn't work until reboot → Quick Launch enabled but doesn't work with multiple profiles

Comment 22

17 years ago
See bug 136940- if multiple profiles exist, QuickLaunch exits

"We decided to implement new code that will run when in Quick Launch mode.  This
code will check, at last window closing, whether the user has multiple profiles
defined and if so, automatically exit QuickLaunch mode (and since the last
window is closing, exit Mozilla).

This code will be enabled via a pref that will default to "off."  The plan is to
change this default to "on" (or remove the pref check) if we are unable to get
QuickLaunch working reliably in multi-profile cases."

Updated

17 years ago
Summary: Quick Launch enabled but doesn't work with multiple profiles → Quick Launch doesn't work with multiple profiles

Comment 23

17 years ago
To my knowlege, I only have one profile, and it's broken for me...

Comment 24

17 years ago
nsbeta1- per Nav triage team.  We might be able to fix this for MachV (covered
by problems in other bugs), but we aren't going to require it.  
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha

Comment 25

17 years ago
WFM fine in RC3 now...

Comment 26

17 years ago
Still broken for me on RC3 (Build ID: 2002052306) on Win2KProf(SP1).

One difference: after a reboot it pre-loads so that the first time I start
Mozilla it starts quickly. After I close the (only) Mozilla window, the Quick
Launch icon disappears from the system tray. The next time I start Mozilla, it
goes through the full load procedure, i.e. quick launch really was inoperative.

Previously (with RC2) I didn't get the first-time-after-boot-pre-load.

I hope this is fixed for general release.

Comment 27

17 years ago
I have the same behaviour like colin.gregg on WinNT4 SP6 with rc3

- After login I have a running quick launch. Double-click starts the
profile-selection-window (I have 2 Mozilla-profiles).
- Closing the last windows exits quick launch

- disabling quick launch in the prefs (including closing the prefs) and
re-enabling it, starts it again. But only until I close the the last window.

This worked for me with surely with rc1 and I thought with rc2, too, but I'm not
sure for rc2 anymore.

Anyway on rc1 (and perhaps rc3) I had a resident quick launch:
- if there was still a window open, the active profile was used
- if there was no window open, the profile-selection-window opened

I think this is how it should be!!

I'm nominating this for 1.0!!!! (otherwise we should disable quick launch
completely, because everything else is inconsistent and irritating)

Comment 28

17 years ago
Sorry!! I certainly meant:

"Anyway on rc1 (and perhaps rc2) I had a resident quick launch"

adding myself to CC

Comment 29

17 years ago
QuickLaunch will work with multiple profiles on trunk builds (nightlies)
On the branch there is a pref set to allow QuickLaunch only with a single 
profile
I have the same problems as the reporter on today's 1.0 branch build. I also
have 2 profiles (one Netscape and one Mozilla).

I think this should be fixed before 1.0 is released. I don't think Critical is
the correct resolution since its a major loss of function, but no dataloss.

CCing valeski@netscape.com
BTW: I have windows xp.
(Assignee)

Comment 32

17 years ago
BTW, users who are willing to face the risk inherent in using QuickLaunch with
multiple profiles can turn this behavior off by manually setting a user pref in
their prefs.js file:

user_pref("browser.turbo.singleProfileOnly", false);
Bill: Do you think it would be a good idea to have someone put that in the
release notes for 1.0 since this might affect many users?

Comment 34

17 years ago
If there is a working bugfix on the trunk (comment #29 from Grace), I think we
should pull that fix to the 1.0-branch rather than adding a work-around to the
release-notes!!!

Is the target-milestone 1.2alpha still actual?

Comment 35

17 years ago
*** Bug 148631 has been marked as a duplicate of this bug. ***

Comment 36

17 years ago
The work-around from Bill (#32) is not working if Mozilla crashes.

After a crash Quick-Launch is deactivated. 
It is only reactivated if
1. you logout and re-login or
2. go to the prefs and disable and enable quick launch

Comment 37

17 years ago
*** Bug 149805 has been marked as a duplicate of this bug. ***

Comment 38

17 years ago
*** Bug 150280 has been marked as a duplicate of this bug. ***

Comment 39

17 years ago
*** Bug 149827 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
*** Bug 166916 has been marked as a duplicate of this bug. ***
Well, I can't get rid off the feeling we're discussing 2 different problems
here... Anyway, this is my experience:

When I installed the 1.1alpha release, I noticed QuickLaunch restarting after I
closed the last window. I don't have this problem with 1.0 release, which I'm
currently using (I threw the 1.1alpha away partially due to this bug, because on
some slow PCs we have at school it was a real nusisance!).

Quite strange thing is I have _only_ _one_ _profile_ and never had more. However
it's not a default profile, which I have deleted and created a new one in
different location (perhaps this could be incorrectly taken as if I had more
than a single profile?).

The operating system is Windows NT Workstation ver. 4.0 with SP6 or SP6a, I
guess. I think Mozilla did the same thing on my home PC which has Windows 2000
with SP2.

I can't say anything about the problems with QuickLaunch not starting
automatically because I start it manually using shortcut that executes
"mozilla.exe -turbo".
Christian Schweer (<a href="#c36">comment #36</a>):

This is logical. QuickLaunch runs in the same process in which all Mozilla's
browser windows do. When Mozilla dies, it's just this process, which is dead. It
means you'll lose all your open browser windows including QuickLaunch. You can
restart it manually in a very easy way, you can even make yourself a shortuct to
do so: Just copy a shortcut created by the installer and add "-turbo" option to
it. The resulting shortcut should run something like this:
"P:\bin.Win\Mozilla\mozilla.exe -turbo" (change the path to the one you use...). 
Is there any relationship between this bug and bug 146340?

I think my experience should belong to the bug 146340, so sorry for the
incorrect posting... :-(

Comment 44

16 years ago
JITR,
I think this bug is different than 146340- that refers to the delay in icon
reappearing in system tray.  With this bug, icon does not reappear at all.  With
multiple profiles, Quick Launch is disabled on exit.

Another bug exists for single profile users that have to uncheck,check prefs
again to get QuickLaunch re-enabled. :(  bug 165743
Grace, thanx for your explanation, which just confirmed my mistake.

All: Sorry for the incorrect posting, again.

Comment 46

16 years ago
I am seeing multiple profiles working with Mozilla 1.2.1 as well as recent nightly

marking worksforme

please reopen if you continue to see problems
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 47

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 48

16 years ago
Quicklaunch closes & must reload Mozilla when last window closed; only have one
profile, WinXP Home.
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.