Closed Bug 1440780 Opened 2 years ago Closed Last year

Implement opt-out-study action as an internal action

Categories

(Firefox :: Normandy Client, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed

People

(Reporter: mythmon, Assigned: mythmon)

References

Details

Attachments

(1 file)

This bug covers converting the opt-out-study action [0] an internal action (see bug 1436129).

[0]: https://github.com/mozilla/normandy/tree/dfd3ff3edc70ac04f8f043e040f9190854f80021/recipe-server/client/actions/opt-out-study
Blocks: 1474413
Blocks: 1481918
This ports the code from the Normandy server github repo to run as a local
action, instead of being fetched from the server.

The original code is here:
https://github.com/mozilla/normandy/tree/master/client/actions/opt-out-study
Attachment #8998650 - Attachment description: Bug 1440780 - Add Normandy action for add-on studies r=Gijs! → Bug 1440780 - Add Normandy action for add-on studies
Assignee: nobody → mcooper
Comment on attachment 8998650 [details]
Bug 1440780 - Add Normandy action for add-on studies

Andrew Swan [:aswan] has approved the revision.
Attachment #8998650 - Flags: review+
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc5cbee865e4
Add Normandy action for add-on studies r=aswan
Backed out for eslint failure on normandy/test/browser/head.js:78

backout: https://hg.mozilla.org/integration/autoland/rev/2d2241b48b73d5e9db851f566012992266fbfc69

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=dc5cbee865e4286a767dd69749314c909e2f7343

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=194926173&repo=autoland&lineNumber=260

[task 2018-08-20T20:37:08.843Z] running build_ext
[task 2018-08-20T20:37:08.843Z] building 'psutil._psutil_linux' extension
[task 2018-08-20T20:37:08.843Z] creating build
[task 2018-08-20T20:37:08.843Z] creating build/temp.linux-x86_64-2.7
[task 2018-08-20T20:37:08.843Z] creating build/temp.linux-x86_64-2.7/psutil
[task 2018-08-20T20:37:08.843Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
[task 2018-08-20T20:37:08.843Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
[task 2018-08-20T20:37:08.843Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_linux.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o
[task 2018-08-20T20:37:08.844Z] creating build/lib.linux-x86_64-2.7
[task 2018-08-20T20:37:08.844Z] creating build/lib.linux-x86_64-2.7/psutil
[task 2018-08-20T20:37:08.844Z] x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-Bsymbolic-functions -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o -o build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so
[task 2018-08-20T20:37:08.844Z] building 'psutil._psutil_posix' extension
[task 2018-08-20T20:37:08.844Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
[task 2018-08-20T20:37:08.844Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
[task 2018-08-20T20:37:08.844Z] x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-Bsymbolic-functions -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o -o build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so
[task 2018-08-20T20:37:08.844Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
[task 2018-08-20T20:37:08.844Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2018-08-20T20:37:08.844Z] 
[task 2018-08-20T20:37:08.844Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2018-08-20T20:42:43.966Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/toolkit/components/normandy/test/browser/head.js:78:82 | Infix operators must be spaced. (space-infix-ops)
[taskcluster 2018-08-20 20:42:44.536Z] === Task Finished ===
[taskcluster 2018-08-20 20:42:44.536Z] Unsuccessful task run with exit code: 1 completed in 596.768 seconds
Flags: needinfo?(mcooper)
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaab563115c8
Add Normandy action for add-on studies r=aswan
Backed out for failures on browser_AddonStudies.js

backout: https://hg.mozilla.org/integration/autoland/rev/1e98d3f45a4c0828b64a5b0212183db9a8be01bb

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=eaab563115c8a15ad26fb20e43f703dd0687e9b8

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=194933454&repo=autoland&lineNumber=14527
 
[task 2018-08-20T21:41:19.506Z] 21:41:19     INFO - TEST-START | toolkit/components/normandy/test/browser/browser_AddonStudies.js
[task 2018-08-20T21:41:19.562Z] 21:41:19     INFO - GECKO(4631) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2018-08-20T21:41:19.766Z] 21:41:19     INFO - TEST-INFO | started process screentopng
[task 2018-08-20T21:41:20.923Z] 21:41:20     INFO - TEST-INFO | screentopng: exit 0
[task 2018-08-20T21:41:20.924Z] 21:41:20     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/normandy/test/browser/browser_AddonStudies.js | Exception thrown - [Exception... "File error: Not found"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://mochitests/content/browser/toolkit/components/normandy/test/browser/browser_AddonStudies.js :: <TOP_LEVEL> :: line 6"  data: no]
[task 2018-08-20T21:41:20.926Z] 21:41:20     INFO - GECKO(4631) | MEMORY STAT | vsize 583MB | residentFast 287MB | heapAllocated 108MB
[task 2018-08-20T21:41:20.927Z] 21:41:20     INFO - TEST-OK | toolkit/components/normandy/test/browser/browser_AddonStudies.js | took 348ms
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0068ee254d4a
Add Normandy action for add-on studies r=aswan
Flags: needinfo?(mcooper)
https://hg.mozilla.org/mozilla-central/rev/0068ee254d4a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Blocks: 1488927
Depends on: 1490060
See Also: → 1490069
No longer blocks: 1488927
Depends on: 1488927
Regressions: 1545417
You need to log in before you can comment on or make changes to this bug.