If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Default paper size on Linux should use LC_PAPER

RESOLVED DUPLICATE of bug 147419

Status

()

Core
Printing: Output
--
enhancement
RESOLVED DUPLICATE of bug 147419
16 years ago
7 years ago

People

(Reporter: James Henstridge, Assigned: Roland Mainz)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041717

In recent versions of glibc (>=2.2, I think), there is support for retrieving
the default paper size associated with the locale (and can be overriden with the
LC_PAPER environment variable).

Using this would be a good way to ensure that people outside of North America
(and have their locales set correctly) see ISO paper sizes rather than american
ones.

The paper size can be retrieved with the nl_langinfo() function (must include
langinfo.h).  The two keys to pass as the argument _NL_PAPER_HEIGHT and
_NL_PAPER_WIDTH.

Unlike every other key passed to nl_langinfo, the glibc developers decided that
these two should return an int cast as a (char *) instead of a string, like the
man pages say it should.  The following has a small example of its use:
  http://sources.redhat.com/ml/libc-alpha/2001-04/msg00187.html

The result is in millimeters.
(Assignee)

Comment 1

16 years ago
Taking myself...
Assignee: rods → Roland.Mainz
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Blocks: 125824

Comment 2

13 years ago
*** Bug 249432 has been marked as a duplicate of this bug. ***
*** Bug 332210 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
(In reply to comment #1)
> Taking myself...
> 

So someone has been working on this since 2002...will it ever be fixed??

Comment 5

11 years ago
*** Bug 281057 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
*** Bug 326305 has been marked as a duplicate of this bug. ***

Comment 7

11 years ago
Can someone please mark this as duplicate of #147419 which has been assigned ?

Comment 8

11 years ago
Sorry about the confusion, please ignore my last comment. #147419 should be marked as duplicate of this one, since this one's been assigned. Tx.!

Comment 9

11 years ago
It's either too late or someone slipped drugs in my last coffee ;)

I hate to say #7 was correct, so asking again to mark this as duplicate of #147419.

Comment 10

11 years ago
Roland, you can give us any hints on what to do in order to fix this?

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 147419

Updated

7 years ago
You need to log in before you can comment on or make changes to this bug.