Lightning not working because non-restartless extensions are not supported, convert to bootstrapped (restartless) or make it fully part of Thunderbird

RESOLVED FIXED in 6.5

Status

defect
--
blocker
RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: jorgk, Unassigned)

Tracking

(Blocks 1 bug)

Lightning 6.3

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
In bug 1447831 and bug 1448221 M-C removed the support for non-bootstrapped add-ons. The removal of XUL overlays will follow suit in bug 1448162 and friends.

We've currently lost Mozmill testing (see bug 1449149), but even if this is restored, the Lightning and GData add-ons won't load (see bug 1449149 comment #2 and above). It is just a matter of time before Calendar related Xpcshell tests will also fail. At time of writing they still work.

This bug will also serve to land temporary fixes to disable Calendar tests when required.

(I hope this is not a duplicate, I did a brief check, but nothing came up.)
(Reporter)

Comment 1

a year ago
I had a long fight with getting Mozmill tests disabled in Calendar. Basically we got errors out of shared-modules/test-calendar-utils.js. I resisted modifying that file, but it was the last resort.

Modifications to the makefile didn't help. Failed attempts here:
https://hg.mozilla.org/try-comm-central/rev/ac29239ac1c7b884e80490d9707b9c799930d2b2
https://hg.mozilla.org/try-comm-central/rev/50f43b9f766564b7e9765594a28b2b6682d951e6
https://hg.mozilla.org/try-comm-central/rev/f7250ca68c19145c6db64f8ed2070cfbed5d9964
https://hg.mozilla.org/try-comm-central/rev/e66569b1652fcf174c6d8587ef7219200c4710d4
https://hg.mozilla.org/try-comm-central/rev/399d06f8aa8a3ca490a9a3e92f06a8013214752a

The last resort would have been to switch Calendar off completely:
https://hg.mozilla.org/try-comm-central/rev/4f5b7cec2b86169675efa94aebb2c24e39a3cfa1

So this patch leaved switches off Mozmill but still leaves Xpcshell in place, ... for now.
(Reporter)

Updated

a year ago
Keywords: leave-open

Comment 2

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/784233e550fd
temporarily remove all Mozmill testing in Calendar. rs=bustage-fix
(Reporter)

Comment 3

a year ago
Looks like testDummy.js is greatly upsetting the GC in JS, see bug 1450128 :-(
Summary: Convert Lightning to a bootstrapped (restartless) add-on or make it fully part of Thunderbird → Lightning not working because non-restartless extensions are not supported, convert to bootstrapped (restartless) or make it fully part of Thunderbird
Version: unspecified → Lightning 6.3
(Reporter)

Updated

11 months ago
Duplicate of this bug: 1462780
Comment hidden (off-topic)
Lightning 6.5 seems to be (partially) working in Thunderbird 63.0a1. Can we close this report?

Comment 7

9 months ago
I have only seen it work after an update.

Then when you quit and restart Thunderbird it is listed as "Enabled" but you can't use it. There is no "Events and Tasks" menu item or Today Pane.

I haven't tried today's build yet.

Comment 8

9 months ago
walt, is that with a profile you only use for Daily? Does diabling, retarting, enabling, restarting let it persist across further restarts?

Comment 9

9 months ago
(In reply to [:MakeMyDay] from comment #8)
> walt, is that with a profile you only use for Daily? Does diabling,
> retarting, enabling, restarting let it persist across further restarts?

It is with a profile I only use for Daily with one email account, which I only run once a day to update if there is an update available.

Interesting finds here.

Using Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Thunderbird/63.0a1 BuildID: 20180801100234

I tried a test profile without any accounts set up, and I am asked to Restart when disabling and enabling the extension.
Lightning persists after enabling and several restart tests.

Added my email account and am no longer asked to Restart when disabling or enabling the extension. Lightning does not appear upon a restart after clicking Enable.

I see this error in the Browser Console.

WebExtensions: Legacy WebExtension {e2fda1a4-762b-4020-b5ad-a41df1933103} loading after app startup, refusing to load immediately. 2 ext-legacy.js:26

Using the Windows build from 20180801 with a test profile and no accounts set up on Windows 10, I don't get asked to Restart when enabling or disabling Lightning, and it does not persist.

Comment 10

9 months ago
Thanks, can you file a separate bug for that and make it block bug 1476259?
(Reporter)

Comment 11

9 months ago
Bug 1477506? Add STR there.

Comment 12

9 months ago
I just upgraded my TB daily to 63.0a1 (2018-08-01) (64-bit) just now; both the calendar and tasks tabs are there, and functionality seems fine.

Comment 13

9 months ago
(In reply to Helge Skjeveland from comment #12)
> I just upgraded my TB daily to 63.0a1 (2018-08-01) (64-bit) just now; both
> the calendar and tasks tabs are there, and functionality seems fine.

Restarting TB disables Lightning 6.5 (the title-bar tabs go away).  It's necessary to re-enable it by disabling it from Tools | Add-ons, then re-starting, and go back in to the Tools | Add-ons, when I see "This is a legacy add-on, a re-start is required to continue". Then, once re-starting, Lightning is again there; but, when AGAIN re-starting, it's gone again.  It has to be forcibly disabled and re-enabled as described above.
ALso bug  (likely bug 1477956 will fix, I think)
Another thing I just noticed in doing more testing.

When a user first installs and opens a release version or 60 beta, they are informed that "Thunderbird now contains calendaring functionality by integrating the Lightning extension" with the options to click the Learn More, Disable, Keep or close x buttons.

In Daily that doesn't appear until after you go to Add-ons Manager, Enable Lightning and restart Daily.
(In reply to WaltS48 [:walts48] from comment #15)
> Another thing I just noticed in doing more testing.
> 
> When a user first installs and opens a release version or 60 beta, they are
> informed that "Thunderbird now contains calendaring functionality by
> integrating the Lightning extension" with the options to click the Learn
> More, Disable, Keep or close x buttons.
> 
> In Daily that doesn't appear until after you go to Add-ons Manager, Enable
> Lightning and restart Daily.

I'd really like to get rid of that message. We've had it for three years now, and if users haven't made up their mind yet…
Flags: needinfo?(philipp)
Flags: needinfo?(makemyday)
(In reply to Geoff Lankow (:darktrojan) from comment #16)
> (In reply to WaltS48 [:walts48] from comment #15)
> > When a user first installs and opens a release version or 60 beta, they are
> > informed that "Thunderbird now contains calendaring functionality by
> > integrating the Lightning extension" with the options to click the Learn
> > More, Disable, Keep or close x buttons.
> 
> I'd really like to get rid of that message. We've had it for three years
> now, and if users haven't made up their mind yet…

Good point, fine with me!
Flags: needinfo?(philipp)

Comment 18

9 months ago
(In reply to Geoff Lankow (:darktrojan) from comment #16)
> I'd really like to get rid of that message. We've had it for three years
> now, and if users haven't made up their mind yet…

Sure, we can stop displaying that message (but not removing the code for doing so, since I still will need that for an upcoming patch). Can you file a bug for it?
Flags: needinfo?(makemyday)
(Reporter)

Comment 19

9 months ago
(In reply to Stefan Sitter [:ssitter] from comment #6)
> Lightning 6.5 seems to be (partially) working in Thunderbird 63.0a1. Can we
> close this report?
Yes. Read bug 1473244 comment #0 and follow bug 1476259. There is more in the works: Bug 1477956.

In general, the overlay loader and Lightning as a non-restartless XUL add-on with overlays might not be the final solution, but we should file another bug for future drastic changes.
Target Milestone: --- → 6.5
(Reporter)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED

Updated

7 months ago
Blocks: 1493008
You need to log in before you can comment on or make changes to this bug.