Closed Bug 14685 Opened 20 years ago Closed 20 years ago

Sidebar fails to show after picking "View / Sidebar" menu

Categories

(SeaMonkey :: Sidebar, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: slamm, Assigned: slamm)

References

Details

Attachments

(2 files)

Comments from beard@netscape.com,

 [....] If I use the menu, the grippy shows and hides, but I
can't expand it. And, when I reshow the grippy, I get the following
assertions:

User break at 1F4A4F48 dprintf(const char*, ...)+00098
  Assertion: "null pointer" (inURI) at file nsIOService.cpp, line 143
  Calling chain using A6/R1 links
   Back chain  ISA  Caller
   00000000    PPC  1F723680
   0AD1C740    PPC  1F71FDE8  main+0013C
   0AD1C6D0    PPC  1F71F98C  main1(int, char**)+004C4
   0AD1C5D0    PPC  1DF73620  nsAppShellService::Run()+00020
   0AD1C590    PPC  1D9C43CC  nsAppShell::Run()+00050
   0AD1C510    PPC  1D9C5170  nsMacMessagePump::DoMessagePump()+00044
   0AD1C4C0    PPC  1D9C5374  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+00084
   0AD1C470    PPC  1D9C562C  nsMacMessagePump::DoMouseDown(EventRecord&)+00084
   0AD1C380    PPC  1D9C5F5C  nsMacMessagePump::DoMenu(EventRecord&, long)+0004C
   0AD1C340    PPC  1D9C6274
nsMacMessagePump::DispatchMenuCommandToRaptor(EventRecord&, long
)+00050
   0AD1C300    PPC  1D9BF810
nsMacMessageSink::DispatchMenuCommand(EventRecord&, long)+00050
   0AD1C2C0    PPC  1D9B8CC0
nsMacWindow::HandleMenuCommand(EventRecord&, long)+00054
   0AD1C260    PPC  1D9B96AC
nsMacEventHandler::HandleMenuCommand(EventRecord&, long)+001D4
   0AD1C1A0    PPC  1D9A101C  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
   0AD1C160    PPC  1D9A0F08  nsWindow::DispatchEvent(nsGUIEvent*,
nsEventStatus&)+00088
   0AD1C110    PPC  1D9B061C  nsMenuBar::MenuSelected(const nsMenuEvent&)+0009C
   0AD1C0C0    PPC  1D9AB860  nsMenu::MenuItemSelected(const nsMenuEvent&)+002AC
   0AD1BEC0    PPC  1D9B2D28  nsMenuItem::MenuItemSelected(const
nsMenuEvent&)+00050
   0AD1BE80    PPC  1D9B3568  nsMenuItem::DoCommand()+0063C
   0AD1BD70    PPC  1EC309E0
RDFElementImpl::HandleDOMEvent(nsIPresContext&, nsEvent*, nsIDOM
Event**, unsigned int, nsEventStatus&)+0047C
   0AD1BC30    PPC  1DAFB834
nsEventListenerManager::HandleEvent(nsIPresContext&, nsEvent*, n
sIDOMEvent**, unsigned int, nsEventStatus&)+01780
   0AD1BAE0    PPC  1F2F08C0  nsJSEventListener::HandleEvent(nsIDOMEvent*)+001AC
   0AD1B9C0    PPC  1F274D6C  nsJSContext::CallFunction(void*, void*,
unsigned int, void*, int
*)+002B4
   0AD1B8F0    PPC  1F3D3E48  JS_CallFunction+00044
   0AD1B8B0    PPC  1F3F1748  js_InternalCall+000CC
   0AD1B800    PPC  1F3F149C  js_Invoke+00974
   0AD1B700    PPC  1F3FA388  js_Interpret+082FC
   0AD1B380    PPC  1F3F149C  js_Invoke+00974
   0AD1B280    PPC  1F3FA388  js_Interpret+082FC
   0AD1AF00    PPC  1F3F149C  js_Invoke+00974
   0AD1AE00    PPC  1F3FA388  js_Interpret+082FC
   0AD1AA80    PPC  1F3F1438  js_Invoke+00910
   0AD1A980    PPC  1E000CE4  WrappedNative_CallMethod(JSContext*,
JSObject*, unsigned int, lo
ng*, long*)+00170
   0AD1A900    PPC  1DFFEE38
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext*, nsXPCWrap
pedNative*, const XPCNativeMemberDescriptor*,
nsXPCWrappedNativeClass::CallMode, unsigned int
, long*, long*)+00E00
   0AD1A6D0    PPC  1F4F8634  XPTC_InvokeByIndex+0002C
   0AD1A690    PPC  1F4F873C  _XPTC_InvokeByIndex+000C8
   0AD1A5E8    PPC  1EBF3F90  RDFXMLDataSourceImpl::Init(const char*)+0007C
   0AD1A588    PPC  1F755A7C  NS_NewURI(nsIURI**, const char*, nsIURI*)+000D0
   0AD1A518    PPC  1F06ECA4  nsIOService::NewURI(const char*,
nsIURI*, nsIURI**)+0002C
   0AD1A498    PPC  1F06EB60  GetScheme(const char*, char**)+00034
   0AD1A438    PPC  1F4A5200  nsDebug::Assertion(const char*, const
char*, const char*, int)+0
0040
  Closing log

Followed by:

User break at 1F4A4F48 dprintf(const char*, ...)+00098
  PreCondition: "null ptr" (aURI != nsnull) at file nsRDFService.cpp, line 1030
  Calling chain using A6/R1 links
   Back chain  ISA  Caller
   00000000    PPC  1F723680
   0AD1C740    PPC  1F71FDE8  main+0013C
   0AD1C6D0    PPC  1F71F98C  main1(int, char**)+004C4
   0AD1C5D0    PPC  1DF73620  nsAppShellService::Run()+00020
   0AD1C590    PPC  1D9C43CC  nsAppShell::Run()+00050
   0AD1C510    PPC  1D9C5170  nsMacMessagePump::DoMessagePump()+00044
   0AD1C4C0    PPC  1D9C5374  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+00084
   0AD1C470    PPC  1D9C562C  nsMacMessagePump::DoMouseDown(EventRecord&)+00084
   0AD1C380    PPC  1D9C5F5C  nsMacMessagePump::DoMenu(EventRecord&, long)+0004C
   0AD1C340    PPC  1D9C6274
nsMacMessagePump::DispatchMenuCommandToRaptor(EventRecord&, long
)+00050
   0AD1C300    PPC  1D9BF810
nsMacMessageSink::DispatchMenuCommand(EventRecord&, long)+00050
   0AD1C2C0    PPC  1D9B8CC0
nsMacWindow::HandleMenuCommand(EventRecord&, long)+00054
   0AD1C260    PPC  1D9B96AC
nsMacEventHandler::HandleMenuCommand(EventRecord&, long)+001D4
   0AD1C1A0    PPC  1D9A101C  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
   0AD1C160    PPC  1D9A0F08  nsWindow::DispatchEvent(nsGUIEvent*,
nsEventStatus&)+00088
   0AD1C110    PPC  1D9B061C  nsMenuBar::MenuSelected(const nsMenuEvent&)+0009C
   0AD1C0C0    PPC  1D9AB860  nsMenu::MenuItemSelected(const nsMenuEvent&)+002AC
   0AD1BEC0    PPC  1D9B2D28  nsMenuItem::MenuItemSelected(const
nsMenuEvent&)+00050
   0AD1BE80    PPC  1D9B3568  nsMenuItem::DoCommand()+0063C
   0AD1BD70    PPC  1EC309E0
RDFElementImpl::HandleDOMEvent(nsIPresContext&, nsEvent*, nsIDOM
Event**, unsigned int, nsEventStatus&)+0047C
   0AD1BC30    PPC  1DAFB834
nsEventListenerManager::HandleEvent(nsIPresContext&, nsEvent*, n
sIDOMEvent**, unsigned int, nsEventStatus&)+01780
   0AD1BAE0    PPC  1F2F08C0  nsJSEventListener::HandleEvent(nsIDOMEvent*)+001AC
   0AD1B9C0    PPC  1F274D6C  nsJSContext::CallFunction(void*, void*,
unsigned int, void*, int
*)+002B4
   0AD1B8F0    PPC  1F3D3E48  JS_CallFunction+00044
   0AD1B8B0    PPC  1F3F1748  js_InternalCall+000CC
   0AD1B800    PPC  1F3F149C  js_Invoke+00974
   0AD1B700    PPC  1F3FA388  js_Interpret+082FC
   0AD1B380    PPC  1F3F149C  js_Invoke+00974
   0AD1B280    PPC  1F3FA388  js_Interpret+082FC
   0AD1AF00    PPC  1F3F149C  js_Invoke+00974
   0AD1AE00    PPC  1F3FA388  js_Interpret+082FC
   0AD1AA80    PPC  1F3F1438  js_Invoke+00910
   0AD1A980    PPC  1E000CE4  WrappedNative_CallMethod(JSContext*,
JSObject*, unsigned int, lo
ng*, long*)+00170
   0AD1A900    PPC  1DFFEE38
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext*, nsXPCWrap
pedNative*, const XPCNativeMemberDescriptor*,
nsXPCWrappedNativeClass::CallMode, unsigned int
, long*, long*)+00E00
   0AD1A6D0    PPC  1F4F8634  XPTC_InvokeByIndex+0002C
   0AD1A690    PPC  1F4F873C  _XPTC_InvokeByIndex+000C8
   0AD1A5E4    PPC  1EBE637C  RDFServiceImpl::GetDataSource(const
char*, nsIRDFDataSource**)+0
0040
   0AD1A2E4    PPC  1F4A50C4  nsDebug::PreCondition(const char*, const
char*, const char*, int
)+00040
  Closing log
OS: Mac System 8.5 → All
Hardware: Macintosh → All
I see this on Linux and Windows too.
1. Collapse the sidebar by clicking on the grippy
2. Hide the sidebar with menuitem "View / Sidebar"
3. Show it again.
4. Try to expand it by clicking on the grippy.
The grippy changes state, but the sidebar does not expand.

I have a test case that I will attach.
Attached file Save as hide.css
Assignee: slamm → evaughan
Eric, is this a box bug? Reassigning to evaughan.
Status: NEW → ASSIGNED
*** Bug 16122 has been marked as a duplicate of this bug. ***
*** Bug 18549 has been marked as a duplicate of this bug. ***
Summary: Sidebar fails to open on the Mac → Sidebar fails to show after picking "View / Sidebar" menu
Giving a better title
*** Bug 18760 has been marked as a duplicate of this bug. ***
*** Bug 20818 has been marked as a duplicate of this bug. ***
Target Milestone: M13
reproduced in 12/5 build.  can't drag it open either, need to open a new window
tosee a sidebar. setting p3 for m13.  Eric, please look at this soon to
determine if you should accept it, and if so you can move to m14 if need be,
since collapsing and hiding are less likely to be used together.
Assignee: evaughan → slamm
Status: ASSIGNED → NEW
*** Bug 17334 has been marked as a duplicate of this bug. ***
I am going to take a closer look at this.
*** Bug 22617 has been marked as a duplicate of this bug. ***
*** Bug 22982 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
*** Bug 23202 has been marked as a duplicate of this bug. ***
Whiteboard: Fix ready.
I have a fix!
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: Fix ready.
Fixed.
*** Bug 24158 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
verified on 1/19 builds
I can still repro this with today's (1.25.00) build from the tip.
Status: VERIFIED → REOPENED
getting off m13 radar til this can be checked out
Resolution: FIXED → ---
Target Milestone: M13 → M14
Alex, I don't see this. Is there a particular platform or test case that you see 
this on? I'm using 1/26 M14 build. I can close sidebar via view sidebar, then 
shutdown restart, choose view sidebar and it open up ok. Resolving as 
worksforme.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Try this:
- open nav
- click on the sidebar grippy on to close the sidebar
- choose View->Sidebar to hide it
- choose View->Sidebar to unhide it.

You are now unable to open the sidebar.
You should be in QA 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
*** Bug 21023 has been marked as a duplicate of this bug. ***
*** Bug 30409 has been marked as a duplicate of this bug. ***
Move to M16 ...
Target Milestone: M14 → M16
still occurs on 4/10 builds
*** Bug 35542 has been marked as a duplicate of this bug. ***
spam: changing qa contact on sidebar bugs from paulmac to shrir@netscape.com 
(all 67 of them!)
QA Contact: paulmac → shrir
Keywords: nsbeta2
Can anyone still reproduce this?
nope..
I'll mark it fixed then.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
verified (2000050808)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.