Closed Bug 1490428 Opened Last year Closed Last month

When searching for e-mail address in Gloda, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item (full address) but the entered partial address

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(thunderbird_esr6869+ fixed, thunderbird70 fixed, thunderbird71 fixed)

VERIFIED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: azuercher, Assigned: jorgk)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180621121604

Steps to reproduce:

type start of an email address in the search bar.  I get some suggestions that include the full email address I am searching for.  I use the arrow keys to move down to the suggested email address I want (it is now highlighted in a blue).  I press the ENTER key to select the suggested email address and the search results window pops up but it only searches for the partial email that I had typed in the box.  iT does not search for the full email address that was highlighted blue.   If I click my mouse cursor on the suggested name it will search for the full email address.  


Actual results:

search results tab shows search for the partial email address that i had started typing in the box before the suggestion were listed.


Expected results:

it should have searched for the full email address that was highlighted in blue when I pressed enter key.
Summary: When using search bar in inbox, using cursor to highlight a recommendation and pressing enter does not search for the highlighted item → When using search bar in inbox, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item
It worked differently in version 52?
Component: Untriaged → Search
Flags: needinfo?(azuercher)
Summary: When using search bar in inbox, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item → When using search messages, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item
Wayne, do this: Using Gloda search, enter an incomplete address. Use the arrow keys to navigate to a suggested address, hit enter. Gloda will now only search for the entered incomplete address, not the full address of the item.

Looks like a regression from the various auto-complete changes we did. And yes, it works correctly in TB 52.

Alice, can you please find the regression for us on Daily.
Flags: needinfo?(azuercher) → needinfo?(alice0775)
Keywords: regression
Summary: When using search messages, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item → When using search messages using Gloda, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item
Thanks Alice, much appreciated as always!!

Marco and Masayuki-san, where from here? You might be familiar with TB's Gloda search (Ctrl+K) which uses keyboard navigation or clicking. Apparently when using keyboard navigation something has changed in what is accepted.

Alice is almost always right, so how does your change relate to what we're doing? Is there perhaps an option we can set to bring back the old behaviour?
Blocks: 1498500
Duplicate of this bug: 1498500
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1551833
Duplicate of this bug: 1578027

(In reply to Jorg K (GMT+2) from comment #4)

...
Marco and Masayuki-san, where from here? You might be familiar with TB's
Gloda search (Ctrl+K) which uses keyboard navigation or clicking. Apparently
when using keyboard navigation something has changed in what is accepted.

Alice is almost always right, so how does your change relate to what we're
doing? Is there perhaps an option we can set to bring back the old behaviour?

Flags: needinfo?(mak77)
Regressed by: 1434837

Seems to work in TB 68. Can someone confirm?

Status: NEW → RESOLVED
Closed: Last month
Flags: needinfo?(mak77)
Resolution: --- → WORKSFORME

(In reply to Jorg K (GMT+2) from comment #9)

Seems to work in TB 68. Can someone confirm?

I tried it in TB68 and it didn't work. Did you select contact by arrow keys and pressing Enter? See the pictures:
https://www.celdy.com/wp-content/uploads/2019/09/Bug1.png
https://www.celdy.com/wp-content/uploads/2019/09/Bug2.png

Yes, I typed "Bugzilla" into the Ctrl+K searchbox. Three matches came up, I navigated with the arrow keys and then hit enter, which displayed the results. Do you use any add-ons? Can you start with add-ons disabled, see Help menu.

(In reply to Jorg K (GMT+2) from comment #11)

Yes, I typed "Bugzilla" into the Ctrl+K searchbox. Three matches came up, I navigated with the arrow keys and then hit enter, which displayed the results. Do you use any add-ons? Can you start with add-ons disabled, see Help menu.

I restarted TB in safe mode with disabled add-ons and it is still happening. TB 68.0, ID 20190826194726, Windows_NT 10.0, Language ["cs"]

Ben, can you give this a shot.

Flags: needinfo?(benjamin)

This does not work consistently

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

I'll take another look.

Assignee: nobody → jorgk
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

+1
macOS Mojave
Thunderbird 60.9

This is actually not the only regression from bug 1434837 (see comment #3). We also fixed bug 1499410 and the messy ESR 60 follow-up in bug 1536374.

The fix is here https://hg.mozilla.org/comm-central/rev/d3daa2594870 changing ontextentered and onkeypress handlers.

Note that for Gloda, those don't exist, not even in ESR 60:
https://dxr.mozilla.org/comm-esr60/source/mail/base/content/specialTabs.xul#54
https://searchfox.org/comm-central/rev/bcf328da9b27554e1f11d5ebf4d6de0c02e5544d/mail/base/content/messenger.xul#716

Sigh, sadly the summary didn't spell out the issue: Navigation and hitting enter works, but when using enter, Gloda returns all matches based on the partial e-mail address entered and not the full address in the suggestion.

Flags: needinfo?(benjamin)
Summary: When using search messages using Gloda, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item → When searching for e-mail address in Gloda, using keyboard to highlight a recommendation and pressing enter does not search for the highlighted item (full address) but the entered partial address
Status: UNCONFIRMED → NEW
Ever confirmed: true

OK, so according to bug 1499410 comment #14 we should add {mozSystemGroup: true} to the event listeners ... if only I could find them. I added it in a few places bug that code isn't run since the debug doesn't come out. I guess searchWidgets.js isn't for Gloda anyway. Alex, you've been messing with auto-complete, can you take a look, please. (And you asked to help with regressions. Sadly this is broken since TB 60.)

Is onkeypress still the go? Then we could add it to
https://searchfox.org/comm-central/rev/bcf328da9b27554e1f11d5ebf4d6de0c02e5544d/mail/base/content/messenger.xul#716
to set the search term.

I'm just puzzled that "click" works as expected and "keypress" with enter doesn't. Somewhere there must be a click handler set.

Flags: needinfo?(alessandro)

Finally found it. One line. Broken since TB 60 :-(

First reviewer wins. Read bug 1499410 comment #14.

Attachment #9091313 - Attachment is obsolete: true
Flags: needinfo?(alessandro)
Attachment #9091315 - Flags: review?(mkmelin+mozilla)
Attachment #9091315 - Flags: review?(alessandro)
Attachment #9091315 - Flags: review?(acelists)
Attachment #9091315 - Flags: approval-comm-esr68+
Attachment #9091315 - Flags: approval-comm-beta+
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird 71.0
Comment on attachment 9091315 [details] [diff] [review]
1490428-use-system-group2.patch

Review of attachment 9091315 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you, works for me.
Attachment #9091315 - Flags: review?(acelists) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1317ce452497
Fix Gloda auto-complete not using suggestion but search string. r=aceman

Status: ASSIGNED → RESOLVED
Closed: Last monthLast month
Resolution: --- → FIXED
Attachment #9091315 - Flags: review?(mkmelin+mozilla)
Attachment #9091315 - Flags: review?(alessandro)

Working in the beta.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.