Closed Bug 1497070 Opened 2 years ago Closed 2 years ago

In-page links are broken due to <base href> added during Mojo migration

Categories

(bugzilla.mozilla.org :: General, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mats, Assigned: kohei.yoshino)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
Details | Review
STR
1. load https://bugzilla.mozilla.org/attachment.cgi?id=618051&action=diff
2. click on of the "Link Here" links 

ACTUAL RESULTS
https://bugzilla.mozilla.org/#a/layout/generic/nsFrame.cpp_sec3
is loaded, which is not at all a link to the relevant section
of the patch.
This is due to `<base href="https://bugzilla.mozilla.org/">` in the page `<head>` added during the Mojo migration (Bug 1455495). :dylan, do we need this now?

https://github.com/mozilla-bteam/bmo/blob/master/template/en/default/global/header.html.tmpl#L101
Flags: needinfo?(dylan)
Keywords: regression
Links on this pages are also broken: https://bugzilla.mozilla.org/page.cgi?id=quicksearch.html
Summary: "Link Here" links in patches are broken → In-page links are broken due to <base href> added during Mojo migration
Attached file GitHub Pull Request
I think it was originally added for Bug 1468848, which was backed out shortly. Should be safe to remove it.
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Flags: needinfo?(dylan)
See Also: → 1468848
See Also: → 1497077
Merged to master.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Depends on: bmo-mojo
See Also: → 133549
No longer depends on: bmo-mojo
Regressed by: bmo-mojo
You need to log in before you can comment on or make changes to this bug.