[File a new bug if this happens again] Intermittent /update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm

RESOLVED FIXED in Firefox 68

Status

()

defect
P5
normal
RESOLVED FIXED
2 months ago
8 days ago

People

(Reporter: intermittent-bug-filer, Assigned: bytesized)

Tracking

({intermittent-failure, regression})

unspecified
mozilla68
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago
treeherder

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=242550209&repo=mozilla-central

https://queue.taskcluster.net/v1/task/QDL0oqj_QB-HXe_ARE_bdw/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/QDL0oqj_QB-HXe_ARE_bdw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

11:40:10 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js
11:40:10 INFO - GECKO(3244) | *** AUS:SVC UpdateManager:_loadXMLFileIntoArray - XML file does not exist. path: C:\ProgramData\Mozilla\updates\B65BC8F4048C4D35\active-update.xml
11:40:10 INFO - GECKO(3244) | *** AUS:SVC Creating UpdateService
11:40:10 INFO - GECKO(3244) | *** AUS:SVC Logging current UpdateService status:
11:40:10 INFO - GECKO(3244) | *** AUS:SVC UpdateService.canCheckForUpdates - able to check for updates
11:40:10 INFO - GECKO(3244) | *** AUS:SVC isServiceInstalled - returning true
11:40:10 INFO - GECKO(3244) | *** AUS:SVC shouldUseService - returning false
11:40:10 INFO - GECKO(3244) | *** AUS:SVC getCanApplyUpdates - testing write access C:\ProgramData\Mozilla\updates\B65BC8F4048C4D35\update.test
11:40:10 INFO - GECKO(3244) | *** AUS:SVC getCanApplyUpdates - testing write access Z:\task_1556190101\build\application\firefox\update.test
11:40:10 INFO - GECKO(3244) | *** AUS:SVC getCanApplyUpdates - able to apply updates
11:40:10 INFO - GECKO(3244) | *** AUS:SVC getCanStageUpdates - staging updates is disabled by preference app.update.staging.enabled
11:40:10 INFO - GECKO(3244) | *** AUS:SVC Elevation required: false
11:40:10 INFO - GECKO(3244) | *** AUS:SVC Update being handled by other instance: false
11:40:10 INFO - GECKO(3244) | *** AUS:SVC Downloading: false
...
11:40:16 INFO - GECKO(3244) | *** AUS:SVC Downloader:onStopRequest - notifying observers of error. topic: update-error, status: download-attempt-failed
11:40:16 INFO - TEST-INFO | started process screenshot
11:40:16 INFO - TEST-INFO | screenshot: exit 0
11:40:16 INFO - Buffered messages logged at 11:40:10
11:40:16 INFO - Entering test bound setupTestCommon
11:40:16 INFO - Leaving test bound setupTestCommon
11:40:16 INFO - Entering test bound aboutPrefs_foregroundCheck_partialBadSize
11:40:16 INFO - 11:40:10:130 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/shared.js | [setUpdateURL : 220] setting app.update.url to http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?detailsURL=http://127.0.0.1:8888/&partialPatchOnly=1&invalidPartialSize=1&appVersion=68.0a1&slowUpdateCheck=1&useSlowDownloadMar=1
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The panel ID should equal checkingForUpdates - "checkingForUpdates" == "checkingForUpdates" -
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | There should not be an active update -
11:40:16 INFO - 11:40:10:750 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556190101\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueCheck
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The panel ID should equal downloading - "downloading" == "downloading" -
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | There should be an active update -
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The active update state should equal downloading -
11:40:16 INFO - 11:40:10:955 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556190101\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
11:40:16 INFO - Buffered messages logged at 11:40:16
11:40:16 INFO - Console message: [JavaScript Error: "Error: BitsError {type: 39, action: 6, stage: 2, codeType: none}" {file: "resource://gre/modules/Bits.jsm" line: 79}]
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The patch property bitsResult value should equal 2147549183 -
11:40:16 INFO - 11:40:16:062 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556190101\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The panel ID should equal downloadFailed - "downloadFailed" == "downloadFailed" -
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | There should not be an active update -
11:40:16 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | The panel's link href should equal the expected value - "http://127.0.0.1:8888/" == "http://127.0.0.1:8888/" -
11:40:16 INFO - Buffered messages finished
11:40:16 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
11:40:16 INFO - failure@resource://gre/modules/Bits.jsm:151:21
11:40:16 INFO - cancelAsync/<@resource://gre/modules/Bits.jsm:288:21
11:40:16 INFO - requestPromise/<@resource://gre/modules/Bits.jsm:176:7
11:40:16 INFO - requestPromise@resource://gre/modules/Bits.jsm:140:10
11:40:16 INFO - cancelAsync@resource://gre/modules/Bits.jsm:287:12
11:40:16 INFO - Downloader_cancel@resource://gre/modules/UpdateService.jsm:3726:27
11:40:16 INFO - Downloader_onProgress@resource://gre/modules/UpdateService.jsm:4240:12
11:40:16 INFO - wrappedObserver_onProgress@resource://gre/modules/Bits.jsm:426:20
11:40:16 INFO - Rejection date: Thu Apr 25 2019 11:40:16 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
11:40:16 INFO - Stack trace:
11:40:16 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
11:40:16 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1140
11:40:16 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
11:40:16 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
11:40:16 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
11:40:16 INFO - Leaving test bound aboutPrefs_foregroundCheck_partialBadSize
11:40:16 INFO - GECKO(3244) | MEMORY STAT | vsize 736MB | vsizeMaxContiguous 609MB | residentFast 255MB | heapAllocated 126MB
11:40:16 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | took 6280ms
11:40:16 INFO - checking window state
11:40:17 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 3816
11:40:17 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 4244
11:40:17 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 3420
11:40:17 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 3708
11:40:17 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 3528
11:40:18 INFO - GECKO(3244) | Completed ShutdownLeaks collections in process 2724
11:40:18 INFO - TEST-START | Shutdown
11:40:18 INFO - Browser Chrome Test Summary
11:40:18 INFO - Passed: 9
11:40:18 INFO - Failed: 1
11:40:18 INFO - Todo: 0
11:40:18 INFO - Mode: e10s
11:40:18 INFO - *** End BrowserChrome Test Results ***

Comment hidden (Intermittent Failures Robot)
Summary: Intermittent TV toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm → Intermittent toolkit/mozapps/update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm
Duplicate of this bug: 1546959
Duplicate of this bug: 1547249
Duplicate of this bug: 1547954

Updated

Last month
Duplicate of this bug: 1548932
Comment hidden (Intermittent Failures Robot)
Assignee: nobody → ksteuber
Attachment #9065208 - Attachment description: Bug 1546957 - Fix intermittent error codes 39,50 from cancelling a request after shutdown r=rstrong → Bug 1546957 - Fix intermittent error codes 39,40,50 from cancelling a request after shutdown r=rstrong
Attachment #9065208 - Attachment description: Bug 1546957 - Fix intermittent error codes 39,40,50 from cancelling a request after shutdown r=rstrong → Bug 1546957 - Prevent BITS Requests from being cancelled twice r=rstrong

Comment 8

Last month
Pushed by ksteuber@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/afaf68ba6e54
Prevent BITS Requests from being cancelled twice r=rstrong

Comment 9

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Summary: Intermittent toolkit/mozapps/update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm → [File a new bug if this happens again] Intermittent update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm
Summary: [File a new bug if this happens again] Intermittent update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm → [File a new bug if this happens again] Intermittent /update/tests/browser/<test-name> | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.