Closed Bug 1548864 Opened 1 year ago Closed 1 year ago

Build and ship Fennec Nightly off mozilla-beta

Categories

(Release Engineering :: Release Automation: Other, task)

task
Not set

Tracking

(firefox68+ fixed)

RESOLVED FIXED
Tracking Status
firefox68 + fixed

People

(Reporter: jlorenzo, Assigned: jlorenzo)

References

Details

Attachments

(12 files, 6 obsolete files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
896 bytes, patch
Details | Diff | Splinter Review

As part of the Fennec ESR68 transition plan[1], we need to let Fennec Nightly ride the 68 train. This means we want to ship Fennec nightly off mozilla-beta for a full cycle.
Most of this work will be useful when we migrate Fennec Nightly to mozilla-esr68. For instance, we want:

  • the ability to create APKs with different branding off the same repo
  • to schedule a nightly graph outside of mozilla-central
  • to ensure geckoview remains shipped of the regular repos

What needs to be done

Optional needs

We may want to keep the version numbers. This is tracked under bug 1548655

[1] https://docs.google.com/document/d/1oRPkwP3l7QzdQYj0Wn7d_3EfTZaakocA_i_pGKlG0dI/edit

Bug 1548864 - part 1: Factorize android.yml

Bug 1548864 - part 2: Enable -beta Android builds

Bug 1548864 - part 3: Change promote_fennec to handle beta tasks only

This means -nightly tasks don't end up in that promote graph.
The push-apk loader also wires the expected dependencies.

Bug 1548864 - part 4: Do not run any Android -beta balrog jobs

Bug 1548864 - part 5: Ensure geckoview Nightly is not shipped off mozilla-beta

Neither from the beta graph nor from the nightly one.
It's notably done by not exposing the geckoview artifacts on the nightly build tasks

Bug 1548864 - part 6: Run missing Nightly tasks on try

Bug 1548864 - part 7: Make single locale run on try too

Bug 1548864 - part 8: Bump mozapkpublisher so push-apk-checks expects ARM64 on beta

Bug 1548864 - part 9: .cron.yml: Let mozilla-beta schedule the Fennec nightly graph

Attachment #9062508 - Attachment is obsolete: true

This means -nightly tasks don't end up in that promote graph.
The push-apk loader also wires the expected dependencies.

Depends on D29850

Neither from the beta graph nor from the nightly one.
It's notably done by not exposing the geckoview artifacts on the nightly build tasks

Depends on D29852

Depends on D29853

With QA doing their initial testing of the Try builds off those patch stack, we noticed that crash reports from Nightly builds are showing in Socorro as Beta release channel. Tracing that back, it looks like it's because MOZ_UPDATE_CHANNEL is being set to beta for those builds instead of nightly.

Flags: needinfo?(jlorenzo)

That makes sense. I'm looking into it. Thanks for the report!

Depends on: 1548655
Flags: needinfo?(jlorenzo)
Attachment #9062519 - Attachment description: Bug 1548864 - part 2: Enable `-beta` Android builds r=tomprince → Bug 1548864 - part 3: Enable `-beta` Android builds r=tomprince
Attachment #9062520 - Attachment description: Bug 1548864 - part 3: Change promote_fennec to handle beta tasks only r=tomprince → Bug 1548864 - part 4: Change promote_fennec to handle beta tasks only r=tomprince
Attachment #9062524 - Attachment description: Bug 1548864 - part 7: Make single locale run on try too r=tomprince → Bug 1548864 - part 5: Make single locale run on try too r=tomprince
Attachment #9062525 - Attachment description: Bug 1548864 - part 8: Bump mozapkpublisher so push-apk-checks expects ARM64 on beta r=tomprince → Bug 1548864 - part 6: Bump mozapkpublisher so push-apk-checks expects ARM64 on beta r=tomprince
Attachment #9062526 - Attachment description: Bug 1548864 - part 9: .cron.yml: Let mozilla-beta schedule the Fennec nightly graph r=tomprince → Bug 1548864 - part 7: .cron.yml: Let mozilla-beta schedule the Fennec nightly graph r=tomprince
Attachment #9065110 - Attachment description: Bug 1548864 - part 10: Run emulator tests on beta r=tomprince → Bug 1548864 - part 8: Run emulator tests on beta r=jmaher
Attachment #9065111 - Attachment description: Bug 1548864 - part 11: Ensure MOZ_UPDATE_CHANNEL is set to either nightly or beta r=tomprince → Bug 1548864 - part 9: Ensure MOZ_UPDATE_CHANNEL is set to either nightly or beta r=tomprince,jmaher
Attachment #9065112 - Attachment is obsolete: true
Attachment #9062521 - Attachment is obsolete: true
Attachment #9062522 - Attachment is obsolete: true
Attachment #9062523 - Attachment is obsolete: true
Depends on: 1552577

Comment on attachment 9065460 [details]
Bug 1548864 - part 2: Let should_use_artifact_map() not depend on the project anymore r=sfraser

Revision D31492 was moved to bug 1551738. Setting attachment 9065460 [details] to obsolete.

Attachment #9065460 - Attachment is obsolete: true
Attachment #9066077 - Attachment description: Bug 1548864 - part 12: Let Fennec Nightly be signed by the nightly key → Bug 1548864 - part 11: Let Fennec Nightly be signed by the nightly key r=tomprince
Attachment #9062524 - Attachment is obsolete: true
Blocks: 1553853
Blocks: 1553877
Blocks: 1553880
Attachment #9062524 - Attachment is obsolete: false
Blocks: 1554046
Blocks: 1554048
Blocks: 1554051
Blocks: 1554066
Blocks: 1554100

Patch queue landed on mozilla-beta: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=1f2cf02d4beba08f432cb2a6fabb3d20a6a59ba9

We don't plan to land these changes on mozilla-central because:

  • Fennec rides the 68 train (which is now on mozilla-beta)
  • It enables Fennec Nightly to be resurrected on mozilla-central if we abort the Fennec ESR plan.

I found some minor issues after landing. I'm taking care of them in separate bugs. Thanks all, for the help!

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1550719
Blocks: 1554501
Blocks: 1554211
Blocks: 1552573
Blocks: 1555982
Blocks: 1556416

johan: in the discussion and review of Bug 1522581, you suggested you were going to land part 1 of this series -- cleaning up android.yml -- to m-c. (Specifically, https://hg.mozilla.org/releases/mozilla-beta/rev/65f7c0babe09.) That didn't happen. Can we do that?

Flags: needinfo?(jlorenzo)
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1e58101918c0
part 1: Factorize android.yml r=tomprince

Thanks for your interest in this patch and for the reminder, Nick :) I didn't land it last week because I was bug 1522581 was close to land, and it seemed more important to land first. That said, I should have communicated it to you.

Anyway, I just rebased the patch on top of the latest central (which includes bug 1522581) and pushed it. Thanks again for the reminder.

Flags: needinfo?(jlorenzo)
Regressions: 1556781
Blocks: 1556784
Blocks: 1559115
You need to log in before you can comment on or make changes to this bug.