Closed Bug 1556561 Opened 6 months ago Closed 6 months ago

Remove <children> usage from autocomplete binding

Categories

(Toolkit :: XUL Widgets, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

(Regressed 2 open bugs)

Details

Attachments

(1 file)

Two of them are specific to the browser searchbar, and the other one is unused. Doing this will allow us to decouple searchbar logic from the autocomplete binding, but also make the autocomplete binding markup more simple and closer to an actual HTML input.

Type: defect → task
Attachment #9069503 - Attachment description: Bug 1556561 - Remove <children> usage from autocomplete binding. r=dao → Bug 1556561 - Remove <children> usage from autocomplete binding. r=dao, surkov
Attachment #9069503 - Attachment description: Bug 1556561 - Remove <children> usage from autocomplete binding. r=dao, surkov → Bug 1556561 - Remove <children> usage from autocomplete binding. r=dao,surkov

I think TB will need to port this change over (if it lands):

<children includes="image|box"/>:

<children/>:

For Firefox's only usage of <children includes="..."/>, I'm just moving out the children from the textbox and putting them as siblings.

For TB, some different ideas are:

  • Moving out the actual children and putting them as siblings like Firefox
  • Using background-image instead of <image src="person-icon"/>
  • Temporarily creating a new binding that extends autocomplete, and that adds back the <children/> in the <content>
Depends on: 1534404

Alternatively, if it's too much trouble to take care of now, I'm happy to keep <children/> and <children includes="image"/> (since TB only needs those 2) until bug 1534455 is fixed.

Flags: needinfo?(mkmelin+mozilla)
Assignee: nobody → ntim.bugs
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a29be90ae608
Remove <children> usage from autocomplete binding. r=dao,surkov
Regressions: 1557942

(In reply to Tim Nguyen :ntim from comment #4)

I think TB will need to port this change over (if it lands):

Thanks, filed bug 1557978.

Flags: needinfo?(mkmelin+mozilla)
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1558030
Regressions: 1569705
Depends on: 1574460
Regressions: 1574460
Depends on: 1574461
Regressions: 1574461
No longer depends on: 1574460, 1574461
You need to log in before you can comment on or make changes to this bug.