Closed Bug 1584861 Opened 3 years ago Closed 3 years ago

Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop) - Fix in comment #15

Categories

(MailNews Core :: Networking, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: rrrvjjj, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: regression, Whiteboard: [regression:68.0])

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Opened Thunderbird 68.1.1 on Win7 64 bit

Actual results:

New emails did not load automatically. After downloading manually it goes back to normal operation. Servers on all accounts set to Check for new messages on startup

Expected results:

Messages should automatically download as they did before upgrade to 68.1.1

Duplicate of bug 1584833 which is a duplicate of bug 1584060.

Please follow bug 1584060.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1584833
Duplicate of bug: 1584060

Do you see failures in the error console similar to the following?

NS_ERROR_FAILURE: Couldn't decrypt string ---> crypto-SDR.js:203

Are the failing accounts POP or IMAP ?

Flags: needinfo?(rvj_43)
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: thunderbird not downloading new mails automatically → Automatic download of emails fails with Thunderbird 68.x, but manual download still works
Duplicate of this bug: 1584599
Duplicate of this bug: 1583458
Duplicate of this bug: 1584833

So the idea is to have this bug here for "automatic download at startup doesn't work, manual download works", and bug 1584060 for the permanent failures (perhaps due to crypto issues).

See Also: → 1584060
Duplicate of this bug: 1577150

Note that I also have a possibly related problem filed as a separate bug #1584952 (Thunderbird Does Not Open in InBox )

Flags: needinfo?(rvj_43)

I have reverted to 60.8.0 (which upgraded automatically to 60.9.0. The Thunderbird not downloading new mails automatically problem went away so I'll use that version until Mozilla fixes the problem in a new version. However the starting in the wrong folder problem (bug #1584952) remains.

Component: Untriaged → Networking
Product: Thunderbird → MailNews Core
Summary: Automatic download of emails fails with Thunderbird 68.x, but manual download still works → Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop)
Whiteboard: [regression:68.1.1?]

See bug 1577150 for a report on TB 68.0.

Whiteboard: [regression:68.1.1?] → [regression:68.0]

Additional note: automatic time triggered download of emails works as well. Only the download at startup fails.

Duplicate of this bug: 1584060
See Also: 1584060

We found that this was caused by having "Local Folders" selected as default account in the Account Manager, something that should be possible. So select a valid default account.

We'll see whether we can automatically detect and rectify this situation in bug 1585469.

Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → WORKSFORME
Summary: Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop) → Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop) - Fix in comment #14

Did everyone who reported this bug (including duplicates) configure TB to use "Local Folders" as their default account?

I don't know, we'll find out. You can't "configure" that, the UI disallows it. Perhaps some add-on, like "Manually sort folders" caused this.

Reporters of the duplicates will be notified, so hopefully one turns up to confirm.

(In reply to Kai Engert (:kaie:) from comment #16)

Did everyone who reported this bug (including duplicates) configure TB to use "Local Folders" as their default account?

No, one of my accounts is the default. I can't set Local Folders as the default.

No, one of my accounts is the default.

How can you tell? Did you check this preference? mail.accountmanager.defaultaccount

I set it to account2, which is my account for Local Folders, just like for most people, and downloading of e-mail at start-up stopped. I selected my first account in the AM and downloading worked again at startup.

(In reply to rvj_43 from comment #18)

No, one of my accounts is the default. I can't set Local Folders as the default.

I never set my Local Folder as default either, but it was set that way in my profile's prefs.js file.

Open your prefs.js file and search for "mail.accountmanager.defaultaccount". If it's set to "account2", change it to "account1" and that will solve your issue.

Please note two things:

The "Local Folders" account is usually account2, but not always. In the config editor (or the prefs.js file) look for mail.server.server. Typically mail.server.server2.hostname will be "Local Folders". Then you need to find the account which belongs to server2, in most cases mail.account.account2.server will be server2.

It's not recommended to edit prefs.js, you can select a real account as default account in the account manager.

Yes, I use local folders as default, and I used to use the add-on Manually Sort Folders.

Changing the default account from "Local Folders" to a real account solved the problem for me.

I noticed this morning following a reboot that RSS feeds updated but mail fetching did not. So I looked at the settings suggested here and find that they do not resemble those suggested as causing an issue.

mail.accountmanager.defaultaccount;account4
mail.server.server4.hostname;pop.gmail.com
mail.server.server1.hostname;Local Folders

Any suggestions/ ideas Jorg?

Flags: needinfo?(jorgk)

Additionally Safe mode made no changes. But I just noticed after restarting the request for a certificate. I did not see that this morning either so the chat account at freenode did not log in either. So it is mail fetch, including IMAP and auto connection to the chat servers at freenode that are not functional as part of start up.

Hi Matt, so the default account is account4, but you didn't show me mail.account.account4.server which could still be server1 ;-) - Unlikely but possible. But in the end, it seems like some certificate issue?

Flags: needinfo?(jorgk)

(In reply to Jorg K (GMT+2) from comment #26)

Hi Matt, so the default account is account4, but you didn't show me mail.account.account4.server which could still be server1 ;-) - Unlikely but possible. But in the end, it seems like some certificate issue?

It is not
mail.server.server4.hostname;pop.gmail.com

mail.account.account4.server ?

mail.account.account4.server;server4
For completeness the only other thing under that key
mail.account.account4.identities;id3,id23,id24

mail.server.server4.login_at_startup;true
mail.server.server4.type;pop3

I had a chance to play with settings a little this morning. Normally I startup offline and once the UI is loaded click the blue icons to go online. In previous versions this kicked off the downloads. Now it does not. If I change the startup to online automatic download occurs. Is this another bug? or another manifestation of what you are looking at.

Yes, not downloading immediately after switching from offline to online is another bug.

Summary: Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop) - Fix in comment #14 → Automatic download of emails fails with Thunderbird 68.x, but manual download still works (pop) - Fix in comment #15

Starting with 68.0, both "Check for new messages at startup" and the "Get Messages" button and its "Get all new messages" pulldown stopped working. Manual download of individual mail accounts and timed download both still work.

Unselecting/reselecting the relevant Server Settings does not help. Safe Mode does not help.

Converted from TB 32-bit to 64-bit, same result. Currently on 68.2.2.

Windows 7. Two mail accounts, both POP: Gmail (set as default, account2) and AT&T Yahoo (account1).

I have Global Inbox set up to receive all mail. It has worked fine for years. All Server Settings are unchecked on Global Inbox, which I assume is correct.

Depends on: 1585469
No longer depends on: 1585469
Duplicate of this bug: 1585469
Duplicate of this bug: 1605846

(In reply to brucej4 from comment #31)

Starting with 68.0, both "Check for new messages at startup" and the "Get Messages" button and its "Get all new messages" pulldown stopped working. Manual download of individual mail accounts and timed download both still work.

Unselecting/reselecting the relevant Server Settings does not help. Safe Mode does not help.

Converted from TB 32-bit to 64-bit, same result. Currently on 68.2.2.

Windows 7. Two mail accounts, both POP: Gmail (set as default, account2) and AT&T Yahoo (account1).

I have Global Inbox set up to receive all mail. It has worked fine for years. All Server Settings are unchecked on Global Inbox, which I assume is correct.

I finally discovered that the advanced option "Include this server when getting new mail" had somehow become unchecked in both accounts. Selecting that fixed the problem. Thanks!

(In reply to Jorg K (GMT+1) from comment #15)

We found that this was caused by having "Local Folders" selected as default account in the Account Manager, something that should be possible. So select a valid default account.

We'll see whether we can automatically detect and rectify this situation in bug 1585469.

Having the same issue as OP.
After updating to 68.4.2, Thunderbird no longer collects mail on startup (using one POP client, Win7 OS).

Looked at all options where this could be hidden, all checks out (pictures below)

https://i.imgur.com/fXXbJxN.jpg
https://i.imgur.com/tH1RfZ1.jpg

Could you please put pictures of ""Local Folders" selected as default account in the Account Manager", as I have no idea what to search for

(In reply to pantagana23 from comment #35)

After updating to 68.4.2, Thunderbird no longer collects mail on startup (using one POP client, Win7 OS).

What was the last version that worked for you?

In the account manager, accounts are shown on the left, the default is underlined. Just select any account and use "Set as default" from the "Account Actions" below.

(In reply to Kai Engert (:KaiE:) from comment #36)

(In reply to pantagana23 from comment #35)

After updating to 68.4.2, Thunderbird no longer collects mail on startup (using one POP client, Win7 OS).

What was the last version that worked for you?

To tell you the truth, haven't been paying attention.
But basically, the last update or perhaps the one before

Here's the update history: https://i.imgur.com/1UhWECS.jpg

(In reply to Kai Engert (:KaiE:) from comment #37)

In the account manager, accounts are shown on the left, the default is underlined. Just select any account and use "Set as default" from the "Account Actions" below.

Could you please go step by step for Account Manager, I'm nowhere close to a power user, I use Thunderbird because it is the only program that did not crash with 25k emails.

I suppose Tools->Account Settings and find it somewhere there?

Yes, "Tools > Account Settings" opens the account manager. In the panel on the left, you have a list of accounts with the default account underlined.

(In reply to Jorg K (GMT+1) from comment #39)

Yes, "Tools > Account Settings" opens the account manager. In the panel on the left, you have a list of accounts with the default account underlined.

Found it, problem with no automatic download at startup solved. It seems that in 68.x version, default account gets unchecked.

For anyone having the same issue (one POP account, no extensions):

Go to Tools->Account Settings
This opens a window, which, in this thread, is called Account Manager.
In Account Manager you can see your mail accounts in left section, which are in bold font.
So if your mail account looks like i.e. Mail account 1, it is not default.
It should be in bold font, and underlined also.
You click on your email account, and then on bottom left part of Account Settings window you click a drop-down menu icon Account Actions.
When this opens, among other options, you will see option Set as Default, and click on it.
Now your Mail account 1 should also be underlined (don't know how to put underline on text here, but you get the picture).
You then click OK on Account Settings window, which should save changes.
Restart Thunderbird and that's it.

If the Set as Default is in grey, and not black font (not available option), you either didn't click on your account name previously, or your problem lies somewhere else.

Hope I helped someone.

(In reply to pantagana23 from comment #40)

(In reply to Jorg K (GMT+1) from comment #39)

Yes, "Tools > Account Settings" opens the account manager. In the panel on the left, you have a list of accounts with the default account underlined.

Found it, problem with no automatic download at startup solved. It seems that in 68.x version, default account gets unchecked.

For anyone having the same issue (one POP account, no extensions):

Go to Tools->Account Settings
This opens a window, which, in this thread, is called Account Manager.
In Account Manager you can see your mail accounts in left section, which are in bold font.
So if your mail account looks like i.e. Mail account 1, it is not default.
It should be in bold font, and underlined also.
You click on your email account, and then on bottom left part of Account Settings window you click a drop-down menu icon Account Actions.
When this opens, among other options, you will see option Set as Default, and click on it.
Now your Mail account 1 should also be underlined (don't know how to put underline on text here, but you get the picture).
You then click OK on Account Settings window, which should save changes.
Restart Thunderbird and that's it.

If the Set as Default is in grey, and not black font (not available option), you either didn't click on your account name previously, or your problem lies somewhere else.

Hope I helped someone.

Pantagana23 - YOU ROCK!!!! Thank you, thank you, thank you!

YES, your response did help someone............. me, thank you VERY MUCH!
My Thunderbird just updated to 68.4.2 the other day, and my auto check for new messages quit working. I spent hours trying to diagnose the problem without any success - actually created more problems while trying to fix this one (but have slowly been fixing them one by one). The fix you posted is very simple, and it works!!!!! (only took a few seconds by the way).

This update of TB is a bit of a mess, I lost my text highlighter add-on, and a few others no longer function. One more bad update like this and this kind might search out a new email program (NOT cloud based of course).

Many thanks, and all the best to you!

Regards,

TBGuy

Duplicate of this bug: 1606258
Duplicate of this bug: 1645004

This bug is not fixed in Thunderbird 68.10.0 (32-bit). I have changed my default account to different accounts (yes, each are underlined as I select them) - none of which are "local folders". I have checked the entry "Check for new mail at startup" which is checked for all 10 accounts from which I download email. All the accounts go to the local folders inbox.

The bug persists. For me it has only started recently but since Thunderbird is on automatic updates, I do not know which version worked. I have done nothing unusual, not added any accounts in the last 6months or moved any of the thunderbird files.

The symptoms are that, although it shows "online" in the bottom left hand corner of the screen, it makes no attempt to download mail at startup on Windows 10 2004. Windows updated recently to 2004 but I don't think that corresponds to the start of the problem. If I then do "check mail" it asks for my master password and will thereafter check mail all day.

I turned on the developer tools. In the log was a single error:
NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMessenger.msgHdrFromURI]

I also tried using a .bat file to set evironment variables to get a log. viz:
set MOZ_LOG=POP3:5,timestamp
set MOZ_LOG_FILE=%USERPROFILE%\Desktop\thunderbird.log
"C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"

If I start up thunderbird then shut it down a minute or two later, nothing appears in the log i.e. it is not reporting failure or trying to download mail. If I manually download a pop account, I get a log of the details.

I am not au fait with the source code of Thunderbird or indeed the technologies used therein, however, I am well versed in programming in general so if you wish me to carry out further debugging, I may be able to help. I cannot find out how to get Thunderbird to log details of decisions it makes. I tried starting thunderbird as above but with the switch "--with-debug" It did not complain but still gave no output in the log.

This bug is also not fixed in Thunderbird 68.10.0 (64-bit) on Ubuntu 20.04.1.

If I start Thunderbird, these messages appear in the syslog:

Dec 31 17:01:23 mymachine systemd[1293]: Started Application launched by gnome-shell.
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: JavaScript error: resource://gre/modules/addons/XPIProvider.jsm, line 1877: Error: Cannot find loader for bootstrap
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: 1609430484705#011addons.xpi#011WARN#011Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: Extension error: Error while loading 'jar:file:///usr/lib/thunderbird/extensions/messagingmenu@mozilla.com.xpi!/manifest.json' (NS_ERROR_FILE_NOT_FOUND) resource://gre/modules/Extension.jsm:513 :: readJSON/</<@resource://gre/modules/Extension.jsm:513:20
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: onStopRequest@resource://gre/modules/NetUtil.jsm:128:9
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: 1609430484814#011addons.xpi#011WARN#011Exception running bootstrap method startup on messagingmenu@mozilla.com: Error: Error while loading 'jar:file:///usr/lib/thunderbird/extensions/messagingmenu@mozilla.com.xpi!/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:513:20) JS Stack trace: readJSON/</<@Extension.jsm:513:20
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: onStopRequest@NetUtil.jsm:128:9
Dec 31 17:01:24 mymachine thunderbird.desktop[73403]: JavaScript error: chrome://messenger/content/mailTabs.js, line 419: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMessenger.msgHdrFromURI]

The Thunderbird Error Console displays these messages:

Error: Cannot find loader for bootstrap XPIProvider.jsm:1877:15
XUL box for statusbarpanel element contained an inline #text child, forcing all its children to be wrapped in a block. messenger.xul
1609444784509	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
Error while loading 'jar:file:///usr/lib/thunderbird/extensions/messagingmenu@mozilla.com.xpi!/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:513
1609444784635	addons.xpi	WARN	Exception running bootstrap method startup on messagingmenu@mozilla.com: Error: Error while loading 'jar:file:///usr/lib/thunderbird/extensions/messagingmenu@mozilla.com.xpi!/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:513:20) JS Stack trace: readJSON/</<@Extension.jsm:513:20
onStopRequest@NetUtil.jsm:128:9
XUL box for statusbarpanel element contained an inline #text child, forcing all its children to be wrapped in a block. 2 folderDisplay.js:2673:9
XUL box for statusbarpanel element contained an inline #text child, forcing all its children to be wrapped in a block. 2 tree.js:1093:10
NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMessenger.msgHdrFromURI] mailTabs.js:419
Stylesheets without CSSOM changes reparsed to check for errors. Refresh the page to also see errors from stylesheets changed from CSSOM and from style attributes. 12
Unknown property ‘user-select’.  Declaration dropped. reps.css:23:15
Stylesheets without CSSOM changes reparsed to check for errors. Refresh the page to also see errors from stylesheets changed from CSSOM and from style attributes.

(In reply to wdp from comment #45)

This bug is also not fixed in Thunderbird 68.10.0 (64-bit) on Ubuntu 20.04.1.

I think you might have missed the resolved works for me.

Beyond that, the current release version is 78 and no changes will be released to the 68 version tree. No point reporting a bug that is in that version as no one will even look at them. please test your assertion with a current release version and if you can replicate it, I suggest you file a new bug referencing this one.

Just to confirm that it is still not fixed for me in 78.6.0 (32-bit) on Windows 10 (fully patched). Yes, I do have a default account (underlined and bold), yes, it is (along with other accounts) set to download on startup, yes, I have set other accounts to be default for a trial, no it made no difference. So "not resolved, doesn't work for me".

Some of my account setups are ancient (prior to the year 2000) and I am disinclined to re-enter them all so there is probably something unusual lurking there which screws up recent thunderbird versions. I also swap them between Windows and Linux - one of the big pluses of thunderbird for me - the data structures are common.

What changed recently (about 2 months ago), is that I now get asked for the master password when I start up thunderbird. It does that before opening any windows. It still makes no attempt to download email until the timed downloads. On the other hand, I HAVE then given it the master password, so when the downloading timeouts kick in, it does download emails. Previously it waited until the time to download before asking for the master password which was a little more tedious.

So, it is a bug, but I can live with it. I just have to remember to click on the "get messages" button after the windows have opened up.

Thank you Pantagana23!

Thunderbird failing to check for new emails on startup was plaguing me for months. Your fix was the key: I disabled all my addons, selected a new default email account (which by itself didn't work for me), and went through each account and disabled "Check for new messages at startup". Restarted, went through each account again and re-enabled "Check for new messages at startup", selected a new default email account, restarted, and it worked. Re-enabled all my addons, restarted, and it still works.

Thunderbird 78.8.0
macOS Big Sur

(In reply to changetheworld from comment #48)

Thank you Pantagana23!

Thunderbird failing to check for new emails on startup was plaguing me for months. Your fix was the key: I disabled all my addons, selected a new default email account (which by itself didn't work for me), and went through each account and disabled "Check for new messages at startup". Restarted, went through each account again and re-enabled "Check for new messages at startup", selected a new default email account, restarted, and it worked. Re-enabled all my addons, restarted, and it still works.

Thunderbird 78.8.0
macOS Big Sur

Thank you!

TB was only checking my POP account at startup and ignored my IMAP accounts. This solved the issue for me.

Finally, after all this time, without having to do any work-arounds, Thunderbird now (78.10.0 (32-bit) on Windows 10) checks for emails on start-up. Thank you, whoever you are, who fixed the problem for me.

(In reply to pantagana23 from comment #40)

(In reply to Jorg K (GMT+1) from comment #39)

Yes, "Tools > Account Settings" opens the account manager. In the panel on the left, you have a list of accounts with the default account underlined.

Found it, problem with no automatic download at startup solved. It seems that in 68.x version, default account gets unchecked.

For anyone having the same issue (one POP account, no extensions):

Go to Tools->Account Settings
This opens a window, which, in this thread, is called Account Manager.
In Account Manager you can see your mail accounts in left section, which are in bold font.
So if your mail account looks like i.e. Mail account 1, it is not default.
It should be in bold font, and underlined also.
You click on your email account, and then on bottom left part of Account Settings window you click a drop-down menu icon Account Actions.
When this opens, among other options, you will see option Set as Default, and click on it.
Now your Mail account 1 should also be underlined (don't know how to put underline on text here, but you get the picture).
You then click OK on Account Settings window, which should save changes.
Restart Thunderbird and that's it.

If the Set as Default is in grey, and not black font (not available option), you either didn't click on your account name previously, or your problem lies somewhere else.

Hope I helped someone.

This also made mine start working.

I have the folder sort add on and have had it for some time. Yesterday, I had the bright idea of changing my mail folder setup a bit by changing all accounts to use "Local Folders" as the inbox and everything else. I had my 7 or 8 email accounts all using a main accounts folders for a very long time and it always bugged me that I had that folder tree and "local folders" folder tree with seemingly duplicate folders in them like Junk, Trash, etc.

So I changed all accounts to use Local Folders for the inbox and all other folders, was a bit of a time consuming task to go through them all and select. Then I moved my emails from my primary sent and inbox to the local folders sent and inbox, closed TB and restarted it. Then my primary email folder structure went away and I now had a single folder tree.

Then I noticed it wasn't going to the "inbox" when I opened TB. So I tinkered with the setting in the "Manually sort folders" setup and got it to start landing on Inbox when I opened.

That's when I noticed my emails weren't downloading when I opened TB... I did what another mentioned to go through each account and verify that I had the box checked to download on start, which looked ok, so I checked/unchecked all and restarted TB. No luck. For fear that I was going to have to undo everything and go back to the 2 tree structure I had before, I ran across this comment. Sure enough, none of my email accounts were "default" anymore. So I picked the account that used to be the primary folder tree and set it as default. Now it's downloading mail again from all accounts on start and continuing to download mail from all accounts while it's opened.

(In reply to Ken from comment #49)

(In reply to changetheworld from comment #48)

Thank you Pantagana23!

Thunderbird failing to check for new emails on startup was plaguing me for months. Your fix was the key: I disabled all my addons, selected a new default email account (which by itself didn't work for me), and went through each account and disabled "Check for new messages at startup". Restarted, went through each account again and re-enabled "Check for new messages at startup", selected a new default email account, restarted, and it worked. Re-enabled all my addons, restarted, and it still works.

Thunderbird 78.8.0
macOS Big Sur

Thank you!

TB was only checking my POP account at startup and ignored my IMAP accounts. This solved the issue for me.

The bug hit me this week. 78.11.0 (32-bit) release channel update channel.

Seven IMAP accounts. Unified folder view. All accounts used to be checked on startup. After recent update, only the default was checked on startup.

Your solution worked, guys, Very much appreciated!

Marty

Ah, I spoke too soon. Whatever was done in 78.10.0 to fix the "no downloads on startup" error, (as I reported 2 months ago) has now been undone in 78.11.0 i.e. on my configuration, it once again, fails to download emails on startup although it does ask for the master password.

Have I made any changes to any accounts in the last 6 months? No. Is there an account both in bold and underlined? Yes. Am I going to go through any workarounds to try to avoid the problem? No. Why? well, it might be re-fixed in version 78.12.0 - who knows?

Wow, whatever was done in 78.11.0 to unfix this problem which was fixed in 78.10.0 has now been undone in 78.12.0 - Downloading on start up works again! Thank you whoever re-did this fix.

It's been a bit of a roller-coaster ride as we say in the UK. But, no matter, it is now re-fixed. It is with some trepidation that I await future developments.

Hello, I spoke too soon: whatever was done in 78.12.0 to fix the bug re-introduced in 78.11.0 which was fixed in 78.10.0 has now been unfixed in 78.13.0 - downloading on startup has ceased again. My trepidation in comment 54 was well founded.

Hello again, the unfix remains in 78.14 - automatic email collection at power up no longer works. The roller coaster didn't get up the hill this time.

Duplicate of this bug: 1731354

The bug (no automatic download on opening Thunderbird) has returned for me in TB 91.2.1 (32 bit). Relevant settings remained the same: mail.accountmanager.defaultaccount is set to account3
mail.account.account3.server is set to server3.

After 3 days of not working, the message download at TB startup is now behaving as expected. There have been no known changes to my Windows 10 or TB. I've done nothing but open to confirm settings (but made no changes to) my Preferences file. Gremlins?

Well, seems like automatic download on startup no longer working in 91.3.1 and 91.3.2 version (32 bit). OS Win7 Pro 64bit. Tried all previous tips and tricks, nothing works.

(In reply to pantagana23 from comment #60)

Well, seems like automatic download on startup no longer working in 91.3.1 and 91.3.2 version (32 bit). OS Win7 Pro 64bit. Tried all previous tips and tricks, nothing works.

Join the club. If you read my messages above, you will see that the problem comes and goes without me doing anything to change my configuration. Some versions of thunderbird have worked, some not. Seems sort-of random. At the moment, automatic download at start-up not working. Who knows, tomorrow we might get a new version which works, and a few days later, one that doesn't. I have decided to simply be patient - I just push the button for "download all" every time I start Thunderbird.

Just to confirm that the problem is back for me on 91.3.2. I guess, we'll just learn to live with it, until the next TB update.

I temporarily rolled TB back to V91.0 but the problem persisted. V91.0 was current 8/12/21-8/24/21 way before the problem reappeared so obviously the cause is elsewhere. Probably a conflict with Windows or another app that changed recently. Problem does exist with both Windows Home 64 bit, version 21H1 and version 21H2, maybe it will go away with Win 11.

This time, I tried the latest Beta version of TB: 95.0b5 (64-bit). That did not fix the problem. Also I read a message from someone using W11 that they have the same problem. So it looks like we may have to wait a long time for a fix.

WARNING: Don't try the beta as an attempted fix! Not only did it not fix the problem, but it put's you permanently on the Beta release channel and there is no easy way to ever get back to regular versions. You cannot just uninstall TB beta and reinstall a previous version. I finally got back by replacing the entire %APPDATA%\Roaming\Thunderbird folder (all 6 GB) with one from a two-week old image which restore my profile to where I could reinstall TB 91.3.2.

As another experiment, I created a new test profile with only 1 email account (I have 8, all going to the Inbox on Local Folders) and one newsgroup. TB with this test profile downloaded the mail at startup as it should. I hope that helps diagnose the cause.

I got the update to TB 91.4.0 today. TB now behaves as designed with emails downloading automatically on startup. Does anyone still have the problem?

I still have the problem. Just installed 94.1 32 bit on Windows 10. No change in behaviour. As usual it asks me for my master password in a pop-up window then puts up the normal gui making no attempt to download from the 5 or so email sources. Click on "get messages" and it does so. I can live with that.

(In reply to Robert Jacobson from comment #66)

I got the update to TB 91.4.0 today. TB now behaves as designed with emails downloading automatically on startup. Does anyone still have the problem?

(In reply to Ray Foulkes from comment #67)

I still have the problem. Just installed 94.1 32 bit on Windows 10.

Perhaps update to the latest version Ray, as suggested by Robert. Instead of one three versions old.

(In reply to Matt from comment #68)

(In reply to Robert Jacobson from comment #66)

I got the update to TB 91.4.0 today. TB now behaves as designed with emails downloading automatically on startup. Does anyone still have the problem?

(In reply to Ray Foulkes from comment #67)

I still have the problem. Just installed 94.1 32 bit on Windows 10.

Perhaps update to the latest version Ray, as suggested by Robert. Instead of one three versions old.

OOPS, grovelling apologies, finger trouble in writing the response - memo to self - use cut and paste next time and do not enter from memory to save wasting peoples time.

Cut and paste from thunderbird version pop-up this time: 91.4.0 (32-bit)

And from the release notes: Version 91.4.0, first offered to channel users on December 7, 2021.

It also says that I am on "the release update channel". So initial download still doesn't work for me on Dec 7th version.

Besides, I guess that version 94 won't be out for some time yet and time travel is still in the future ;-)

I have seen reports from others that that version 91.4.0 did not fix the problem for them, but it did for me. The next Mozilla update is scheduled for 1/4/22. Good luck.

PS: the Beta versions are up to 95, but as I wrote before, I strongly advise against trying it (except perhaps in a sandbox) as it gets you on the Beta release track with no easy way to get off it.

Same problem here using Windows7(32bit), Thunderbird 91.5.0(32bit).

Same problem here!
I use TB 91.5.1 (32bit) on Windows7.

Maybe of interest:

On startup the status bar at the bottom shows the following message:
[account name]: connected with [pop server]

Sometimes this message even does not disappear but remains in the status bar.

Which means, the checking for new messages starts, but does not proceed.

This is only the case when pressing the button in the upper left.

I decided to try Ubuntu 64-bit alongside with W7 32-bit. Installed Thunderbird on Ubuntu and copied the W7 profile to it. This was done before the W7 TB startup problem appears. Didn't take note of version number.
After installation, TB on Ubuntu doesn't download messages at startup...
Made some configs and reboots and now TB works ok on Ubuntu. Don't know what changed or caused it.
So I copied the Ubuntu TB profile to TB on W7 and now it downloads messages at startup again.
Tried comparing the relevant TB files from before and after but can't find nothing obvious.
As a side effect, the fonts on each pane were altered and until now I can't get them back to normal.

I came to the conclusion that this problem has nothing to do with Thunderbird directly.

I run TB on two systems. The newest version on Windows 7, and the last supported version on Windows XP.
On both the automatic download at startup was working.

And about two weeks ago, automatic download at startup failed as described in this thread - on both systems!
And a few days ago it worked again - on both systems!

And I did not change any settings on both systems.

Therefore I assume some kind of interaction between my mail provider (GMX) and Thunderbird.
Or any other point within the network between TB and server, I don't know.

(In reply to Ray Foulkes from comment #61)

(In reply to pantagana23 from comment #60)

Well, seems like automatic download on startup no longer working in 91.3.1 and 91.3.2 version (32 bit). OS Win7 Pro 64bit. Tried all previous tips and tricks, nothing works.

Join the club. If you read my messages above, you will see that the problem comes and goes without me doing anything to change my configuration. Some versions of thunderbird have worked, some not. Seems sort-of random. At the moment, automatic download at start-up not working. Who knows, tomorrow we might get a new version which works, and a few days later, one that doesn't. I have decided to simply be patient - I just push the button for "download all" every time I start Thunderbird.

To try to help again:
Had problems 3 months ago when Thunderbird on 1 computer with Win7 wouldn't start automatic download, and on the other with Win10 it did.

Even after all the gimmicks from above and updates, everyting was the same.

I noticed then when I exit Thunderbird, it always returned to the session when the problem started (I had some emails open separately, I would close those, open other, but always the same mails would pop up when I restarted Thunderbird).

Then I saw someone say to use CCleaner - so I did.

I checked Internet cache, Internet history, cookies and Session.

Cleaned up, and boom - started working again.

My best guess was that somehow program got stuck in a session, so once it got a clean start, it worked normally.

From then (3 months ago) it works normally.

Not sure if any updates were done in the mean time.

(In reply to Michael from comment #74)

Therefore I assume some kind of interaction between my mail provider (GMX) and Thunderbird.
GMX is Bug 1752842, apparently.

(In reply to pantagana23 from comment #75)

Then I saw someone say to use CCleaner - so I did.

I checked Internet cache, Internet history, cookies and Session.

Cleaned up, and boom - started working again.

pantagana23, your comment regarding CCleaner gave me a clue.....
I ran CCleaner and, under the Thunderbird section, only checked "Session". It reported to have deleted 4 files.
After that Thunderbird downloads emails automatically again on startup.
Problem solved after so many months !!!!

So, for me at least, it did seem to be a problem with Thunderbird screwing up its "session" file - whatever they are,

I would like you to be aware CCleaner causes more problems than it has ever fixed in Thunderbird. This is also not a self help support forum, it is a serious bug tracker. Everyone involved with development have wandered off, having lost interest in this bug because it is resolved. P{osting further items is actually counterproductive.

If you think you have a bug in a current version file a new bug, but do not post in this bug further, the contributions are not welcome as they do nothing to resolve this bug. It is resolved.

If a current bug does exist no one will fix it because the discussion is misplaced here instead of in a current bug report. You will then be disappointed when you get yet another release without a fix, because you have failed entirely to correct report the bug.

Note this part well. The bug etiquette that is linked to from every comment makes the point "No pointless comments. Limit comments on a bug to information which will help with resolving it. "

As this bug was closed in comment 1 with the note

Please follow bug 1584060.

There is nothing following that bug comment that really follow the established etiquette, mine included. This topic is dead

I am going to unsubscribe from this bug because I am tired of the spam I get from it.

You need to log in before you can comment on or make changes to this bug.