Clicking on bookmark icon in address bar no longer brings up the File Bookmark menu

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: David Smith, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020730
BuildID:    20020730

Clicking on bookmark icon in address bar no longer brings up the File Bookmark
dialog.

Reproducible: Always
Steps to Reproduce:
1. Go to a web page
2. Click on Bookmark icon in address bar

Actual Results:  Nothing happens

Expected Results:  Bring up File Bookmarks dialog

Comment 1

16 years ago
no. this was an error that was corrected by bug 158364
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 2

16 years ago
*** Bug 161385 has been marked as a duplicate of this bug. ***
*** Bug 163144 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 162426 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
The arguments against having this feature in the browser seem to revolve around
the breaking of functionality as regards dragging and dropping the url from the
address bar to a location of the user's choice. This seems to be acceptable from
a user perspective. What I suggest is have to kinds of functionality associated
with the url widget:

1. Dragging the widget allows you to drag and drop the url
2. Double clicking the widget lets you organize the bookmark as a url, iow,
opens up the bookmark manager. 

This shouldn't be a very difficult thing to fix either, I saw the patch that
timeless made to navigatoroverlay.xul to resolve the issue with the dialog
popping up.

Comment 6

16 years ago
if we're going to make doubleclicking do something, i'd much prefer for it to
behave like explorer and open the dropdown list.

Comment 7

16 years ago
*** Bug 166193 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 167036 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 168432 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 166962 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 200334 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
Created attachment 119458 [details]
bookmark-icon.png

This image explains precisely what icon I expect to double-click in order to
call "File Bookmark" dialog. It worked before (Mozilla pre-1.0), but someone
(why?) disabled it.

Comment 13

15 years ago
Segeui - that's just the site icon (aka favicon), which is put there by the site
you're visiting. It has nothing to do with the bookmark manager. See
http://www.favicon.com/ for more details.

Comment 14

15 years ago
Neil, you didn't get the point. The icon is different from site to site, and I
know that. But if you drag it to the toolbar - it will bookmark it there, right?
In Mozilla before 1.0 you could also double-click on it and it would bring the
dialog window which now you open by using "Bookmarks"->"File Bookmarks...".

So somewhere after 1.0 there was a regression. And I am trying to report it (See
my original report in the bug # 200334).

As an answer you explain me that that icon is "favicon". I know what it is. I am
just reporting that the duble-click on it is broken.

Comment 15

15 years ago
Axxackall: the feature (apparently) wasn't even intended, and in any case was
purposefully removed (so it's not "broken"). See comment 1, pointing to bug
158364. Bringing it back is a WONTFIX request (this bug). No further discussion
necessary.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.