Closed Bug 1607985 Opened 1 month ago Closed 1 month ago

Firefox 72.0.1 permissions.default.image problem. (also affected to Thunderbird 72+)

Categories

(Core :: Permission Manager, defect, P1)

72 Branch
defect

Tracking

()

VERIFIED FIXED
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 --- unaffected
firefox-esr68 --- unaffected
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- verified

People

(Reporter: pop111per, Assigned: pbz)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fixed by bug 1357107])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

about:config , permissions.default.image=2

Actual results:

Images are still loaded and displayed.

Expected results:

Images should not be loaded.

Does it work if you enter about:config into the address bar, set extensions.contentblocker.enabled to true, then restart Firefox?

Component: Untriaged → Permission Manager
Product: Firefox → Core

(In reply to Gingerbread Man from comment #1)

Does it work if you enter about:config into the address bar, set extensions.contentblocker.enabled to true, then restart Firefox?

Yes, I can confirm that this does fix the issue.

See Also: → 1608004
Duplicate of this bug: 1608004
See Also: 1608004
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1607726

This is also affected to Thunderbird 72+.

Summary: Firefox 72.0.1 permissions.default.image problem → Firefox 72.0.1 permissions.default.image problem. (also affected to Thunderbird 72+)

This will start working again once we apply the patches from bug 1357107. Paul, would you like to do that? I think we can also remove nsContentBlocker now.

(Personally I'd be tempted to just remove support for permissions.default.image, but since there seems to be some demand I don't think it's expensive to keep it alive, either)

Flags: needinfo?(pbz)
Priority: -- → P1
Depends on: 1357107
Assignee: nobody → pbz
Status: NEW → ASSIGNED
Flags: needinfo?(pbz)
Duplicate of this bug: 1608450
Duplicate of this bug: 1608574
Duplicate of this bug: 1608634
Duplicate of this bug: 1610090
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1357107]

Bug 1357107 isn't something we can uplift to 73. Is there anything we can/should do about this for Beta here or should we call 73 wontfix?

Flags: needinfo?(pbz)

Thanks Ryan, I think 73 is a wontfix.

Flags: needinfo?(pbz)

Reproduced the initial issue using Release version 73.
Verified - Fixed in Nightly 74.0a1 (Build id: 20200125213807) and latest Nightly 75.0a1 (Build id: 20200212093201) using Windows 10, Mac OS 10.15 and Ubuntu 18.04

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.