Closed Bug 1618202 Opened 2 years ago Closed 2 years ago

Enable the non-native theme on Android Nightly

Categories

(Core :: Widget: Android, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(3 files)

Android has their own UA sheets which cause a bunch of compat issues, and get people backed out because of silly rules there.

We could get rid of them if we had a proper native theme. And now we do!

Assignee: nobody → emilio
Depends on: 1470709
No longer blocks: 1346893
Depends on: 1346893

I browsed a bit with it and it looks pretty nice. Should we consider enabling it
on Nightly so we find if there's any obvious problem?

Given the state of our form controls on android, this is probably an improvement
even without the things that block this on desktop. Let's try this out.

Depends on D64396

The second patch needs some test adjustments, so will land the first for now.

Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28024d6694a1
Support widget.disable-native-theme-for-content on Android, and don't apply geckoview.css in that case. r=snorp
Depends on: 1618988
Depends on: 1618993
Depends on: 1619428
Depends on: 1619663
Depends on: 1619664
Depends on: 1615026
Depends on: 1620246
Depends on: 1620297
Depends on: 1620307
Depends on: 1620360
Depends on: 1620362
Depends on: 1620451
Depends on: 1620476
Depends on: 1620479

Tons of new passes, some fuzzy bits, and one failure from a test that makes bad
assumptions about themed and unthemed <input type=color> being equally tall.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b46e40872077
Enable widget.disable-native-theme-for-content on Android Nightly. r=snorp
https://hg.mozilla.org/integration/autoland/rev/a2c3bd0e1fba
Update WPT annotations. r=snorp
Depends on: 1621141
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/760a89ae35a7
More fuzzy appearance test annotations.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/e5be676f6f06
One fuzzy appearance test annotation.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/c1a32c968550
Fix one test that was mistakenly changed to pass.
Blocks: 1621163
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/9448002ebec9
Temporarily skip one mochitest on android.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/cea91b0cc4f9
Apparently literally all webkit-appearance reftests are intermittently fuzzy on android.
Depends on: 1621319
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f8967fe76c1
Enable widget.disable-native-theme-for-content on Android Nightly. r=snorp
https://hg.mozilla.org/integration/autoland/rev/471a9b797ac5
Update WPT annotations. r=snorp
Summary: Consider enabling the non-native theme for Android, and remove android's bespoke UA stylesheets → Enable the non-native theme on Android Nightly
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/e8b91e15f860
Some minor reftest annotation tweaks.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/ed67383e77a7
Mark the previously annotated test as random as it fails in opt but passes in debug (o.O)
Regressions: 1622077

Yay

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(emilio)
Resolution: --- → FIXED
Regressions: 1622113
Regressions: 1622287
Regressions: 1622776
Target Milestone: --- → mozilla76
Depends on: 1624696
No longer blocks: 1625604
Regressions: 1625604
Duplicate of this bug: 1502150
Duplicate of this bug: 1314202
You need to log in before you can comment on or make changes to this bug.