Closed Bug 1675970 Opened 2 months ago Closed 2 months ago

Email subject disappears when I hover over it with mouse when using Windows 7 Classic theme

Categories

(Thunderbird :: Theme, defect)

Unspecified
Windows 7
defect

Tracking

(thunderbird_esr78+ fixed, thunderbird83 wontfix)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird83 --- wontfix

People

(Reporter: stuart.soloway, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

This is version 78.4.1 (32-bit) of Thunderbird.
Whenever I hover the mouse over an unread email in my inbox display pane, the entire line (subject, correspondents, date, etc) disappears.

Actual results:

Whenever I hover the mouse over an unread email in my inbox display pane, the entire line (subject, correspondents, date, etc) disappears.
My guess is that the fields that "disappear" are not gone, but that they are changed to white so they are not visible against the background.

Expected results:

The fields should not have disappeared. I should point out that whenever I mouse over to somewhere different, they reappear.
I can click on the invisible fields and open the Email. But the first time I saw this bug I didn't realize it and I thought my Email had disappeared.

This seems to happen to W7 users who are not using an Aero desktop theme. There is a simple userChrome.css to adjust the hover colors.

Unread emails disappear when cursor on them in Thunderbird 78.4.1

Component: Untriaged → Theme
Duplicate of this bug: 1675974
Duplicate of this bug: 1675944
Duplicate of this bug: 1676023
Flags: needinfo?(richard.marti)
Keywords: regression
OS: Unspecified → Windows 7
Summary: Email subject disappears when I hover over it → Email subject disappears when I hover over it when using Windows 7
Duplicate of this bug: 1676042

John, do you have a Windows 7 installation to test this patch?

If not, Alessandro can you check the code?

The patch changes for Win 7 Classic/HC the hover of treechildren::-moz-tree-cell-text to use the inherit colour and not the HighlightText colour because we don't set a hover background.

Additionally I added two rules for the folderPane icons to use the text colour to make them visible on the dark HC themes which don't use the dark theme rules.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #9186525 - Flags: review?(john)
Attachment #9186525 - Flags: review?(alessandro)

I only have a Windows 10 and Ubuntu build system running.

I can quickly create a Windows 7 virtual machine. What does your Windows 7 build environment look like? For instance, which compiler, build tools etc?

Comment on attachment 9186525 [details] [diff] [review]
1675970-win7-classic-hover.patch

Review of attachment 9186525 [details] [diff] [review]:
-----------------------------------------------------------------

The CSS looks good and it seems that would solve the issue.
I don't have a Win7 VM to test this, so let's wait for Russell Page to confirm.
Attachment #9186525 - Flags: review?(alessandro) → review+

Steve, can you test comment 11?

Flags: needinfo?(sfhowes)

(In reply to Wayne Mery (:wsmwk) from comment #13)

Steve, can you test comment 11?

So, nobody in TB development has a W7 computer, which is an officially supported platform? I'll see if I have time to do the test.

Flags: needinfo?(sfhowes)
Duplicate of this bug: 1676354

We need to take this for 78.5.0. But it is unlikely we will do another beta before then, so it will go straight to ESR - which is OK as long as we have people test it on win7.

Flags: needinfo?(rob)
Summary: Email subject disappears when I hover over it when using Windows 7 → Email subject disappears when I hover over it with mouse when using Windows 7 Classic theme

I can confirm this bug shows up on Windows 7 Classic -- with a twist! I find hovering causes the entire line to go white, but ONLY for unread untagged items. That is to say, if the text is bold and black, the line disappears. Anything not bold remains. Anything of any colour (except black) remains, whether bolded or not.

Furthermore, if you hover and then click the READ/UNREAD button (which always remains visible), then the line will appear and disappear before your very eyes. (Of course if the line is selected (not hovering) to do any right-click tagging, the reaction is normal.)

I've tested it on W7 while creating the patch. Let's land it.

Target Milestone: --- → 84 Branch
Attachment #9186525 - Flags: review?(john)
Duplicate of this bug: 1676420
Duplicate of this bug: 1676436

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/5e35dc929449
Windows 7 Classic: fix the hovered unread treechildren. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9186525 [details] [diff] [review]
1675970-win7-classic-hover.patch

[Triage Comment]
For 78.4.3 as discussed with wsmwk in Matrix.

Flags: needinfo?(rob)
Attachment #9186525 - Flags: approval-comm-esr78+

A candidate build with this fix is available for testing at https://ftp.mozilla.org/pub/thunderbird/candidates/78.4.3-candidates/build1/.

Sorry, I can't run 64-bit on my Windows. (And I'll need to know how to run the setup without harming my current system -- is it just like an upgrade?)

I just downloaded it and ran it on Win7 64-bit with my existing email folders. (I set up a restore-point just in case.) It seems to work -- The bug is gone, all my Email seems to be there, and nothing has exploded.

I just installed the patched version, and it solved the problem.
Sorry I went dark earlier. I have had issues with the build instructions, and am working through them. I'll post another bug report once I have sorted them out.

Seems additional testing from my side is no longer needed :)

Flags: needinfo?(pppx)
Duplicate of this bug: 1676613

I just installed the test 32-bit version of TB 78.4.3 from Wayne's link in Comment 28 and switched my Windows theme from my usual Aero to Windows Classic. Unfortunately I have bad news to report.

The program worked normally on Aero as expected. When I switched to Classic, the lines never went invisible -- but there was no mouseover! Whereas a faint selection line always appears on mouseover, there was nothing here. Even if I closed and relaunced TB, still no mouseover.

I switched to Windows Basic and it worked normally. I switched back to Classic and again no mouseover. Back to my Aero settings and all is well again. So something odd is happening under Classic.

Flags: needinfo?(dannyfox)
Duplicate of this bug: 1676652
Duplicate of this bug: 1676598

After reading the feedback, it sounds like the patch we have now is an improvement and "good enough" to ship - not perfect but we'd prefer to not wait for another patch. AIUI this improves the current bad situation, and doesn't take a horrible step backwards. So we'll ship this to users and look forward to future improvements.

You're going to get a ton of bug reports one way of the other. With the patch, the mouseover is invisible, and one cannot see exactly which line is focussed. I found it disconcerting and I think it's too easy to operate on the wrong message -- the user has to be VERY sure the mouse pointer is on the correct line. At least with the current white-out, the user knows exactly where the mouse is (ie, the target/focus of an imminent operation) and it DOES come back into view. IMHO, I think the whiteout is the lesser of two evils.

Of course an obvious workaround is for the Classic user to switch modes -- but that affects their entire system, and they have to know to do it.

Clarification of my Comment #36: The circumstance is not as dire as I mentioned above.

If you select a line, then the focus is obvious, and you can proceed with confidence. But if one simply tries to mouse over blindly and right-click to select the line, you could end up inadvertently selecting the wrong line -- frustrating and possibly damaging. The right-clicked line does become officially selected (and therefore obvious too) -- one just has to be extra careful that it is actually the intended line.

So I guess the two evils are equal after all...

Confirm fixed in Win 7 64-bit with 78.4.3 (duplicate bug 1675880)
Thx for help.

Duplicate of this bug: 1675880

Installed 78.4.3 32 bit on Win 7 with a Non-Aero Win theme in effect.

As I expected from reading the traffic, now (with the default theme in effect), when I hover over an unread message, the message listing doesn't disappear. Rather, the hover doesn't do anything (no sort of highlight or such from the hover).

Certainly usable.

Thanks to all who worked on this.

Should I be using the 64-bit version? How do I move to that?

Doug

@doug.kerr:

The question is why you would be using 32-bit TB in the first place, and I'm guessing it's because you may be running 32-bit Windows 7. Although I have a 64-bit machine (required for 64-bit Windows, BTW), we voluntarily chose to go with 32-bit because at the time there were some ancient software packages that we absolutely had to run. You may have had a similar situation where 32-bit Windows was required (or perhaps you had only a 32-bit dinosaur PC and had no choice).

Only if you have 64-bit Windows, then you can (and should) run the 64-bit version TB -- much more efficient.

I'm not fully comfortable telling you how to migrate, but... As far as I know, you just manually download the latest TB 64-bit version (Setup) and install it (someone please correct me if I'm wrong). But be sure to back up your mailboxes first! (That would be the TB and TB profile area in \USER\username\APPDATA\ROAMING\Thunderbird.)

Hi, Dan,

Well, I'm not sure how I got started with the 32-bit version. Just a screw-up, I guess.

I first stated using Tbird with my current machine, with 64-bit Windows 7 in it.

So I will download the 64-but version and move to that.

Thanks.

Best regards,

Doug

there is generally no reason to move to 64 bit. it is fine to stay on 32bit until one is migrated automatically. it is a myth that 64 bit is in substantially a better build

Hi, Wayne,

Thanks for that. I will sty with what I have (32 bit) on my wife's machine. I did the "upgrade" on mine.

Doug

(In reply to doug.kerr@att.net from comment #44)

Hi, Wayne,

Thanks for that. I will stay with what I have (32 bit) on my wife's machine. I did the "upgrade" on mine.

Doug

Duplicate of this bug: 1677702
You need to log in before you can comment on or make changes to this bug.