Closed Bug 1721801 Opened 6 months ago Closed 5 months ago

opening spell check dialog hangs thunderbird

Categories

(Thunderbird :: Message Compose Window, defect, P1)

Thunderbird 92
Desktop
Windows 10

Tracking

(thunderbird_esr91 unaffected, thunderbird91 unaffected, thunderbird92+ fixed)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird91 --- unaffected
thunderbird92 + fixed

People

(Reporter: d2ogilvi, Unassigned)

References

(Regression)

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached image spellcheck.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Actual results:

  1. Set Windows colour scheme to High Contrast Black (Start Menu > Settings > Ease of Access > High Contrast > "High Contrast Black" in "Choose a scheme" drop down list. You can return to normal colour scheme with Left Alt+Left Shift+Prtscr).
  2. In TB, reply to a short message.
  3. After you have completed a message, with 1 spelling error, press Enter to send the message.

Expected results:

99% of the time, the spell checker works as desired.
1% of the time, the spell checker corrects the first spelling mistake, then asts as if it has found a second spelling mistake, but all fields in the dialog box are empty, then has high CPU usage and hands, as seen in the attachment.
Often I will ESC out of the spellcheck and change the spelling manually in the text, then send the messgae gaian (using ctrl+enter) at which point this error occurs.

OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop

I tried to respomg to the same email as before, with no spelling mistakes, and the spell checker dialog box hangs again. I think this is a new bug that has been introduced in TB Daily 2021-07-22.

Priority: -- → P1

The error occurs when the email being checked has the following text. The response text doesn't seem to matter. It seems that the text being replied to is where the problem lies.

Anyway, here's the text:

We just missed having a thunderstorm in Cambridge. Missed us by that much (think Get Smart here!)

It was a pretty long day, but I've done it so many times that it didn't seem that long!

I was thinking that it would be nice to do it again sometime when I'm up in Waterloo, but the next time for an OH appointment will be January 20th... probably not a good time for a picnic in the park!

Once again, thanks for the nice subs and such a pleasant venue!

All the best,
David

On 22/07/2021 7:34 a.m., Pauline Bevers wrote:

Hi Dave
My pleasure! At least we got some fresh air in spite of the muggy day!

Glad to hear eyes are OK and hope they didn’t have to change the regimen for your eye drops. You must have been so tired by the end of it all - that was a LONG day.

Hope you missed the thunderstorm/rain which hit us about dinner time. I was hoping you didn’t get a soaker!

Take care Dave and happy haircut!!!
Pauline

On Wed, Jul 21, 2021 at 4:01 PM David Ogilvie <d2ogilvi@hotmail.com> wrote:

That was such a nice spot to be in... glad I was
able to enjoy it and your company!

The OH appointment went well - no changes.

I forgot to ask them about to OHIP billing for eye
exams.  Sorry about that!

I popped down to the LV clinic after the
appointment and had  chat with Linda and Kathryn,
who were the only people in the office. Everyone
else was working from home yesterday.  That must
feel pretty strange!

Anyway, I hope that both of us will be able to get
rid of our shaggies before too long.  I'll have to
go over and have a chat with our resident har
dresser as she doesn't seem to be looking at her
emails.

Hope you are having a great afternoon!

All the best,
David O 

Bug 1720725 was landed for 2021-07-20.
Can you re-check with current daily?

Keywords: regression
Priority: P1 → --

Still a problem for me on my test emaul on Daily 2021-08-03.

Attached file speller problem.eml

I just attached the email as an eml file, whch may be easier to use and test from. Please change the email address of the to: field before testing! Thanks!

I just tried this on trunk. Copy pasting the text from comment 2 into a compose window and then clicking spell check (to bring up the dialog) will hang Thuderbird.

Severity: -- → S1
Status: UNCONFIRMED → NEW
Component: Untriaged → Message Compose Window
Ever confirmed: true
Priority: -- → P1
Summary: Spell check dialog hangs when sending a reply to a message → opening spell check dialog hangs thunderbird

91 beta seems unaffected.

Language is English (Canadian), if that helps.

Duplicate of this bug: 1721695

Not that it matters, but why close my older bug as a duplicate of this newer bug? Isn't the other way around more logical?

Note that my older bug notes a regression window:

0719 OK
0720 BAD

if that helps.

I just hung testing 92 beta. I have a sample and spindump if needed.

(In reply to Calum Mackay from comment #10)

Not that it matters, but why close my older bug as a duplicate of this newer bug? Isn't the other way around more logical?

It's a toss up this one has a testcase.
Thanks for the regression range. This suggests the regressor is bug 1720725

Assignee: nobody → geoff
Flags: needinfo?(geoff)
Keywords: testcase
Regressed by: 1720725
Duplicate of this bug: 1725576

Anyone using daily August 5 or newer, is the problem gone*? If not, perhaps there are multiple regressions?

`* See bug 1725576 comment 7. One of the symptoms is crash after doing multiple replaces.

heh, my older bug had a testcase too :) - just reply to an email, add a few words at the top, and hit the Spelling button. Hangs every time for me.

Confirmed, problem is still present in Daily 0813

Also, note that just pressing the Spelling button is enough to hang TB, for me. No replaces done yet.

(In reply to Calum Mackay from comment #14)

Confirmed, problem is still present in Daily 0813

Maybe then we will need to reopen bug 1721695. Let's see what happens with 92.0b2 this week - it should build tomorrow.

Well this is weird. I tried to reproduce it in various builds last week, and I could get the crash from bug 1722748, but now I can't. It should've been fixed in those builds so maybe that's a red herring.

I've never seen it hang. The same set of cases in bug 1721695 comment 2 would get me to the crash if the spelling dialog opened and I replaced a word, which is different from what is reported.

I notice bug 1311934 is also in the regression range. Maybe that's got something to do with it. Have you got any ideas Masayuki? I'm stumped.

Flags: needinfo?(geoff) → needinfo?(masayuki)

Full hang using STR from comment 2 is still 100% reproducible for me on current trunk.

Duplicate of this bug: 1725945
Duplicate of this bug: 1726033

92.0b2 is available. See if that helps.

If not, then we are waiting on bug 1725930

(In reply to Wayne Mery (:wsmwk) from comment #22)

92.0b2 is available. See if that helps.

If not, then we are waiting on bug 1725930

Nope, still hangs. I reverted my office PC back to 91.0 stable after having issues on 92.0b2. Is bug 1725930 also related to a crash I just had with 92.0b2 https://crash-stats.mozilla.org/report/index/b1d498ce-e1f4-41b5-8832-7da410210816 ?

Depends on: 1726080

(In reply to Arthur K. [He/Him] from comment #23)

Is bug 1725930 also related to a crash I just had with 92.0b2 https://crash-stats.mozilla.org/report/index/b1d498ce-e1f4-41b5-8832-7da410210816 ?

No, but it's the same crash I experienced in comment 17, which was supposed to be fixed in bug 1722748 but is clearly still happening for some people, so I've opened bug 1726080 as well.

I am not working on this. I can't even reproduce it. Someone else had better take it.

Assignee: geoff → nobody
Duplicate of this bug: 1726166

[Removed invalid comment]

Duplicate of this bug: 1726178

I re-downloaded the English-Canadian dictionary, resrarted TB Daily, and still get the hang. I tried downloading the English-Canadian language pack, but was told it was incompatible with my version of TB.

Pretty sure this bug is different, and not the same as for 91.

I got confused with the many spell checker bugs, removed my comment.

Duplicate of this bug: 1726215
See Also: → 1726280
See Also: → 1725576

You'll want to try tomorrow's daily

Duplicate of this bug: 1726365

Sorry if I am "out of place". I am new at this.
I sent a message earlier that got associated with this error.

I received 3 emails and I assume together they meant somehow the problem was fixed?

Anyhow, now on two emails I have noticed something else.

In both cases, spell check "connected" the last word in one line with the first word in the next.
I confirmed I had typed a carriage return in there.
Eventually it "sent" when I clicked sent.
But it provided no correction option.

Again, forgive me if I am not handling this properly.
I was brought to this page by clicking in the third email I received today about the first issue

Spell check no longer hangs, but it doesn't correct the spelling either.

If I have the string "A nice picxnic in the park!", and do a spell check and press "replace all" for the "picxnic" spell error, the line is corrected to "A nice picnicpicxnic in the park!'... the old spelling error is not removed.

(In reply to David Ogilvie from comment #36)

Spell check no longer hangs, but it doesn't correct the spelling either.

David, please file a new bug report. We'll want to mark it (potentially) a regression of bug 1726080

Flags: needinfo?(d2ogilvi)
See Also: → 1726532

Good morning.
As I mentioned, I am just a user, wanting to be helpful.

This AM, I went into Thunderbird settings and disabled spell check to send to messages in local draft folder.
After those messages were sent, I went back in and turned it back on.
On a whim, I thought, let me see if it works now.
And, sending an email to an alternate personal email, it did.

One other thing.
I had noticed, when the spell check locked things up, "English" was not in the language box.

Now, when the spell check works, it does show "English"

Duplicate of this bug: 1726826

Is the fix for the crash/hang in the upcoming 92.0b3 by chance?

(In reply to Arthur K. [He/Him] from comment #40)

Is the fix for the crash/hang in the upcoming 92.0b3 by chance?

Should be. It just worked for me.

(In reply to Wayne Mery (:wsmwk) from comment #41)

(In reply to Arthur K. [He/Him] from comment #40)

Is the fix for the crash/hang in the upcoming 92.0b3 by chance?

Should be. It just worked for me.

Yup. No crashy crashy hang with the 92.0b3 candidate.

Duplicate of this bug: 1725576

Also gone for me.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(d2ogilvi)
Resolution: --- → WORKSFORME

Thanks for taking care of this. Greatly appreciated.

All is Ok with the 92.0b3. Well done guys !! Thanks!

Works here as well! Great going! :)

Thanks guys, all is fine with 92.0b3

Friends, I have experienced something this AM after updating to 92.0b3 (32-bit).

I have had spell check suggest a correction BUT THEN leave the uncorrected word in the recommendation with no intervening space, thus making two words into one word.

I have worked around it by stopping the spell checker, making the change, and going on. I am able to do that, and the messages seem to send properly.

Again, as a novice, sorry if I ought to have posted separately or as a new thread.

(In reply to david from comment #49)

I have had spell check suggest a correction BUT THEN leave the uncorrected word in the recommendation with no intervening space, thus making two words into one word.

That issue is bug 1726532 which is not yet fixed on beta.

You need to log in before you can comment on or make changes to this bug.