Closed Bug 177498 Opened 18 years ago Closed 18 years ago

ctrl-enter functionality conflicts with mozilla's

Categories

(Firefox :: Address Bar, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: mcbevin, Assigned: hewitt)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

in mozilla, entering a url and then hitting ctrl-enter is configurable to open
the url in a new tab.

in phoenix however this simply messes up the url, and there is no way to turn
this feature off, and also no way to switch the behaviour that mozilla allows
on. it would lead to much less user confusion if the two builds didn't have
conflicting shortcuts and i also personally miss the mozilla functionality

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
*** Bug 177499 has been marked as a duplicate of this bug. ***
Reporter, Phoenix is not Mozilla. Ctrl+Enter is used to prepend "www." and
append ".com" to the URL you're typing. It's not "messing up the URL". Alt+Enter
opens a new tab.

This is a WONTFIX.
That may be so, but using Ctrl+Enter to open a new tab is definitely a hard
habit to get out of, having used Mozilla (and indeed older versions of Phoenix,
where Ctrl+Enter *did* open a new tab!) for goodness knows how long. It's really
annoying when you enter a URL, hit Ctrl+Enter, and *bang!* The page you were
viewing vanishes, to be replaced by some random site you never wanted at all
(e.g. "org.com search directory" or something if I wanted mozilla.org).

See also bug 176337.

Suggested fix: swap Phoenix's Alt+Enter and Ctrl+Enter. Those who want the new
Autocomplete feature can use a new keystroke, rather than forcing an old and
trusted feature to give up its long-established keystroke.
The developers have made it clear that they are trying to imitate IE's behaviour
in this particular field because IE is the defacto standard out there. Therefore
marking this WONTFIX. 

Please file an RFE for the swapping of Phoenix' CTRL-Enter and ALT-Enter behaviour.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
> Please file an RFE for the swapping of Phoenix' CTRL-Enter
> and ALT-Enter behaviour.

Simon, that's what this is (except for the incorrect bug severity). I don't
think it's good practice of WONTFIX'ing bugs if you're not the bug owner.
Severity: minor → enhancement
Not that I don't agree with you that this is a WONTFIX, of course. :)
David, I wouldn't have marked this WF, if Blake hadn't just commented on this
issue yesterday on Mozillazine. See
http://www.mozillazine.org/talkback/read.php?f=11&i=4729&t=4620

So I think it is safe to mark this WF.
*** Bug 178249 has been marked as a duplicate of this bug. ***
*** Bug 178247 has been marked as a duplicate of this bug. ***
Please consider implementing this as a preference.

Its a big problem for me because I switch a lot between mozilla & phoenix, and
it sucks having to pay so much attention to a shortcut that should be a
shortcut, not a frustration source.

There is the argument that phoenix is not mozilla, so it shouldn't mimic all the
commands.  That might be true, but using alt instead of ctrl also is a pain in
the normal workflow of using phoenix. For example, when to copy and paste an url
from somewhere to the url bar the sequence of shortcuts should be
ctrl-c,ctrl-v,ctrl-enter instead of ctrl-c,ctrl-v,alt-enter (its just faster and
easier to continue pressing ctrl instead of switching it). The same can be said
for copypasting something in the search bar. Finally, it also conflicts with the
shortcut for opening a new tab from a web page (its ctrl-click, not alt-click).

If you must, use alt-enter as a default, but PLEASE PLEASE PLEASE give me an
easy way for switching that (easy doesn't mean that it has to be in the
preferences menu, I can also edit preferences files).
Please make this configurable.

I only use Ctrl-Enter or Shift-Enter accidentally, when pasting something into
the URL bar with Ctrl-V or Shift-Insert and then hit Enter a bit too fast. Its
really getting into my nerves.
verified.
Status: RESOLVED → VERIFIED
There are a lot of people using the Mozilla Suite right now.  When the Mozilla
Suite switches to Firebird/Thunderbird/Sunbird/*bird, there will be many people
who want Ctrl+Enter to open a link in a new tab.  The people who have posted in
this bug are merely asking for a preference to do so (and don't need a GUI to
change the pref).
I would also like to see a preference setting for this, for the reasons
mentioned above. Should I file a new RFE (as said in comment #4) or wait for
somebody to re-open this one?
See bug 237027.  It addresses the same issue in a different way.
There's no need to break compatibility with Mozilla nor with IE. We can have both:

Ctrl+Enter in the address bar should add www...com if the string has no dots
(e.g. 'cnn' -> 'www.cnn.com'). This should also apply to 'about:' addresses and
the like.

Ctrl+Enter in the address bar should open in new tab if the string is a part of
URI, with at least one dot (e.g. 'cnn.com' -> New-Tab/cnn.com)

Ctrl+Enter on links should open them in a new tab, like it does today.

Please re-open this bug.

Prog.
People who just want to have the "Ctrl-Enter opens URL in a new Tab" feature
back might want to try out a small extension I have written, see attachment
161856 [details] in bug 237027 comment 6.
*** Bug 266537 has been marked as a duplicate of this bug. ***
*** Bug 249189 has been marked as a duplicate of this bug. ***
Blocks: 282239
No longer blocks: 282239
Blocks: 282239
*** Bug 297448 has been marked as a duplicate of this bug. ***
No longer blocks: 282239
*** Bug 339053 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.