Closed Bug 1864818 Opened 7 months ago Closed 17 days ago

[css-properties-values-api] Let css-properties-values-api ride the trains

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
relnote-firefox --- 128+
firefox128 --- fixed

People

(Reporter: zrhoffman, Assigned: emilio)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Once css-properties-values-api is in a usable state, we should enable it by default.

Keywords: dev-doc-needed
Depends on: 1865810

Depending on bug 1856522 explicitly, since bug 1856524 was resolved without having completed bug 1856522.

Depends on: 1856522
Depends on: 1869185
Depends on: 1875546
Depends on: 1875673
Depends on: 1868436, 1855110
No longer depends on: 1856522
Depends on: 1877383
Depends on: 1870348
Depends on: 1884872
Depends on: 1888317
Duplicate of this bug: 1892586
No longer depends on: 1884872
Depends on: 1870370
Depends on: 1533327

Our implementation is in a reasonably good state. Only test failures
are:

  • Long-standing bug 1533327.
  • A test / spec issue that is covered by D211871 (the animation works
    correctly).
  • TypedOM

So I don't see a reason to keep gating this to nightly-only.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Depends on: 1899272
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a362bc63470f
Let properties and values ride the trains. r=zrhoffman,firefox-style-system-reviewers

Release Note Request (optional, but appreciated)
[Why is this notable]: Registered custom properties in animations and transitions are smoothly interpolated, and registered custom properties are type-safe, can have default values, and can be specified to or not to inherit, regardless of where they are used.
[Affects Firefox for Android]: Yes
[Suggested wording]: Support for CSS @property / properties-and-values API is enabled by default.
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Web/API/CSS_Properties_and_Values_API

relnote-firefox: --- → ?
Status: ASSIGNED → RESOLVED
Closed: 17 days ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
Regressions: 1899797

Added to the Fx128 relnotes.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: