Closed Bug 200257 Opened 19 years ago Closed 16 years ago

mozilla calendar is not supported on Firefox?

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: aynilove, Unassigned)

References

()

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4a) Gecko/20030329 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4a) Gecko/20030329 Phoenix/0.5

install of mozilla calendar on phoenix is successfully done,
but there is no way to reach to calendar.

you may say, "It's for mozilla not for phoenix", I can not agree.
Phoenix is well-done browser, so lose a powerful extension be great loss.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Phoenix way to handle extensions is different from Mozilla's one.

-> Calendar/General, but not confirming, since the decision to support Phoenix
is up to Calendar owners.
Assignee: blaker → mikep
Component: General → Calendar General
Product: Phoenix → Calendar
QA Contact: asa → brantgurganus2001
Any link on the way Phoenix handle extensions. I found 42 extensions but no
documentation on how to do them :-(
http://www.xulplanet.com/ndeakin/arts/phoenix.html should help you.
Dave Hyatt once made a nice page summarizing the changes, but it disappeared.

http://www.mozillazine.org/forums/viewtopic.php?p=39242 might also be useful.
I think I would rather see the calendar made into its own program, like Mail /
News, then to become an extension to Phoenix.  However, since this new roadmap
is still new, I don't really completely understand the relationship between
being an extension to Phoenix and being a seperate application.
Confirming, but only to receive mail about this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 203223 has been marked as a duplicate of this bug. ***
How to convert your Mozilla extensions

Soon, Mozilla Firebird will be the primary web browser from Mozilla.org Brian
King has written a document describing how to convert Mozilla Application Suite
(SeaMonkey) extensions into Mozilla Firebird extensions. (URL :
http://www.mozdev.org/notes/transition.html)
This document is probably useful for you if you are an extension author for Mozilla.
Mozilla.org News

Posted by David Tenser | 2003-05-15
(copied from Mozilla Firebird Help : http://texturizer.net/firebird/)
This bug has been sitting here for quite a while now.
Will it be ported to Firebird anytime soon?
Just a note that once you install the calendar XPI using Firebird you can get to
it from command line:
./MozillaFirebird -calendar or
MozillaFirebird.exe -calendar
Summary: mozilla calendar is not supported on phoenix? → mozilla calendar is not supported on Firebird (formerly)phoenix?
> MozillaFirebird.exe -calendar
Above resolution is mentioned above, comment #5. [mozillazine forums]

And, as you already know, it's not a complete resolution.
Unfortunately it's not work with Firebird 05/25 ver.
I try to evaluate the effort to build a package for Mozilla Firebird.
I read for this http://www.mozdev.org/notes/transition.html.
I manage to include an entry in the tool menu and to register it
as a Firebird extension. But the main difficulty is the "preferences". 

This part of the interface seems to be really different in Firebird. 
In the current calendar version the preferences are included as overlay of the
"Mozilla Application Suite" preferences. These preferences code (in
chrome://communicator/content/pref...) is still present in the Mozilla Firebird
0.6, but it could be suppress in the future (to be confirmed !).
It seems that the normal choice would be to rewrite the preferences as
an independant dialog which could be call with the settings button in
Tools->options->extensions->calendar and in the calendar window itself.
It seems that the "tabbrowser extensions" could be used as an example.

Another problem arises when calling calendar twice with the menu entry. This
leads to the following error in the javascript console:
Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: <unknown filename> ::
onxblconstructor :: line 2"  data: no]
Does somebody understand this message better than I do ?
OS: Windows 2000 → All
Hardware: PC → All
For testing purposes.
Here a zip archive with the modified calendar/content/contents.rdf 
and the new files to support Mozilla Firebird :
- entry in Tools menu
- registration as extension
- settings from the setting button in Tools->Options->extension->calendar

I used this files to modified the windows XPI package
http://www.oeone.com/files/calendar_windows.xpi and it had work for me with 
MozillaFirebird 0.6.
Comment on attachment 125082 [details]
ZIP of the new files and the modified contents.rdf

Excellent job! I tested the  modified files and they successfully added the
calendar to the tools menu. Both windows and linux. Preferences work too. Just
would've been better to receive this as a patch rather than in a zip file.
Mikep: Can you take a quick look too so we can add this to cvs?
Attachment #125082 - Flags: first-review?(mikep)
I'm reluctant to do this, since I don't want Calendar to be part of Phoenix, I
want it to be its own application.
Some will say that this is better than nothing, however I'm afraid that by doing
this, we won't put the effort into making Calendar stand alone.
Comments?
What is the issue here? Calendar is never going to be part of Firebird - I can
pretty well assure you of that. Thunderbird possibly, but not FB. I guess the
issue is whether or not to make Calendar an add-on to FB/TB or to make it into a
separate app?

Please correct me if I'm wrong but until Mozilla.org gets XRE and GRE up and
running I don't see that you have that much choice. To have to include the XRE
and GRE(?) elements in a stand-alone Calendar build seems to me to be insane,
especially if a user already has FB and TB installed. Additionally, I would
suspect that a lot of Thunderbird users would prefer to see the Calendar as an
extension to TB once TB can handle extensions (I must confess that I don't see
Calendar as the type of thing that makes a good FB extension as it is too
different, unlike TB).

My recommendation would be for now to enable the Calendar as a FB extension and
then as a TB extension when that becomes possible. Other than that, just keep on
improving the Calendar until XRE and GRE become available and decide where to go
from there. I guess one question worth considering until then is how many
non-FB/TB/Moz users are likely to want to use an XUL Calendar app.
Just a comment on Mike one : http://bugzilla.mozilla.org/show_bug.cgi?id=200257#c14
I agree with Mike completely but I decide to look at this Firebird nevertheless.
The reasons are mainly that : 
- the menu integration is very easy to do (and it was requested by some users).
- the preference (or settings) integration mainly consist in the replacement of
the mozilla overlay with independant window. The options window is no more
integrated with Mozilla (or Firebird) but is not only calendar dependant. I
think that this is also a step toward a stand alone calendar (a very small step).
About Mostafa comment : http://bugzilla.mozilla.org/show_bug.cgi?id=200257#c13.
I provided a ZIP (for testing purposes) because there is only one modified file
and three or four new files. I can provide a patch for contents.rdf (if the
feedbacks are positives).
Eric: I don't know what utility you are using but with diff you can use -urP to
include the new files in the patch as well.
Thanks Mostafa for the guideline.
I can finally provide it as a patch (if you want to test it).
Note: we still have some errors in the JS console :

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/profile/profileSelection.js :: StartUp :: line
97"  data: no]

 Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: <unknown filename>
:: onxblconstructor :: line 2"	data: no]

Any ideas about those errors ?
Attachment #125082 - Attachment is obsolete: true
*** Bug 209768 has been marked as a duplicate of this bug. ***
Ad comment 14:

>I'm reluctant to do this, since I don't want Calendar to be part of Phoenix, I
>want it to be its own application. Some will say that this is better than 
>nothing, however I'm afraid that by doing this, we won't put the effort into 
>making Calendar stand alone. Comments?

Mike, I think both approaches are worthy of attention. Making Calendar an
extension for firebird and /or thunderbird will increase its userbase and that
is a worthwhile goal all by itself.

Making it into a standalone-app (I saw the sunbird checkins today) is also good
and interesting. 

But users, who have already installed Firebird/Thunderbird will want a small and
lean extension without all the GRE stuff (especially those users with modems and
ISDN which is still very popular here in Europe) and not providing calendar for
those people will harm its adoption rate and testing coverage.
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
The calendar package correctly does not work completely with Firebird (no
toolbar, no mail,...). My opinion is that we should place our effort in a
Thunderbird package more that in a Phoenix package. The current code should be
modified only be disabling or collapsing the commands which does not work with
Firebird.

A light package for Firebird which only display the calendar (but does not allow
to modify it could be develop)

The thunderbird support bug is http://bugzilla.mozilla.org/show_bug.cgi?id=219589.

Comments welcome
Comment on attachment 125082 [details]
ZIP of the new files and the modified contents.rdf

patch is obsolete
Attachment #125082 - Flags: first-review?(mikeypotter)
Summary: mozilla calendar is not supported on Firebird (formerly)phoenix? → mozilla calendar is not supported on Firefox?
Depends on: 244869
No longer depends on: 244869
Depends on: 245208
Depends on: 245524
This has long been fixed.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Reopening to track possible progress on Firefox 1.5 support.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The first change needed is to have the supported versions bumped up to 1.5
Also it seemed to me, and dmose agreed, that the version of the xpi is better to be consistent with what Sunbird is at (0.3a1+)
The version in about.html is usually only bumped up with official xpi releases but to differentiate from the last official release we need it bumped up.
Attachment #207499 - Flags: first-review?(dmose)
Depends on: 322395
Comment on attachment 207499 [details] [diff] [review]
Bumping up the supported versions

r=dmose for landing on the 1.8 branch.  I'd suggest waiting until I crash-land the rest of the calendar-trunk onto the branch (hopefully in a few hours) and then checking in after that.
Attachment #207499 - Flags: first-review?(dmose) → first-review+
Comment on attachment 207499 [details] [diff] [review]
Bumping up the supported versions

Patch checked in on 1.8 branch.
New experimental xpi build available for windows on http://www.mozilla.org/projects/calendar/download.html
*** Bug 322591 has been marked as a duplicate of this bug. ***
After installing into seamonkey 1.0b, default startup window (no -calendar parameter) is now calendar window with no GUI way to get to any other window.   

Workaround: add -browser parameter to (shortcut) command to get seamonkey to display the browser window.

Nice to be able to use DOM inspector again, though.
Depends on: 322770
Depends on: 324163
QA Contact: gurganbl → general
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Status: REOPENED → NEW
calendar.xpi is dead.
Status: NEW → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.