Infinite browser spawn & file creation loop via circular file associations (mozilla as default application, helper app set to "open with default")

NEW
Unassigned

Status

()

--
critical
16 years ago
4 months ago

People

(Reporter: vega.james, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030808

Problem: Mozilla goes into an infinite loop of opening new browser windows and
creating new copies of a file that is trying to be opened. This occurs when
Mozilla is set to automatically open the file with the default application and
Windows has Mozilla associated as the default application for that filetype.

Steps to reproduce:
1. Attempt to open a .cpp file with Mozilla.
2. Specify that Mozilla always use the default application to open .cpp files.
3. Windows "Open file with ..." dialog opens. Specify Mozilla as the default
application.
4. Mozilla will open a new browser window every time it attempts to open the
file and will create a copy of the file, tacking a -1 onto the filename each
time, i.e. foo.cpp -> foo-1.cpp -> foo-1-1.cpp -> etc

This not only uses up system resources by continually opening new browsers, but
it can use up all of the space on the hard drive. This will probably work with
other file extensions, but .cpp is the one that I experienced it with.

Comment 1

16 years ago
this is already reported and is not security sensitive
Group: security
Whiteboard: DUPEME

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 167320 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
reopening; the use case with "mozilla as default application" vs "mozilla
explicitly specified as helper app" should be kept separate, imo... the latter
is much easier to fix.
Status: RESOLVED → REOPENED
Depends on: 167320
Resolution: DUPLICATE → ---
Assignee: law → file-handling
Status: REOPENED → NEW
QA Contact: chrispetersen → ian
"fix" in the sense of "detect and disallow"
*** Bug 230772 has been marked as a duplicate of this bug. ***
Summary: Infinite browser spawn & file creation via circular file associations → Infinite browser spawn & file creation loop via circular file associations (mozilla as default application, helper app set to "open with default")

Comment 6

13 years ago
*** Bug 323119 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
See also bug 218257, which suggests a solution for Firefox (don't allow choosing Firefox as the helper app).
Assignee: file-handling → nobody
QA Contact: ian → file-handling

Comment 8

9 years ago
(In reply to comment #0)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030808
> 
> Problem: Mozilla goes into an infinite loop of opening new browser windows and
> creating new copies of a file that is trying to be opened. This occurs when
> Mozilla is set to automatically open the file with the default application and
> Windows has Mozilla associated as the default application for that filetype.
> 

Confirmed using 3.6 and .swf files. Not a showstopper but very confusing for newbies trying to open files.

Comment 9

9 years ago
Just noticed this was an old bug - sorry. Whatever the issue was then is recurring in 3.6.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Duplicate of this bug: 565873

Updated

4 years ago
Duplicate of this bug: 1153597

Updated

3 years ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified

Updated

3 years ago
Duplicate of this bug: 1288990

Updated

8 months ago
Duplicate of this bug: 1343250

Updated

8 months ago
See Also: → bug 218257

Updated

7 months ago
Duplicate of this bug: 1478289

Updated

6 months ago
Duplicate of this bug: 1493055

Updated

5 months ago
Duplicate of this bug: 1499561

Updated

4 months ago
See Also: → bug 1496380
You need to log in before you can comment on or make changes to this bug.