Closed Bug 23222 Opened 20 years ago Closed 11 years ago

Option to auto start Mozilla after installation

Categories

(SeaMonkey :: Installer, defect)

All
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

Details

(Keywords: helpwanted, Whiteboard: [bsmedberg-installui])

Current Mozilla is started after installing it. This should not be the case.
There should be an option in the installation procedure to start Mozilla after
the installation finishes.
We have conflicting dictates on this! See 10432 and 21655 which want us to
launch mozilla and the profile manager to complete the installation. In part
this is because Netscape wants to throw a registration screen in there (so
force launching could be made a Netscape-only option), but also in part to hide
the pain of registering components during the install time rather than at first
user start.
I think the auto start of Mozilla after installation should be a Netscape only
thing!
The part of registering components could be handled by a small dialog saying
"Preparing to start Mozilla for the first time..."
Status: NEW → ASSIGNED
not sure what we want to do with this.  Adding more people to the CC: list for
input.
Please please remember this is open source even though that the main thing is
Netscape 5.0...
I don't mind there being a flag that avoids this for Mozilla builds.  However,
the need to populate the component registry is real.  If we don't do this during
install, then it becomes painfully perceptible when the user attempts to run the
app the first time.
Depends on: 10432, 21655
Target Milestone: M15
setting target milestone to M15
Steve, maybe the showing of the dialog should be independent of the component 
registry population?

example: we can have a dialog asking the user if they want to launch mozilla 
(show the browser window).  If they choose yes, we can do the component registry 
*and* launch a browser window.  If they choose to decline, then only do the 
component registry.

This would probably require the following command line parameters:
  * to register the component registry *and* show the browser window
  * to *only* register the component registry and quit afterwards.
Steve, maybe the showing of the dialog should be independent of the component 
registry population?

example: we can have a dialog asking the user if they want to launch mozilla 
(show the browser window).  If they choose yes, we can do the component registry 
*and* launch a browser window.  If they choose to decline, then only do the 
component registry.

This would probably require the following command line parameters:
  * to register the component registry *and* show the browser window
  * to *only* register the component registry and quit afterwards.
I think this sound like a good idea.
Sure.  I don't think we need 2 flags though.  The register and launch would just 
be the default.  The new flag would be to register and quit.  This should not 
show the splash screen either. 

Adding DP to the CC list.  DP, would you be the correct owner for creating this 
flag?  There should be a second bug for implementing the flag and this bug 
should be reserved for the corresponding installer change(s).
Adding a flag like this to mozilla/netscape seems not the right thing to me. 
The do component registry only is available in many flavours
- nsComponentManager::AutoReg()
- regxpcom.exe

ssu, you can do one of the above right instead of invoking the app.
Kevin, would this conflict with your registration page at startup?  Is your 
registration page tied to the -installer flag?

Steve, you might also want to talk with Kevin to make sure it doesn't conflict 
with marketing requirements.  They've made a big issue about their startup page, 
and I don't want to have all the work be a waste.
If the internal default is to do what it does today, then there is no conflict.
If you change that default, then internal builds need the installer to send in
the explicit flag.  Either way, this behavior should only perceptibly change on
Mozilla builds.
mass change to M16
Target Milestone: M15 → M16
selmer, do you know if the -installer option is tied to launching the Activation 
page?

If it is, I'll mark this bug as invalid.
If it isn't, but it will in the future, I'll mark this bug as invalid.
However, it isn't and won't be in the future as well, I can do something to fix 
this bug.
Sean, -installer only controls whether migration information gets imported from
4.x.  Activation happens on every new profile at every startup until the user
either activates or decides not to activate.  The activation behavior will not
be tied to any command line arguments since it's a per-profile, must-decide kind
of thing.

I think you should go ahead and create a flag for Mozilla builds that allows
component registration to happen without any splash screen and then quit.
Someone needs to implement the "do component reg & quit" handling too.
this would be nice to have, but no plan to address this issue for now.
Target Milestone: M16 → M30
Changing fictional "M30" to reality
Target Milestone: M30 → Future
QA Contact: gbush → gemal
Currently most installers for windows have a checkbox:
run app when done installing.

That's all it takes. Then we can argue about the default.
Default to run moz for windows.

Is this windows only?
...if not:
For unix if the person running it is root we should probably default to not 
running it.

Keywords: helpwanted
Depends on: 52052
Priority: P3 → P2
*** Bug 62062 has been marked as a duplicate of this bug. ***
OS: Windows 98 → All
Hardware: PC → All
a request was also made to the Linux installation
is there a bug filed yet for the linux platform?
I've changed this to OS=All
Is that enough, or do someone else needs to be on the CC?
No longer depends on: 52052
*** Bug 62227 has been marked as a duplicate of this bug. ***
over to Curt.
Assignee: ssu → curt
Status: ASSIGNED → NEW
*** Bug 131658 has been marked as a duplicate of this bug. ***
from duped bug:
"Often you (I) install mozilla as root and i won't run mozilla as root.."
Summary: Option at auto start Mozilla after installation → Option to auto start Mozilla after installation
*** Bug 223011 has been marked as a duplicate of this bug. ***
Another vote on not running mozilla after install ( on windows ) .

Put an option on the last installer wizard page, like other programs do.
You can also put a note about how netscape profiles are migrated.
*** Bug 225438 has been marked as a duplicate of this bug. ***
curt's gone, nobody's working on this at the moment. If you think you can help
with this bug, please reassign it to yourself.

Assignee: curt → nobody
QA Contact: bugzilla → general
Whiteboard: [bsmedberg-installui]
when looking at #7, I agree
registering components is OK and should be default.
starting mozilla is NOT OK and should be by an option.
the linux installer no longer launches Mozilla at all.
==> windows-only
OS: All → Windows XP
Product: Browser → Seamonkey
Priority: P2 → --
Target Milestone: Future → ---
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.