Closed Bug 25950 Opened 23 years ago Closed 3 years ago

Include votes from duplicates when calculating votes on a bug

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement, P4)

enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mozilla, Unassigned)

References

Details

Attachments

(1 obsolete file)

Does anyone think it would be unfair to count dups as votes for a bug? I see 
some bugs with literally a dozen dups. To me that is a sure sign of its 
importance to people.
I don't want to second-guess or obfusicate the voting system.  If someone sees
that the bug they submitted was marked as a duplicate, they have the opportunity
to go chase down the original bug and vote on it. 

If the problem is that we want more people to understand and use the voting
system, then we need to work on that.
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → WONTFIX
I don't think many people do because it is not obvious that votes are anything 
more than nothing. That is to say that I don't see any reordering of bug 
priorities based on votes, am I missing something?
Again, this is an education issue.  Bugzilla just collects the voting data and
reports it to anyone who asks.  If we want engineers to pay attention to the
votes and tweak their priorities accordingly, that's a separate problem (and not
one that Bugzilla itself is going to solve).
At least when somebody voted for a duplicate bug, shouldn't the votes be
automatically transfered when the bug is marked as a duplicate?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
This has been covered before in bug #16153.  If this gets implemented it will
need to not occur right away, say after a month or when the bug is VERIFIED or
CLOSED, or both.

An alternative is bug #27553.
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: REOPENED → NEW
Err, no, it wasn't covered in that bug, that's deps not dups.

But anyway, this is a dupe, I think I'd prefer to close this one because of the
conversation on the other one (although it's close) despite its age.

*** This bug has been marked as a duplicate of 36919 ***
Status: NEW → RESOLVED
Closed: 23 years ago22 years ago
Resolution: --- → DUPLICATE
Wake up Matthew ...

An implementation of this would probably solve bug #36919, but they're not the
same ...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OS: Windows 98 → All
Hardware: PC → All
Adding default QA contact to all open Webtools/Bugzilla bugs lacking one.
Sorry for the spam.
QA Contact: matty
Just a thought.  Instead of transferring the votes, we could automatically pick
them up from bugs marked as duplicates of this one.  That way when a bug is
reopened is gets automatically undone.

And this doesn't suffer from the problems of transferring votes through
dependencies (bug #16153), because a dupe can only be a dupe of one bug.

So I think this is quite doable.
I agree with Matt
Target Milestone: --- → Future
Severity: normal → enhancement
Moving to new product Bugzilla.  Putting this in Changing/Editing Bugs since
this is with marking dups.
Assignee: tara → myk
Status: REOPENED → NEW
Component: Bugzilla → Creating/Changing Bugs
Product: Webtools → Bugzilla
Version: other → unspecified
*** Bug 123159 has been marked as a duplicate of this bug. ***
*** Bug 129669 has been marked as a duplicate of this bug. ***
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
See also bug 65370, create a new "interest" field that combines dup count,
number of votes, and number of CCs.  Fixing that bug would make this change
unnecessary.

- Jesse using Asa's computer.
*** Bug 179528 has been marked as a duplicate of this bug. ***
Broadening the summary to include the scope of several of the bugs that have
been duped to this one.  The discussion in this bug covers that scope, but the
summary didn't, so it was confusing people.

I personally think comment 10 is a pretty cool idea.  I'm worried about the kind
of table joins it would require to pull it off in buglist.cgi, though. 
Subselects would fix that, but gee, MySQL can't really do that yet. :(

Maybe when MySQL 4.2 comes out.  (Or we can just do it that way on Postgres or
something).
Summary: Dups count as a vote? → Include votes from duplicates when calculating votes on a bug
*** Bug 257691 has been marked as a duplicate of this bug. ***
Attached file (obsolete) —
1234567890
Comment on attachment 168129 [details]
 

Sorry if I missed something, but this attachment looks like spam.
Attachment #168129 - Attachment is obsolete: true
Attachment #168129 - Attachment is patch: false
Attachment #168129 - Attachment mime type: text/plain → text/html
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---
Assignee: myk → create-and-change
Priority: P3 → P4
Duplicate of this bug: 373815
Duplicate of this bug: 373814
Duplicate of this bug: 457255
Attachment #168129 - Attachment description: 123 →
Attachment #168129 - Attachment filename: Enter A Bug.htm →
Attachment #168129 - Attachment mime type: text/html → text/plain

The voting functionality will be replaced with emoji comment reactions in the near future.

Status: NEW → RESOLVED
Closed: 22 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.