Last Comment Bug 261682 - View Unread messages updates to quickly.
: View Unread messages updates to quickly.
Status: RESOLVED FIXED
: fixed-aviary1.0
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: David :Bienvenu
:
Mentors:
http://exodus.230volts.net/~yazz/
: 260971 262242 262305 262960 263899 263972 265099 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-26 11:19 PDT by Yazz D. Atlas
Modified: 2004-10-19 10:01 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (13.44 KB, patch)
2004-10-01 10:06 PDT, David :Bienvenu
mscott: superreview+
Details | Diff | Review

Description Yazz D. Atlas 2004-09-26 11:19:44 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Under Thunderbird 0.8 on Windows XP if you select "View Unread" and then view
some messages Thunderbird will update the message selection area after a few
seconds.

The update will hide the currently viewed message from the selection window.
This update also for a short time clears the message selection area as it
populates it with just unread messages. 

Versions before 0.8 did not do this. Is there a way to set the way "View Unread"
back to the old method. Having the message I just read vanish, clear the message
selection are, re-update the message selection area is anoying. I liked how I 
could start Thunderbird at the begining of the day and not have to keep 
switching the View to find just read messages.

Reproducible: Always
Steps to Reproduce:





See the URL I provided for screenshots.
Comment 1 anthony 2004-09-28 04:18:32 PDT
also happens on linux using 0.8 - and you are forced to select "View ALL" to
perform task on message being read
Comment 2 Bob Horvath 2004-09-30 08:30:31 PDT
This also happens with Custom views.  I have one that is called "Labelled and
Unread" that allows me to see important, and new messages.  If I click on an
unread one, and a new message comes in, I can't respond or forward the one I am
looking at which has disappeared from the list.
Comment 3 David :Bienvenu 2004-09-30 08:34:35 PDT
I'll fix this today...
Comment 4 David :Bienvenu 2004-09-30 08:34:47 PDT
*** Bug 262242 has been marked as a duplicate of this bug. ***
Comment 5 David :Bienvenu 2004-09-30 10:00:03 PDT
*** Bug 262305 has been marked as a duplicate of this bug. ***
Comment 6 David :Bienvenu 2004-10-01 10:06:18 PDT
Created attachment 160759 [details] [diff] [review]
proposed fix

I added a bunch of debugging statements which are currently turned off, in
order to help get everything working again...
Comment 7 Scott MacGregor 2004-10-01 10:09:52 PDT
Comment on attachment 160759 [details] [diff] [review]
proposed fix

You've got a change to msgHdrViewOverlay.js that's part of another bug I need
to review. 

should this:

+dump("uri == current loading folder uri\n");

use your viewDebug method?
Comment 8 David :Bienvenu 2004-10-01 12:06:58 PDT
fixed on trunk, seamonkey and tbird, and on tbird aviary branch
Comment 9 David :Bienvenu 2004-10-04 07:47:18 PDT
*** Bug 260971 has been marked as a duplicate of this bug. ***
Comment 10 David :Bienvenu 2004-10-05 07:38:08 PDT
*** Bug 262960 has been marked as a duplicate of this bug. ***
Comment 11 David :Bienvenu 2004-10-11 13:58:23 PDT
*** Bug 263899 has been marked as a duplicate of this bug. ***
Comment 12 David :Bienvenu 2004-10-12 09:54:52 PDT
*** Bug 263972 has been marked as a duplicate of this bug. ***
Comment 13 David :Bienvenu 2004-10-19 10:01:42 PDT
*** Bug 265099 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.