Closed Bug 283598 Opened 15 years ago Closed 14 years ago

Give the firefox .dmg a nice icon

Categories

(Firefox Build System :: General, enhancement, P4)

PowerPC
macOS
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: u49640, Assigned: jon)

References

()

Details

(Keywords: fixed1.8, Whiteboard: [ETA 09/02][needs review beltzner])

Attachments

(16 files)

5.25 KB, image/png
Details
60.97 KB, application/octet-stream
Details
62.66 KB, application/octet-stream
Details
74.11 KB, image/png
Details
65.80 KB, image/png
Details
47.73 KB, image/png
Details
72.60 KB, image/png
Details
63.04 KB, image/png
Details
48.59 KB, image/png
Details
19.90 KB, image/jpeg
Details
55.47 KB, image/png
beltzner
: review+
Details
50.61 KB, image/png
beltzner
: review+
Details
460 bytes, application/gzip
Details
83.98 KB, image/png
Details
466 bytes, application/gzip
Details
78.20 KB, image/png
Details
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

The .dmg linked in the URL has a nice custom Icon.
I think firefox (and the other Mozilla Apps) deserve a custom Icon too

Reproducible: Always
Status: UNCONFIRMED → NEW
Component: Installer → OS Integration
Ever confirmed: true
Priority: -- → P4
QA Contact: bugzilla → os-integration
Here's a DMG icon for OS X for Firefox from Jon Hicks.
Here's a DMG icon for OS X for Thunderbird from Jon Hicks.
Mac OS X DMG background by Jon Hicks
Mac OS X DMG background by Jon Hicks
Mac OS X DMG background by Jon Hicks
Mac OS X DMG background by Jon Hicks
Mac OS X DMG background by Jon Hicks.

Sorry for the bugspam - maybe I should have zipped all of these into one
attachment. Anyhow, here are DMG icons for Firefox and Thunderbird.

There are also three variations of DMG background images for both Firerox and
Thunderbird:

1. There is a version with instructional text in the image which I presumed
would be an internationalization problem, so...
2. There is a version with no text
3. and a version with no text, and also 50% lighter (I prefer this one since
the actual app icon will look more prominent, but the full-color one is fine
with me too).

All credit for the artwork goes to Jon Hicks. Jon also points to these posts
for instructions:
http://decaffeinated.org/archives/2003/10/24/dmg
http://decaffeinated.org/archives/2004/04/20/dmg
maybe you want to ask review for one or more of your attachments?
I would recommend the "no text, lighter background" backgrounds - and I think
the icons are nice.

I don't really mind the default icons and plain background - but I'm fine with
this artwork being used if people want it.
so... do you want to ask for a review? ;)
they're your attachments. i'm sure you posted them for a reason :)
i just love them... great Icons.

i'd prefer the one with the Text to make it clear that noone should launch it
from the dmg, but i dont know how many people would do this and this wouldnt be
easy to localize, so maybe we should use one without the Text (or is it possible
to just display a (localizeable) String there?

Maybe there should be a place for a Readme file with the Release notes.
Ben: is this something that would be included? 

I can try this as a first bug to get me started on hacking for Mac but i want to
know if this will then actually make it to the trunk before i get started...
I think this is actually something that needs to be done on the build machines?
Moving to "build config" component.
Component: OS Integration → Build Config
QA Contact: os.integration → build.config
I'll see what I can do about this in bug 257854.
Depends on: 302080
These icons and backgrounds are great, and I'll be bringing them in shortly for
officially-branded Firefox and Thunderbird builds.

Can we get similar backgrounds and icons for Deer Park and unofficial
Thunderbird builds?
More: I plan on using the backgrounds with text in the standard English builds.
 I've added a white comma to the Firefox background where it belongs.

For localized builds, I'd like to use a textless background by default.  When
there's no text, I see no reason for there to be a gray box.  Can we get these
images without the gray for those cases?

I imagine that the images with the gray boxes would serve as templates for
localizers who wish to provide their own text.

Mike Beltzner suggests that instead of text, we might be able to get away with
iconography.  We could show an app icon being dragged to an application folder
icon.  I like that idea.  Here's Beltzner.  Let's discuss.
Work is being done in the parent bug 302080.
There's three solutions that I see for this:

1 - remove all text entirely
2 - get the text translated and package different .dmg backgrounds
3 - come up with some simple iconography that shows the Firefox icon being
d'n'd'ed into the applications folder

The parent of this bug is blocking branch, so we should decide on a strategy by EOD.
I like the sound of option 3 - use iconography to show the app being dragged into into the applications 
folder. If we're agreed on that, I can get on and create the new artwork.

Presumably this excludes using the 'Firefox' logotype?
> Presumably this excludes using the 'Firefox' logotype?

That is a very safe presumption, logotypes are not translated as far as I know. :)
(In reply to comment #22)
> I like the sound of option 3 - use iconography to show the app being dragged
> into into the applications folder. If we're agreed on that, I can get on and
> create the new artwork.

Jasper Hauser put something diagrammatic together for the Camino dmg, and I
really like it.  It's not anywhere public, though.  (Yet.)  I'm completely for this.
By the request of John Hicks I attached the diagramatic background I made last
week for Camino. Mark wondered if it where possible to create one that would
explain the whole install process without using words. Attached is what I came
up with. Note that if it's going to be used for FF I can provide the psd file I
have. It will take some work to create a diagramatic simple version of the FF
icon (good one for John to do).
Thats just what I was imagining - nice work Jasper!

So how does this work? Do we have to vote on this? I say we go ahead and do this.
Jasper, John, and others: please keep the following in mind when coming up with
your designs:

You should leave 15px of dead space along the bottom and right edges of your dmg
backgrounds.

The Finder in Jaguar (and earlier) always draws scrollbars in these parts of the
window, even if they are empty and disabled.  Panther (and Tiger) do not draw
scrollbars if they are not necessary, but still includes a 15x15px resize box at
the bottom right.  If your background designs encroach on these areas, we'll
have to either chop them off on Jaguar or leave potentially unsightly white
stripes on Panther.  (Whether or not they stripes would be unsightly depends on
your design.)

Since we've undoubtedly got many more users on Panther and Tiger than Jaguar,
the best way to handle this is to allow full-bleed designs as long as nothing
important would be sliced off on Jaguar.

I don't know if anyone else has anything to say, but in the absence of other
opinions, I'll use diagrammatic l10n-free backgrounds when bug 302080 is
reviewed and checked in.
No problem - I intend the design to be predominantly white! So all I need is the .psd from Jasper, and I 
can crack on...
Great work! 

I don't think we need to include instructions on what to do with the DMG after
dragging the application into the applications folder. It's a little bit harder
to communicate as well, since there is no eject icon drag target visible in the
desktop until you start dragging the DMG (a long-known weakness of the dock).

Unless you feel strongly about including this, I'd suggest dropping it, as it
seems to confuse the otherwise excellent iconographic story you're telling.
2 things, he finder sidebar show an eject icon for the disk and every MAc
keyboard has an eject key. I think that the last eject part is good to have for
first time users of the platform, anybody else will understand it right away.
For those first time users I think we should really do it, as they need the help.
(In reply to comment #30)
> 2 things, he finder sidebar show an eject icon for the disk

The sidebar is now gone, gone, gone, whoa-oh...  We'll now have
professional-looking raw windows containing only our content.  No sidebars,
toolbars, status bars, oxygen bars, etc.
Hahah K well anyway, I think 90% of peole know what the last icon means (eject)
even my dad who is of the lp and tape generation.
My point is more about how ejecting the DMG isn't part of the install process.
Put it this way: when this was text, nobody was ever considering adding in words
to the effect of "Once the application has been installed, eject the disk
image." It's not a neccessary step in the installation of the product (and not
one normally covered by OS X installer text messages. To my eye, it makes
installation look more complicated than it actually is.

Anyhoo: for FFx and TBird, I'd suggest dropping these elements.
The new dmg packager and preliminary artwork from this bug have been checked in
to the trunk and 1.8 branch under bug 302080.  Jon, when the new artwork is
ready, we can check it in.

As it stands now, the existing (English text) Firefox and Thunderbird
backgrounds attached here are used for official Firefox and Thunderbird builds.
 Blank backgrounds are used for Deer Park and unofficial Thunderbird - it would
be nice to get designs for those too.  For Camino, Jasper's diagrammatic
background is in place, but won't be used in new dmg files until the tinderbox
build scripts are updated.  The provided disk icons were used, and I rolled my
own for Deer Park and the unofficial Thunderbird.
I do wonder if we do need the eject icons. You'd be surprised hoy many people
I've seen with a desktop cluttered with drive images that they don't know they
can eject. Dunno, maybe all we should care about is whether they can install the
app or not.

Jaspers sent me his artwork, so I'll get on with the images, leaving off the
eject for now.
Blocks: 305686
This bug has l10n impact and needs to be communicated that way. Setting keyword.

Bug 306163 is closest to depend on this one, I guess. Bug 305717 is about lack
of intuition of the camino artwork, too.
Blocks: 306163
Keywords: late-l10n
Removing late-l10n keyword, there is no localization impact here.  See recent
comments and WONTFIXed bug 306163.
Keywords: late-l10n
New l10n-free dmg artwork should block the release.  Since the only remaining
work here is Jon's, I'm tossing the mike over to him.
Assignee: nobody → jon
Flags: blocking1.8b4?
Flags: blocking1.8b4? → blocking1.8b4+
I'm on the case with these - hopefully get them finished by the end of the week.
Whiteboard: [ETA 09/02]
These are the new background images Jon came up with.  The application icon
will be 128x128 to the left of the arrow.  I will supply proper .DS_Store
files.
Attachment #194959 - Flags: review?(mike)
Attachment #194960 - Flags: review?(mike)
Attached file .DS_Store for Firefox
This is the .DS_Store companion to attachment 194959 [details], it belong in the tree at
mozilla/other-licenses/branding/firefox/dsstore.  The image should be in that
same directory, named background.png.  Notes to self: window dimensions
(206,304,541,719), icon center position (95,152), icon size 128.
So that you can see what this will look like in a disk image without doing an
entire branded build, this is the result produced by the new Firefox background
and its .DS_Store companion.  The window opens so that the content is centered
on a 1024x768 display.
is there a way to link the Applications-Icon to the /Applications Folder?
(so a user could directly drag the App to the Icon in the .dmg?)

(i think i've read something like this in a Bug#, but cant remember where)
Bug 305717, it's possible to put a symbolic link to /Applications in the disk
image.  Although it's a neat idea, I think (and other seem to agree) that the
utility of having the Applications icon appear in the disk image is outweighed
by the confusion that would result when less savvy users "discover" that a good
chunk of their hard drives' contents are distributed with Firefox.  (Kinda
justifies the comparatively huge Mac download size, huh?)

There's also localization impact when a symlink is used: /Applications isn't
displayed as "Applications" in each locale.  (I suppose this problem could be
avoided by naming the link " ".)
(In reply to comment #47)
> Bug 305717, it's possible to put a symbolic link to /Applications in the disk
> image.  Although it's a neat idea, I think (and other seem to agree) that the
> utility of having the Applications icon appear in the disk image is outweighed
> by the confusion that would result when less savvy users "discover" that a good
> chunk of their hard drives' contents are distributed with Firefox.  (Kinda
> justifies the comparatively huge Mac download size, huh?)

Good point. users shouldnt be able to see their /Applications there, just drag
it there and i dont think that there is any way to make this Link Write-Only.
(or otherwise they could think: "Why are my Apps there in the Firefox DMG? is
mozilla spying on me?)

btw: i really like those Backgrounds!

There is just a small concern: Would clueless people drag the Firefox icon to
the Place where the App Symbol is?

An other Idea (probably total unrelated): Firefox need write permission for the
first start. would it be possible to add enough space to the DMG to allow
firefox to write the files it needs to write, so people could run FireFox from
within the .dmg? (i dont know if this is really a good idea)
Firefox 1.5 and trunk should *not* need write access for first start, and should
be able to run from a readonly DMG directly (even though it isn't recommended).
If that doesn't work, we need to figure out why.
It does work - 1.5 releases will run directly from any read-only location,
including the distribution dmg.
Whiteboard: [ETA 09/02] → [ETA 09/02][needs review beltzner]
Attachment #194959 - Flags: review?(mike) → review+
Attachment #194960 - Flags: review?(mike) → review+
r=mike.

I think that these an a big improvement over what we have now. We can refine
them if we get any significant amount of confusion about the applications folder
in the graphic not being "live".

 (possible refinements: draw a "finder" window around the applications folder;
put numerals on each step to clarify the idea of the graphic being instructions,
etc.
Comment on attachment 194959 [details]
Firefox background, l10n-free

Checked in to trunk, requesting branch approval.

(It would have been nice to roll with the new artwork for b1, but it's closed
now.)
Attachment #194959 - Flags: approval1.8b5?
Attachment #194960 - Flags: approval1.8b5?
Further refinements, if any, should be in a new bug, please.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
(In reply to comment #53)
> Further refinements, if any, should be in a new bug, please.

Bug 305717 seems to be a likely candidate :)
Attachment #194959 - Flags: approval1.8b5? → approval1.8b5+
Attachment #194960 - Flags: approval1.8b5? → approval1.8b5+
I just landed this on the branch, look for it in an 0913 nightly.
Keywords: fixed1.8
I've just looked at the localized builds (Dutch and Norwegian) of RC3, and the localized builds do NOT have this included.

Reopen? Change KEYWORD as this is NOT fixed on 1.8/FF1.5? Add localization dependency? 
CC:ing benjamin
Depends on: 318043
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.