Closed Bug 283987 Opened 18 years ago Closed 18 years ago

No warning when closing multiple tabs in full screen (close button)

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: guiverunit, Assigned: Mook)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050227 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050227 Firefox/1.0+

the confirm close warning doesn't appear when you push the close button, it
works with alt+f4

Reproducible: Always

Steps to Reproduce:
1.open 2 or more tabs
2.go into full screen
3.push close button

Actual Results:  
closes without confirm close warning

Expected Results:  
shown confirm close warning
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

I'm not seeing a "close window button" in fullscreen mode (no titlebar)
Alt-F4 and ctrl+shift+W are the only ways I can close it and they both cause the
close dialog to show.
(In reply to comment #1)
> I'm not seeing a "close window button" in fullscreen mode (no titlebar)

top right, the x
That's just to close 1 tab at the time
Attached image screen shot
this might make it clearer
The close button (id="close-button") uses "window.close();".
If I change it to "goQuitApplication();" it shows the confirm close dialog
Actually "BrowserTryToCloseWindow()" is better
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050228 Firefox/1.0+

Pressing the close button in fullscreen shuts down Firefox without any dialog.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This does seem to fix this (using the same method File -> Close Window uses). 
Patch as described by Kieran Britton in comment #5 and comment #6, but in CVS
diff form so it can be reviewed.

(I don't think any of us have CVS privs; mconnor, if this gets r+, please check
in for us; thanks.  Assuming no sr for browser.)
Attachment #178849 - Flags: review?(mconnor)
*** Bug 288772 has been marked as a duplicate of this bug. ***
Summary: no warning when closing multiple tabs in full screen → No warning when closing multiple tabs in full screen (close button)
Attachment #178849 - Flags: review?(mconnor) → review+
Attachment #178849 - Flags: approval-aviary1.1a1?
Comment on attachment 178849 [details] [diff] [review]
Patch as described by Kieran Britton in comment #5 #6

a=asa
Attachment #178849 - Flags: approval-aviary1.1a1? → approval-aviary1.1a1+
Assignee: bugs → mook.moz
Checking in browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.261; previous revision: 1.260
done
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox1.1
*** Bug 294797 has been marked as a duplicate of this bug. ***
*** Bug 296472 has been marked as a duplicate of this bug. ***
*** Bug 296548 has been marked as a duplicate of this bug. ***
(In reply to comment #14)
> *** Bug 296548 has been marked as a duplicate of this bug. ***

This bug has not been resolved as of Firefox 1.0.4. Is there a timeline as to
when this will be implemented?
(In reply to comment #15)
> This bug has not been resolved as of Firefox 1.0.4. Is there a timeline as to
> when this will be implemented?

This was fixed after 1.0.4, it will be working as expected in Firefox 1.1
*** Bug 297659 has been marked as a duplicate of this bug. ***
*** Bug 258091 has been marked as a duplicate of this bug. ***
*** Bug 303667 has been marked as a duplicate of this bug. ***
*** Bug 304618 has been marked as a duplicate of this bug. ***
*** Bug 306357 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.