Closed Bug 284245 Opened 15 years ago Closed 15 years ago

Richedit/designMode not working anymore at blogger.com

Categories

(Core :: Editor, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: jst)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, testcase, top500)

Attachments

(3 files, 1 obsolete file)

Creating a new post or editing a post, using the richedit control, doesn't work
anymore at http://www.blogger.com for recent trunk Mozilla builds.
It works in 2005-02-23 trunk builds.
It doesn't work in 2005-02-23 trunk builds.
I believe the fix for bug 209020 introduced this.
I'll attach a testcase which -I think- shows basically what the problem is here:

- Press button 1. -> Designmode is now on (that works)
- Press button 2. -> Designmode doesn't work anymore (this is also the case with
2005-02-23 builds and before, see bug 277787)
- Press button 1. -> Designmode still doesn't work (but this worked with
2005-02-23 builds and before)

Sidenote: 
Pressing button 3 and then pressing button 1 makes the designmode work again.

Extra sidenote: 
Pressing button 4 after the three (or only the first two) steps I mentioned
earlier gives a strange effect.
The whole screen area is not updated anymore, the area where the alert has been
stays white. When you cover the whole window with another window and then you
return, the whole content area has turned white.
Attached file Testcase
Er, I meant "It doesn't work in 2005-02-24 trunk builds."
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

Testcase, button 1&3: Error: uncaught exception: [Exception... "Component
returned failure code: 0x80004005 (NS_ERROR_FAILURE)
[nsIDOMNSHTMLDocument.designMode]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
location: "JS frame :: https://bugzilla.mozilla.org/attachment.cgi?id=175927 ::
onclick :: line 1"  data: no]

Button 2 works :/ no others..
Ah, right... In this case we tear down and recreate the presshell, but the
document still thinks it's in designMode.... 
Blocks: 209020
Flags: blocking1.8b2?
This richedit editor probably also suffers from this bug:
http://www.dynarch.com/demos/htmlarea/examples/core.html
Confirmed also on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050228 Firefox/1.0+

So please change OS->ALL
Flags: blocking-aviary1.1?
To jst to sort out....
Assignee: mozeditor → jst
Changing OS to all
and yes I have the same problem with
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050302
Firefox/1.0+
OS: Windows 2000 → All
Hardware: PC → All
Keywords: top500
*** Bug 285583 has been marked as a duplicate of this bug. ***
Attached file Testcase2 (obsolete) —
Slightly different testcase. This testcase does doc.write('<html>etc') after
designMode is set.
This also worked before the checkin for bug 209020.
This is probably the situation for the htmlarea wysiwyg system.
*** Bug 287679 has been marked as a duplicate of this bug. ***
*** Bug 287853 has been marked as a duplicate of this bug. ***
This bug is likely related to (and may be caused by the same thing as) bug #283897.
Depends on: 283897
*** Bug 288440 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.1? → blocking-aviary1.1+
I think the patch for bug 289179 may have fixed this problem. Certainly
Testcase2 seems to work now.
More likely, the patch for bug 283897 did.
Comment on attachment 177785 [details]
Testcase2

Yes, testcase2 works now (which was basically bug 284245), but the first
testcase not.
Attachment #177785 - Attachment is obsolete: true
Depends on: 277787
I've just tried and it still won't work at blogger.com

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050413
Firefox/1.0+
Attached image screenshot1
With the testcase when I click the button 'try_execcommand_else_alert' and on
blogger.com when trying to select a font I get a pop error similiar to this. To
the attachment screenshot1. Before I would just get weird issues with trying to
type but no popup message.

The error is @ [nsIDOMNSHTMLDocument.execCommand] caused by
http://www.blogger.com/app/scripts/richedit.toolbars.js
*** Bug 293838 has been marked as a duplicate of this bug. ***
Flags: blocking1.8b3+
Flags: blocking1.8b2?
Flags: blocking1.8b2-
*** Bug 295992 has been marked as a duplicate of this bug. ***
Attached patch Fix.Splinter Review
This patch makes us re-initialize the editor when a [i]frame where midas is
enabled is displayed again after being hidden (or after its frame has been
re-created for whatever reason).
Attachment #186969 - Flags: superreview?(dbaron)
Attachment #186969 - Flags: review?(dbaron)
Attachment #186969 - Flags: superreview?(dbaron)
Attachment #186969 - Flags: superreview+
Attachment #186969 - Flags: review?(dbaron)
Attachment #186969 - Flags: review+
Attachment #186969 - Flags: approval1.8b3?
Attachment #186969 - Flags: approval1.8b3? → approval1.8b3+
Fixed.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Blocks: 217205
QA Contact: bugzilla → nobody
Summary: Richedit/designMode not working anymore at blogger.com → Richedit/designMode not working anymore at blogger.com
Status: RESOLVED → VERIFIED
Blocks: 348802
Depends on: 430800
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.