Extensions no longer work in trunk builds

VERIFIED FIXED

Status

()

Toolkit
Add-ons Manager
--
major
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: mossop, Assigned: Benjamin Smedberg)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Since the nightly of 16th August, all extensions have stopped working on trunk
builds of Firefox. This is before the version was changed.

No extension changes are visible. Opening the extension manager logs numerous of
the following messages as it fails to find the icon for each extension: 

No chrome package registered for chrome://flashgot/skin/icon32.png .

Clicking options for an extension displays the same error.

A new profile does not resolve the problem.

Updated

13 years ago
Severity: normal → major
Flags: blocking1.8b4?

Comment 1

13 years ago
My extensions fail silently, no message, icon shows as normal. But when i do
right click and select options nothing happens and i can't close the extension
manager without atl+ctrl+del and ending the task that way.

20050816 daily trunk build
(Reporter)

Comment 2

13 years ago
This isn't on branch so blocking 1.9a1 is more likely.
Flags: blocking1.8b4? → blocking1.9a1?
(Assignee)

Comment 3

13 years ago
If this was caused by bug 299992, it should be trunk-only (299992 is not on the
branch at this point). Is this visible only on trunk?
(Reporter)

Comment 4

13 years ago
*** Bug 304878 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
I can confirm this behavior on my trunk build from this morning. Had to create a
new profile even because Firefox, even after a system reboot, insisted my other
profiles were in use. 
(Assignee)

Comment 7

13 years ago
When were these builds produced? There was a time yesterday when the windows
builds were orange, but the checkin to nsINIParser.cpp at 2005-08-15 15:13 fixed
that and should have fixed the problem with the profile manager.

Comment 8

13 years ago
Possibly related bugs or part of the cure, for reference:

Bugzilla Bug 304472 bump Firefox version on trunk to 1.6a1
Bugzilla Bug 300731 change app/extension version scheme going forward
Bugzilla Bug 304476 remove app.extensions.version from firefox.js on Mozilla 1.8
branch

Comment 9

13 years ago
(In reply to comment #1)
> My extensions fail silently, no message, icon shows as normal. But when i do
> right click and select options nothing happens and i can't close the extension
> manager without atl+ctrl+del and ending the task that way.
> 
> 20050816 daily trunk build

I had the same issue with the Extensions window as well. All my extensions are
dead expect for ForwardFork because I installed it manually with a file linking
to a directory instead of an XPI package.

Hence, it seems that this issue only occurs with XPI installed extensions, and
not the file-linking way. Can this behavior be confirmed?
304472 has absolutely nothing to do with this. im using 2005081607 which was
built before 304472 was checked in, and extensions still fail for me.
(Reporter)

Comment 11

13 years ago
Nightly build started at 7am. Just tried the latest trunk (started 15:50) and it
still exhibits the problem.

As I said in the original comment, this is before the 1.6a1 change was checked
in and the trunk has certainly been working since the version comparator
changes. bug 304476 seems to be branch only so I dont see that applying here.

Comment 12

13 years ago
I have tried adapting my theme to firefox trunk zipbuild 2005-08-16-1932. I
first tested this with a jarfile version of SphereGnome with maxversions set to
1.6, 1.6+ and 1.6a1. The browser refused to accept all of them, saying they were
not compatible with Deer park.

I next tried a development workhorse version of SphereGnome. The chrome.manifest
refers to directories, not jarfile entries. It is installed by planting the
folder in the extensions directory of the test profile (the profile name was
modified to Test_Profile, just to make sure there were no problems). I then
experimented with maxversions of 1.0, 1.0+, 1.5, etc. All failed. 

The browser displays the entry in the themes list, but the listing says it will
be updated the next time the browser is restarted. This last I find interesting.
The browser, at one level, has accepted the theme as valid.

Comment 13

13 years ago
Yeap all are dead. :(

Comment 14

13 years ago
confirming: 
Nighlty Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050816
Firefox/1.0+ 
No extensions working.
Extension manager freezes when trying to click on OPTIONS.

Comment 15

13 years ago
Confirming the problem on Mac OS X 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050816
Firefox/1.6a1

Updated

13 years ago
OS: Windows XP → All

Comment 16

13 years ago
Confirmed: Custom Themes/Extensions not working.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050816
Firefox/1.6a1  Hourly Build  : 19.25 (PDT) 

This appeared in js console

"ExtensionManager:_finishOperations - failure, catching exception -line no:6092- 
file: undefined - [Exception... "Component returned failure code: 0x80004003 
(NS_ERROR_INVALID_POINTER) [nsIRDFDataSource.Assert]"  nsresult: "0x80004003 
(NS_ERROR_INVALID_POINTER)"  location: "JS frame :: 
file:///D:/APPS-F~1/P-T-1.6/firefox/components/nsExtensionManager.js :: 
anonymous :: line 6092"  data: no]"

....and this error

"No chrome package registered for chrome://navigator/locale/navigator.
properties."

"No chrome package registered for
chrome://navigator-region/locale/region.properties."

"No chrome package registered for
chrome://communicator-region/locale/region.properties."
(Reporter)

Comment 17

13 years ago
*** Bug 304923 has been marked as a duplicate of this bug. ***
On Win32 I created a new profile directory without spaces in the path to it
(e.g. c:\profilename) and extensions worked. I tested this successfully with a
new and an existing profile that I moved and edited profiles.ini - in the case
of the existing profile I had to delete extensions.ini so it would be generated
with the new paths.
(Reporter)

Comment 19

13 years ago
Just tried what Rob suggested and still extensions would not work, this is with
build 2005081700.
bug #302136 could be causing this. its only been applied to the trunk (this
problem is only on the trunk). check comment 17 on that bug.

Comment 21

13 years ago
(In reply to comment #19)
> Just tried what Rob suggested and still extensions would not work, this is with
> build 2005081700.
> 
Change paths not only profile directory but also firefox's directory.

I can confirm Rob's suggestion.
BuildID: 2005081600


(In reply to comment #20)
> bug #302136 could be causing this. its only been applied to the trunk (this
> problem is only on the trunk). check comment 17 on that bug.
No.
I know 2005081511/pacifica-trunk does not have this problem, and 2005081516 has.
The builds I'm debugging it with have no spaces in their paths... it makes sense
this would be necessary. It appears that nsINIParser is only returning the text
up to the first space in ini files so I highly suspect bug 299992 caused this.
(Reporter)

Comment 24

13 years ago
After some more experimentation it seems that if you use the nightly build and
have the profile in a dir without spaces it does work fine. Having the program
in a dir with spaces doesnt seem to make any difference.

I still cannot get extensions to work in newer builds, but I suspect that may be
a different issue to do with the version update.
The simplest way to see that ini parsing has changed is to create a new pofile
that has a name with a space in it (e.g. Default User). After creating it launch
Firefox, exit, and then launch the profilemanager. The name will no longer
contain the text from the space to the end of the original name in the profile
manager. It also truncates the name in profiles.ini.
Blocks: 299992
(Assignee)

Comment 27

13 years ago
Created attachment 192932 [details] [diff] [review]
Don't strtok on whitespace, only strspnp
Attachment #192932 - Flags: review?(shaver)

Comment 28

13 years ago
(In reply to comment #27)
> Created an attachment (id=192932) [edit]
> Don't strtok on whitespace, only strspnp
> 

build finished a few minutes ago and the patch works for me
we need to get this checked in quickly. with an emphasis on quickly. ive gotten
so used to extensions (especially nightly tester tools), i feel crippled without
them.

Comment 30

13 years ago
8/17/2005

Applied the patch, rebuilt, extensions installing again. 

Comment 31

13 years ago
Referring to my comment #16;

Previously i reported about the js console error show up in FF and others
reported in EM, native extensions came with FF Talkback,Reporter and DoMi still
show even after restart DP "...will be installed when DeerPark Restart". I
suspect its related.

(Without this patch) After doing some experimental, above problem solved, and i
can installed Skypilot Theme + 5 extensions and its worked fine this included
BuildID Copier :).

Steps:

1).Creating new profile (following Robert Strong aka w.o.o.m suggestion)
2).Looks in FF application folder (extensions) for Reporter, Talkback and DoMi
3).Find install.rdf, adding min/maxVersion for TB to 1.6a1, which are blank or
missing since 16th builds.
4).Same method apply to themes/extensions but both lines adding 1.6a1 for FF/TB.
4).Launch FF
5).Install Themes/Extensions (modified) and restart FF. Everything should work
properly. At least for me.

Hope this will help.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050817
Firefox/1.6a1 ID:2005081716

i already bumped my extensions. still no joy. "... will be installed after dear
park is restarted"
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1 ID:2005081804

Even if I run Firefox this way from the commandline: "C:\firefox\firefox.exe"
-profile "C:\profile", extensions located in the profile don't work. They show
up normally in the EM, listed as if they were working.

But only global extensions actually work.

In branch I have no problem at all with the same extensions.

Comment 34

13 years ago
Comment on attachment 192932 [details] [diff] [review]
Don't strtok on whitespace, only strspnp

is the comment:
copied from toolkit/mozapps/updater/src/updater/updater.cpp still correct?

Nit... Since these are your functions, names like "mstrspnp" sucks.

if delims is ever null we will crash.

Doug
(Assignee)

Comment 35

13 years ago
Comment on attachment 192932 [details] [diff] [review]
Don't strtok on whitespace, only strspnp

Don't worry about the function names, I'm going to move them soon and give them
real NS_names. I think that the comment should remain, at least as a licensing
reminder. And delims must not be null (it's almost always a literal string).
Attachment #192932 - Flags: review?(shaver) → review?(dougt)

Comment 36

13 years ago
Comment on attachment 192932 [details] [diff] [review]
Don't strtok on whitespace, only strspnp

s/copied from/based on
Attachment #192932 - Flags: review?(dougt) → review+
(Assignee)

Comment 37

13 years ago
Fixed on trunk. This patch will go into the 1.8 branch with the rest of 299992.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 38

13 years ago
Has this landed on Pacifica yet?  Bonsai says so, but this bug still exists as
blatantly as it did on every other build before it.

Comment 39

13 years ago
Please be patient. The checkin is only 50 minutes ago.
And see http://tinderbox.mozilla.org/Firefox/
patch doesnt fix it. extensions still dont work and profile names are still
truncated. round two anyone?
(Reporter)

Comment 41

13 years ago
Looking at the logs of the first pacifica build that should have had the patch,
the cvs checkout failed so the patch wasnt included.

Comment 42

13 years ago
In Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1, my test version of SphereGnome has this in the install.rdf:

        <em:minVersion>1.0+</em:minVersion>
        <em:maxVersion>1.6+</em:maxVersion>

The browser came up with the theme in all its glory.

It is true that I had placed the theme with an earlier build that didn't work,
so I don't know yet if you can actually install a theme or extension. But this
one does work.

Comment 43

13 years ago
BTW--the build I am using was timestamped 2005-08-18 1942.

I have just  gone in and bumped All-in-One gestures 0.16 and Toolbar
Enhancements 0.16.2 to maxversion 1.6+. Both installed nomrally and are working
just fine.

Comment 44

13 years ago
Nice to see that:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1 ID:2005081816

Kinda works. A few existions work again like Javscript Options and Nightly
Tester tools. Though all others are still broke. Same errors in javascript
console though like:

No chrome package registered for chrome://cookieui/skin/icon.jpg .
*** Bug 304970 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a1?
This is repaired for me now.

Comment 47

13 years ago
Verified to work on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050818
Firefox/1.6a1 ID:2005081821

For this still having problems, you need to change modify the install.rdf of
every extension so maxVersion is set to 1.6a and and remove extensions.rdf.


f
Status: RESOLVED → VERIFIED
(Assignee)

Comment 48

13 years ago
*** Bug 305197 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 49

13 years ago
*** Bug 304935 has been marked as a duplicate of this bug. ***

Comment 50

13 years ago
Except the greasemonkey extension all other extensions worked with this new builds.

Had to change maxversion to 1.6+ for all the extensions (Adblock,gmail notifier,
cache fixer, adblock filterset.g, smoothwheel)

However greasemonkey would install but not work !! It used to do on the branch
builds rv:1.8b4

Comment 51

13 years ago
Except the greasemonkey extension all other extensions worked with this new builds.

Had to change maxversion to 1.6+ for all the extensions (Adblock,gmail notifier,
cache fixer, adblock filterset.g, smoothwheel)

However greasemonkey would install but not work !! It used to do on the branch
builds rv:1.8b4
*** Bug 305539 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.